aboutsummaryrefslogtreecommitdiffstats
path: root/tools/bison/Makefile
diff options
context:
space:
mode:
Diffstat (limited to 'tools/bison/Makefile')
-rw-r--r--tools/bison/Makefile30
1 files changed, 30 insertions, 0 deletions
diff --git a/tools/bison/Makefile b/tools/bison/Makefile
new file mode 100644
index 0000000..b8ad32c
--- /dev/null
+++ b/tools/bison/Makefile
@@ -0,0 +1,30 @@
+#
+# Copyright (C) 2008-2015 OpenWrt.org
+#
+# This is free software, licensed under the GNU General Public License v2.
+# See /LICENSE for more information.
+#
+include $(TOPDIR)/rules.mk
+
+PKG_NAME:=bison
+PKG_VERSION:=3.0.4
+
+PKG_SOURCE:=$(PKG_NAME)-$(PKG_VERSION).tar.xz
+PKG_SOURCE_URL:=@GNU/$(PKG_NAME)
+PKG_MD5SUM:=c342201de104cc9ce0a21e0ad10d4021
+
+HOST_BUILD_PARALLEL:=1
+
+include $(INCLUDE_DIR)/host-build.mk
+
+define Host/Clean
+ -$(MAKE) -C $(HOST_BUILD_DIR) uninstall
+ $(call Host/Clean/Default)
+endef
+
+define Host/Install
+ $(call Host/Install/Default)
+ $(INSTALL_BIN) ./scripts/yacc $(STAGING_DIR_HOST)/bin/yacc
+endef
+
+$(eval $(call HostBuild))