aboutsummaryrefslogtreecommitdiffstats
path: root/target/linux/sunxi/Makefile
diff options
context:
space:
mode:
Diffstat (limited to 'target/linux/sunxi/Makefile')
-rw-r--r--target/linux/sunxi/Makefile32
1 files changed, 32 insertions, 0 deletions
diff --git a/target/linux/sunxi/Makefile b/target/linux/sunxi/Makefile
new file mode 100644
index 0000000..fe18fc3
--- /dev/null
+++ b/target/linux/sunxi/Makefile
@@ -0,0 +1,32 @@
+#
+# Copyright (C) 2013-2014 OpenWrt.org
+#
+# This is free software, licensed under the GNU General Public License v2.
+# See /LICENSE for more information.
+#
+
+include $(TOPDIR)/rules.mk
+
+ARCH:=arm
+BOARD:=sunxi
+BOARDNAME:=Allwinner A1x/A20/A3x
+FEATURES:=fpu usb ext4 display rtc
+CPU_TYPE:=cortex-a8
+CPU_SUBTYPE:=vfpv3
+MAINTAINER:=Zoltan HERPAI <wigyori@uid0.hu>
+
+KERNEL_PATCHVER:=4.1
+KERNELNAME:=zImage dtbs
+
+# A10: Cortex-A8
+# A13: Cortex-A8
+# A20: dual Cortex-A7
+# A31: quad Cortex-A7
+# A80: octa Cortex-A15/A7
+# H3: quad Cortex-A7
+
+include $(INCLUDE_DIR)/target.mk
+
+DEFAULT_PACKAGES += uboot-envtools kmod-eeprom-sunxi kmod-wdt-sunxi
+
+$(eval $(call BuildTarget))