aboutsummaryrefslogtreecommitdiffstats
path: root/target/linux/mvebu/Makefile
diff options
context:
space:
mode:
Diffstat (limited to 'target/linux/mvebu/Makefile')
-rw-r--r--target/linux/mvebu/Makefile25
1 files changed, 25 insertions, 0 deletions
diff --git a/target/linux/mvebu/Makefile b/target/linux/mvebu/Makefile
new file mode 100644
index 0000000..5b09285
--- /dev/null
+++ b/target/linux/mvebu/Makefile
@@ -0,0 +1,25 @@
+#
+# Copyright (C) 2012-2015 OpenWrt.org
+#
+# This is free software, licensed under the GNU General Public License v2.
+# See /LICENSE for more information.
+#
+include $(TOPDIR)/rules.mk
+
+ARCH:=arm
+BOARD:=mvebu
+BOARDNAME:=Marvell Armada 37x/38x/XP
+FEATURES:=usb pci pcie gpio nand squashfs
+CPU_TYPE:=cortex-a9
+CPU_SUBTYPE:=vfpv3
+MAINTAINER:=Imre Kaloz <kaloz@openwrt.org>
+
+KERNEL_PATCHVER:=3.18
+
+include $(INCLUDE_DIR)/target.mk
+
+KERNELNAME:=zImage dtbs
+
+DEFAULT_PACKAGES += uboot-envtools
+
+$(eval $(call BuildTarget))