aboutsummaryrefslogtreecommitdiffstats
path: root/target/linux/brcm2708/Makefile
diff options
context:
space:
mode:
Diffstat (limited to 'target/linux/brcm2708/Makefile')
-rw-r--r--target/linux/brcm2708/Makefile31
1 files changed, 31 insertions, 0 deletions
diff --git a/target/linux/brcm2708/Makefile b/target/linux/brcm2708/Makefile
new file mode 100644
index 0000000..f8c9347
--- /dev/null
+++ b/target/linux/brcm2708/Makefile
@@ -0,0 +1,31 @@
+#
+# Copyright (C) 2012-2015 OpenWrt.org
+#
+# This is free software, licensed under the GNU General Public License v2.
+# See /LICENSE for more information.
+#
+include $(TOPDIR)/rules.mk
+include $(INCLUDE_DIR)/host.mk
+
+ARCH:=arm
+BOARD:=brcm2708
+BOARDNAME:=Broadcom BCM2708/BCM2709
+FEATURES:=ext4 audio usb usbgadget display gpio
+MAINTAINER:=Florian Fainelli <florian@openwrt.org>
+CPU_TYPE:=arm1176jzf-s
+CPU_SUBTYPE:=vfp
+SUBTARGETS:=bcm2708 bcm2709
+
+KERNEL_PATCHVER:=4.1
+
+include $(INCLUDE_DIR)/target.mk
+DEFAULT_PACKAGES += brcm2708-gpu-fw kmod-usb-hid kmod-sound-core kmod-sound-arm-bcm2835 kmod-fs-vfat kmod-nls-cp437 kmod-nls-iso8859-1
+
+define Target/Description
+ Build firmware image for Broadcom BCM2708/BCM2709 SoC devices.
+ Currently produces SD Card image for Raspberry Pi.
+endef
+
+KERNELNAME:=Image dtbs
+
+$(eval $(call BuildTarget))