aboutsummaryrefslogtreecommitdiffstats
path: root/tools/gengetopt
diff options
context:
space:
mode:
authorJames <>2015-11-04 11:49:21 +0000
committerJames <>2015-11-04 11:49:21 +0000
commit716ca530e1c4515d8683c9d5be3d56b301758b66 (patch)
tree700eb5bcc1a462a5f21dcec15ce7c97ecfefa772 /tools/gengetopt
downloadtrunk-47381-716ca530e1c4515d8683c9d5be3d56b301758b66.tar.gz
trunk-47381-716ca530e1c4515d8683c9d5be3d56b301758b66.tar.bz2
trunk-47381-716ca530e1c4515d8683c9d5be3d56b301758b66.zip
trunk-47381HEADmaster
Diffstat (limited to 'tools/gengetopt')
-rw-r--r--tools/gengetopt/Makefile30
-rw-r--r--tools/gengetopt/patches/100-dependency_fix.patch11
-rw-r--r--tools/gengetopt/patches/200-no_docs_tests.patch13
3 files changed, 54 insertions, 0 deletions
diff --git a/tools/gengetopt/Makefile b/tools/gengetopt/Makefile
new file mode 100644
index 0000000..74e528e
--- /dev/null
+++ b/tools/gengetopt/Makefile
@@ -0,0 +1,30 @@
+#
+# Copyright (C) 2014 OpenWrt.org
+#
+# This is free software, licengengetopt under the GNU General Public License v2.
+# See /LICENSE for more information.
+#
+include $(TOPDIR)/rules.mk
+
+PKG_NAME:=gengetopt
+PKG_VERSION:=2.22.6
+
+PKG_SOURCE:=$(PKG_NAME)-$(PKG_VERSION).tar.gz
+PKG_SOURCE_URL:=@GNU/$(PKG_NAME)
+PKG_MD5SUM:=29749a48dda69277ab969c510597a14e
+
+HOST_FIXUP := autoreconf
+
+HOST_BUILD_PARALLEL:=1
+
+include $(INCLUDE_DIR)/host-build.mk
+
+define Host/Install
+ $(INSTALL_BIN) $(HOST_BUILD_DIR)/src/gengetopt $(STAGING_DIR_HOST)/bin/
+endef
+
+define Host/Clean
+ rm -f $(STAGING_DIR_HOST)/bin/gengetopt
+endef
+
+$(eval $(call HostBuild))
diff --git a/tools/gengetopt/patches/100-dependency_fix.patch b/tools/gengetopt/patches/100-dependency_fix.patch
new file mode 100644
index 0000000..69cb598
--- /dev/null
+++ b/tools/gengetopt/patches/100-dependency_fix.patch
@@ -0,0 +1,11 @@
+--- a/src/Makefile.am
++++ b/src/Makefile.am
+@@ -51,7 +51,7 @@ libgengetopt_la_LIBADD = $(top_builddir)
+ @LTLIBOBJS@ \
+ skels/libgen.la
+
+-LDADD = $(top_builddir)/src/libgengetopt.la
++LDADD = libgengetopt.la
+
+ EXTRA_DIST = parser.h argsdef.h gengetopt.h ggos.h gm.h gnugetopt.h \
+ cmdline.c cmdline.h \
diff --git a/tools/gengetopt/patches/200-no_docs_tests.patch b/tools/gengetopt/patches/200-no_docs_tests.patch
new file mode 100644
index 0000000..d393069
--- /dev/null
+++ b/tools/gengetopt/patches/200-no_docs_tests.patch
@@ -0,0 +1,13 @@
+diff -urN gengetopt-2.22.6/Makefile.am gengetopt-2.22.6.new/Makefile.am
+--- gengetopt-2.22.6/Makefile.am 2012-11-02 06:26:54.000000000 -0700
++++ gengetopt-2.22.6.new/Makefile.am 2015-05-21 17:43:15.183083542 -0700
+@@ -18,6 +18,6 @@
+ ACLOCAL_AMFLAGS = -I m4 -I gl/m4
+
+ EXTRA_DIST = configure TODO LICENSE gl/m4/gnulib-cache.m4
+-SUBDIRS = gl src doc tests
++SUBDIRS = gl src
+
+-gengetoptdoc_DATA = ChangeLog COPYING NEWS THANKS INSTALL README LICENSE
+\ No newline at end of file
++gengetoptdoc_DATA = ChangeLog COPYING NEWS THANKS INSTALL README LICENSE