aboutsummaryrefslogtreecommitdiffstats
path: root/tools/flex
diff options
context:
space:
mode:
authorJames <>2015-11-04 11:49:21 +0000
committerJames <>2015-11-04 11:49:21 +0000
commit716ca530e1c4515d8683c9d5be3d56b301758b66 (patch)
tree700eb5bcc1a462a5f21dcec15ce7c97ecfefa772 /tools/flex
downloadtrunk-47381-master.tar.gz
trunk-47381-master.tar.bz2
trunk-47381-master.zip
trunk-47381HEADmaster
Diffstat (limited to 'tools/flex')
-rw-r--r--tools/flex/Makefile28
-rw-r--r--tools/flex/patches/100-remove_no_undefined.patch18
2 files changed, 46 insertions, 0 deletions
diff --git a/tools/flex/Makefile b/tools/flex/Makefile
new file mode 100644
index 0000000..0e56ede
--- /dev/null
+++ b/tools/flex/Makefile
@@ -0,0 +1,28 @@
+#
+# Copyright (C) 2008-2014 OpenWrt.org
+#
+# This is free software, licensed under the GNU General Public License v2.
+# See /LICENSE for more information.
+#
+include $(TOPDIR)/rules.mk
+
+PKG_NAME:=flex
+PKG_VERSION:=2.5.39
+
+PKG_SOURCE:=$(PKG_NAME)-$(PKG_VERSION).tar.bz2
+PKG_SOURCE_URL:=@SF/$(PKG_NAME)
+PKG_MD5SUM:=77d44c6bb8c0705e0017ab9a84a1502b
+PKG_CAT:=bzcat
+
+HOST_BUILD_PARALLEL:=1
+
+include $(INCLUDE_DIR)/host-build.mk
+
+HOST_CONFIGURE_ARGS += --disable-shared
+
+define Host/Clean
+ -$(MAKE) -C $(HOST_BUILD_DIR) uninstall
+ $(call Host/Clean/Default)
+endef
+
+$(eval $(call HostBuild))
diff --git a/tools/flex/patches/100-remove_no_undefined.patch b/tools/flex/patches/100-remove_no_undefined.patch
new file mode 100644
index 0000000..4e8aca1
--- /dev/null
+++ b/tools/flex/patches/100-remove_no_undefined.patch
@@ -0,0 +1,18 @@
+--- a/Makefile.am
++++ b/Makefile.am
+@@ -73,13 +73,13 @@ libfl_la_SOURCES = \
+ libmain.c \
+ libyywrap.c
+
+-libfl_la_LDFLAGS = -no-undefined -version-info @SHARED_VERSION_INFO@
++libfl_la_LDFLAGS = -version-info @SHARED_VERSION_INFO@
+
+ libfl_pic_la_SOURCES = \
+ libmain.c \
+ libyywrap.c
+
+-libfl_pic_la_LDFLAGS = -no-undefined -version-info @SHARED_VERSION_INFO@
++libfl_pic_la_LDFLAGS = -version-info @SHARED_VERSION_INFO@
+
+ noinst_HEADERS = \
+ flexdef.h \