aboutsummaryrefslogtreecommitdiffstats
path: root/tools/quilt/.svn
diff options
context:
space:
mode:
Diffstat (limited to 'tools/quilt/.svn')
-rw-r--r--tools/quilt/.svn/entries65
-rw-r--r--tools/quilt/.svn/text-base/Makefile.svn-base39
2 files changed, 104 insertions, 0 deletions
diff --git a/tools/quilt/.svn/entries b/tools/quilt/.svn/entries
new file mode 100644
index 0000000..e8f51fa
--- /dev/null
+++ b/tools/quilt/.svn/entries
@@ -0,0 +1,65 @@
+10
+
+dir
+36060
+svn://svn.openwrt.org/openwrt/trunk/tools/quilt
+svn://svn.openwrt.org/openwrt
+
+
+
+2013-03-07T17:32:29.455175Z
+35900
+nbd
+
+
+
+
+
+
+
+
+
+
+
+
+
+
+3c298f89-4303-0410-b956-a3cf2f4a3e73
+
+patches
+dir
+
+Makefile
+file
+
+
+
+
+2013-03-17T12:13:23.000000Z
+b865dd2456218d9662d273ab82b8466f
+2013-03-07T17:32:29.455175Z
+35900
+nbd
+
+
+
+
+
+
+
+
+
+
+
+
+
+
+
+
+
+
+
+
+
+861
+
diff --git a/tools/quilt/.svn/text-base/Makefile.svn-base b/tools/quilt/.svn/text-base/Makefile.svn-base
new file mode 100644
index 0000000..541e656
--- /dev/null
+++ b/tools/quilt/.svn/text-base/Makefile.svn-base
@@ -0,0 +1,39 @@
+#
+# Copyright (C) 2006 -2010 OpenWrt.org
+#
+# This is free software, licensed under the GNU General Public License v2.
+# See /LICENSE for more information.
+#
+include $(TOPDIR)/rules.mk
+
+PKG_NAME:=quilt
+PKG_VERSION:=0.48
+
+PKG_SOURCE:=$(PKG_NAME)-$(PKG_VERSION).tar.gz
+PKG_SOURCE_URL:=http://download.savannah.gnu.org/releases/$(PKG_NAME)
+PKG_MD5SUM:=f77adda60039ffa753f3c584a286f12b
+
+include $(INCLUDE_DIR)/host-build.mk
+
+HOST_CONFIGURE_ARGS += \
+ --with-find=$(FIND)
+
+define Host/Configure
+ cd $(HOST_BUILD_DIR) && autoconf
+ $(call Host/Configure/Default)
+ [ -f $(HOST_BUILD_DIR)/Makefile ]
+endef
+
+define Host/Compile
+ $(MAKE) -C $(HOST_BUILD_DIR) SHELL="$(BASH)" all lib/backup-files
+endef
+
+define Host/Install
+ $(MAKE) -C $(HOST_BUILD_DIR) SHELL="$(BASH)" install
+endef
+
+define Host/Clean
+ rm -f $(STAGING_DIR_HOST)/bin/quilt
+endef
+
+$(eval $(call HostBuild))