aboutsummaryrefslogtreecommitdiffstats
path: root/tools/mpc
diff options
context:
space:
mode:
Diffstat (limited to 'tools/mpc')
-rw-r--r--tools/mpc/.svn/entries62
-rw-r--r--tools/mpc/.svn/text-base/Makefile.svn-base28
-rw-r--r--tools/mpc/Makefile28
3 files changed, 118 insertions, 0 deletions
diff --git a/tools/mpc/.svn/entries b/tools/mpc/.svn/entries
new file mode 100644
index 0000000..dbd4a22
--- /dev/null
+++ b/tools/mpc/.svn/entries
@@ -0,0 +1,62 @@
+10
+
+dir
+36060
+svn://svn.openwrt.org/openwrt/trunk/tools/mpc
+svn://svn.openwrt.org/openwrt
+
+
+
+2012-09-15T14:17:55.447767Z
+33436
+nbd
+
+
+
+
+
+
+
+
+
+
+
+
+
+
+3c298f89-4303-0410-b956-a3cf2f4a3e73
+
+Makefile
+file
+
+
+
+
+2013-03-17T12:13:23.000000Z
+27c03817f2341cb95225b2f32f3a5eaa
+2012-09-15T14:17:55.447767Z
+33436
+nbd
+
+
+
+
+
+
+
+
+
+
+
+
+
+
+
+
+
+
+
+
+
+619
+
diff --git a/tools/mpc/.svn/text-base/Makefile.svn-base b/tools/mpc/.svn/text-base/Makefile.svn-base
new file mode 100644
index 0000000..adbe33e
--- /dev/null
+++ b/tools/mpc/.svn/text-base/Makefile.svn-base
@@ -0,0 +1,28 @@
+#
+# Copyright (C) 2009-2012 OpenWrt.org
+#
+# This is free software, licensed under the GNU General Public License v2.
+# See /LICENSE for more information.
+#
+include $(TOPDIR)/rules.mk
+
+PKG_NAME:=mpc
+PKG_VERSION:=0.9
+
+PKG_SOURCE_URL:=http://www.multiprecision.org/mpc/download/
+PKG_SOURCE:=$(PKG_NAME)-$(PKG_VERSION).tar.gz
+PKG_MD5SUM:=0d6acab8d214bd7d1fbbc593e83dd00d
+
+HOST_BUILD_PARALLEL:=1
+
+include $(INCLUDE_DIR)/host-build.mk
+
+unexport CFLAGS
+
+HOST_CONFIGURE_ARGS += \
+ --enable-static \
+ --disable-shared \
+ --with-mpfr=$(TOPDIR)/staging_dir/host \
+ --with-gmp=$(TOPDIR)/staging_dir/host
+
+$(eval $(call HostBuild))
diff --git a/tools/mpc/Makefile b/tools/mpc/Makefile
new file mode 100644
index 0000000..adbe33e
--- /dev/null
+++ b/tools/mpc/Makefile
@@ -0,0 +1,28 @@
+#
+# Copyright (C) 2009-2012 OpenWrt.org
+#
+# This is free software, licensed under the GNU General Public License v2.
+# See /LICENSE for more information.
+#
+include $(TOPDIR)/rules.mk
+
+PKG_NAME:=mpc
+PKG_VERSION:=0.9
+
+PKG_SOURCE_URL:=http://www.multiprecision.org/mpc/download/
+PKG_SOURCE:=$(PKG_NAME)-$(PKG_VERSION).tar.gz
+PKG_MD5SUM:=0d6acab8d214bd7d1fbbc593e83dd00d
+
+HOST_BUILD_PARALLEL:=1
+
+include $(INCLUDE_DIR)/host-build.mk
+
+unexport CFLAGS
+
+HOST_CONFIGURE_ARGS += \
+ --enable-static \
+ --disable-shared \
+ --with-mpfr=$(TOPDIR)/staging_dir/host \
+ --with-gmp=$(TOPDIR)/staging_dir/host
+
+$(eval $(call HostBuild))