aboutsummaryrefslogtreecommitdiffstats
path: root/toolchain/musl/.svn
diff options
context:
space:
mode:
Diffstat (limited to 'toolchain/musl/.svn')
-rw-r--r--toolchain/musl/.svn/entries173
-rw-r--r--toolchain/musl/.svn/prop-base/Makefile.svn-base5
-rw-r--r--toolchain/musl/.svn/text-base/Config.in.svn-base24
-rw-r--r--toolchain/musl/.svn/text-base/Config.version.svn-base18
-rw-r--r--toolchain/musl/.svn/text-base/Makefile.svn-base26
-rw-r--r--toolchain/musl/.svn/text-base/common.mk.svn-base68
6 files changed, 314 insertions, 0 deletions
diff --git a/toolchain/musl/.svn/entries b/toolchain/musl/.svn/entries
new file mode 100644
index 0000000..56a0433
--- /dev/null
+++ b/toolchain/musl/.svn/entries
@@ -0,0 +1,173 @@
+10
+
+dir
+36060
+svn://svn.openwrt.org/openwrt/trunk/toolchain/musl
+svn://svn.openwrt.org/openwrt
+
+
+
+2013-02-26T16:40:27.831280Z
+35815
+florian
+
+
+
+
+
+
+
+
+
+
+
+
+
+
+3c298f89-4303-0410-b956-a3cf2f4a3e73
+
+patches-0.9.8
+dir
+
+patches-0.9.9
+dir
+
+Config.version
+file
+
+
+
+
+2013-03-17T12:13:25.000000Z
+9774ee71bfe165b2ba6bbc4f411b0b8f
+2013-02-26T16:40:27.831280Z
+35815
+florian
+
+
+
+
+
+
+
+
+
+
+
+
+
+
+
+
+
+
+
+
+
+300
+
+Config.in
+file
+
+
+
+
+2013-03-17T12:13:25.000000Z
+c010bf2054289c8c760e55991e8b130c
+2013-02-26T16:40:27.831280Z
+35815
+florian
+
+
+
+
+
+
+
+
+
+
+
+
+
+
+
+
+
+
+
+
+
+411
+
+headers
+dir
+
+Makefile
+file
+
+
+
+
+2013-03-17T12:13:25.000000Z
+32c719dba77d2b7b171a6e516d71b85b
+2012-12-10T14:24:24.856323Z
+34598
+florian
+has-props
+
+
+
+
+
+
+
+
+
+
+
+
+
+
+
+
+
+
+
+
+741
+
+common.mk
+file
+
+
+
+
+2013-03-17T12:13:25.000000Z
+a2db7128861dbf2baefc0e9f836781ee
+2013-02-26T16:40:27.831280Z
+35815
+florian
+
+
+
+
+
+
+
+
+
+
+
+
+
+
+
+
+
+
+
+
+
+1750
+
diff --git a/toolchain/musl/.svn/prop-base/Makefile.svn-base b/toolchain/musl/.svn/prop-base/Makefile.svn-base
new file mode 100644
index 0000000..bdbd305
--- /dev/null
+++ b/toolchain/musl/.svn/prop-base/Makefile.svn-base
@@ -0,0 +1,5 @@
+K 13
+svn:eol-style
+V 6
+native
+END
diff --git a/toolchain/musl/.svn/text-base/Config.in.svn-base b/toolchain/musl/.svn/text-base/Config.in.svn-base
new file mode 100644
index 0000000..1d9f3f9
--- /dev/null
+++ b/toolchain/musl/.svn/text-base/Config.in.svn-base
@@ -0,0 +1,24 @@
+# Choose musl version.
+
+choice
+ prompt "musl Version"
+ depends on TOOLCHAINOPTS && USE_MUSL
+ default MUSL_VERSION_0_9_8
+ help
+ Select the version of musl you wish to use.
+
+ config MUSL_VERSION_0_9_8
+ bool "musl 0.9.8"
+
+ config MUSL_VERSION_0_9_9
+ bool "musl 0.9.9"
+
+endchoice
+
+
+# Debug version.
+
+config MUSL_ENABLE_DEBUG
+ bool "Build with debug information"
+ depends on TOOLCHAINOPTS && USE_MUSL
+ default n
diff --git a/toolchain/musl/.svn/text-base/Config.version.svn-base b/toolchain/musl/.svn/text-base/Config.version.svn-base
new file mode 100644
index 0000000..bdefec9
--- /dev/null
+++ b/toolchain/musl/.svn/text-base/Config.version.svn-base
@@ -0,0 +1,18 @@
+config MUSL_VERSION
+ string
+ depends on USE_MUSL
+ default "0.9.8" if MUSL_VERSION_0_9_8
+ default "0.9.9" if MUSL_VERSION_0_9_9
+ default "0.9.8"
+
+if !TOOLCHAINOPTS
+
+ config MUSL_VERSION_0_9_8
+ default y if USE_MUSL
+ bool
+
+ config MUSL_VERSION_0_9_9
+ default y if USE_MUSL
+ bool
+
+endif
diff --git a/toolchain/musl/.svn/text-base/Makefile.svn-base b/toolchain/musl/.svn/text-base/Makefile.svn-base
new file mode 100644
index 0000000..f95bb05
--- /dev/null
+++ b/toolchain/musl/.svn/text-base/Makefile.svn-base
@@ -0,0 +1,26 @@
+PATH_PREFIX=.
+
+include ./common.mk
+
+HOST_STAMP_BUILT:=$(HOST_BUILD_DIR)/.built
+HOST_STAMP_INSTALLED:=$(TOOLCHAIN_DIR)/stamp/.musl_installed
+
+HOST_BUILD_PARALLEL:=1
+
+define Host/SetToolchainInfo
+ $(SED) 's,^\(LIBC_TYPE\)=.*,\1=$(PKG_NAME),' $(TOOLCHAIN_DIR)/info.mk
+ $(SED) 's,^\(LIBC_URL\)=.*,\1=http://www.musl-libc.org/,' $(TOOLCHAIN_DIR)/info.mk
+ $(SED) 's,^\(LIBC_VERSION\)=.*,\1=$(PKG_VERSION),' $(TOOLCHAIN_DIR)/info.mk
+ $(SED) 's,^\(LIBC_SO_VERSION\)=.*,\1=$(LIBC_SO_VERSION),' $(TOOLCHAIN_DIR)/info.mk
+endef
+
+define Host/Compile
+ $(MAKE) $(HOST_JOBS) -C $(HOST_BUILD_DIR) all
+endef
+
+define Host/Install
+ $(call Host/SetToolchainInfo)
+ $(MAKE) -C $(HOST_BUILD_DIR) DESTDIR="$(TOOLCHAIN_DIR)/" install
+endef
+
+$(eval $(call HostBuild))
diff --git a/toolchain/musl/.svn/text-base/common.mk.svn-base b/toolchain/musl/.svn/text-base/common.mk.svn-base
new file mode 100644
index 0000000..342753b
--- /dev/null
+++ b/toolchain/musl/.svn/text-base/common.mk.svn-base
@@ -0,0 +1,68 @@
+#
+# Copyright (C) 2012 OpenWrt.org
+#
+# This is free software, licensed under the GNU General Public License v2.
+# See /LICENSE for more information.
+#
+include $(TOPDIR)/rules.mk
+include $(INCLUDE_DIR)/target.mk
+
+PKG_NAME:=musl
+PKG_VERSION:=$(call qstrip,$(CONFIG_MUSL_VERSION))
+PKG_RELEASE=$(PKG_SOURCE_VERSION)
+
+PKG_SOURCE_VERSION_0.9.8:=e6dcebd5efa2d390f0a24dc11444024e9fd1990c
+PKG_SOURCE_VERSION_0.9.9:=a57ac9bf64ba202bd94d1b81bddd93b850c7b9d6
+
+PKG_SOURCE_PROTO:=git
+PKG_SOURCE_URL:=git://git.musl-libc.org/musl
+PKG_SOURCE_SUBDIR=$(PKG_NAME)-$(PKG_VERSION)
+PKG_SOURCE_VERSION:=$(PKG_SOURCE_VERSION_$(PKG_VERSION))
+PKG_SOURCE:=$(PKG_NAME)-$(PKG_VERSION)-$(PKG_SOURCE_VERSION).tar.gz
+LIBC_SO_VERSION:=$(PKG_VERSION)
+PATCH_DIR:=$(PATH_PREFIX)/patches-$(PKG_VERSION)
+CONFIG_DIR:=$(PATH_PREFIX)/config-$(PKG_VERSION)
+
+HOST_BUILD_DIR:=$(BUILD_DIR_TOOLCHAIN)/$(PKG_NAME)-$(PKG_VERSION)
+
+include $(INCLUDE_DIR)/toolchain-build.mk
+
+MUSL_CONFIGURE:= \
+ $(TARGET_CONFIGURE_OPTS) \
+ CFLAGS="$(TARGET_CFLAGS)" \
+ CROSS_COMPILE="$(TARGET_CROSS)" \
+ $(HOST_BUILD_DIR)/configure \
+ --prefix=/ \
+ --host=$(GNU_HOST_NAME) \
+ --target=$(REAL_GNU_TARGET_NAME) \
+ --disable-gcc-wrapper
+
+ifeq ($(CONFIG_MUSL_ENABLE_DEBUG),y)
+MUSL_CONFIGURE+= \
+ --enable-debug
+endif
+
+define Host/Prepare
+ $(call Host/Prepare/Default)
+ $(if $(strip $(QUILT)), \
+ cd $(HOST_BUILD_DIR); \
+ if $(QUILT_CMD) next >/dev/null 2>&1; then \
+ $(QUILT_CMD) push -a; \
+ fi
+ )
+ ln -snf $(PKG_NAME)-$(PKG_VERSION) $(BUILD_DIR_TOOLCHAIN)/$(PKG_NAME)
+endef
+
+define Host/Configure
+ ( cd $(HOST_BUILD_DIR); rm -f config.cache; \
+ $(MUSL_CONFIGURE) \
+ );
+endef
+
+
+define Host/Clean
+ rm -rf \
+ $(HOST_BUILD_DIR) \
+ $(BUILD_DIR_TOOLCHAIN)/$(PKG_NAME) \
+ $(BUILD_DIR_TOOLCHAIN)/$(LIBC)-dev
+endef