aboutsummaryrefslogtreecommitdiffstats
path: root/target/linux/ramips/.svn
diff options
context:
space:
mode:
Diffstat (limited to 'target/linux/ramips/.svn')
-rw-r--r--target/linux/ramips/.svn/entries154
-rw-r--r--target/linux/ramips/.svn/prop-base/base-files.mk.svn-base5
-rw-r--r--target/linux/ramips/.svn/text-base/Makefile.svn-base28
-rw-r--r--target/linux/ramips/.svn/text-base/base-files.mk.svn-base5
-rw-r--r--target/linux/ramips/.svn/text-base/modules.mk.svn-base26
5 files changed, 218 insertions, 0 deletions
diff --git a/target/linux/ramips/.svn/entries b/target/linux/ramips/.svn/entries
new file mode 100644
index 0000000..bcba209
--- /dev/null
+++ b/target/linux/ramips/.svn/entries
@@ -0,0 +1,154 @@
+10
+
+dir
+36060
+svn://svn.openwrt.org/openwrt/trunk/target/linux/ramips
+svn://svn.openwrt.org/openwrt
+
+
+
+2013-03-15T14:39:51.655286Z
+36039
+juhosg
+
+
+
+
+
+
+
+
+
+
+
+
+
+
+3c298f89-4303-0410-b956-a3cf2f4a3e73
+
+rt288x
+dir
+
+base-files.mk
+file
+
+
+
+
+2013-03-17T12:12:48.000000Z
+439a34f947962b50b671173df48f2bb1
+2011-12-01T22:48:51.084067Z
+29387
+juhosg
+has-props
+
+
+
+
+
+
+
+
+
+
+
+
+
+
+
+
+
+
+
+
+80
+
+files
+dir
+
+image
+dir
+
+rt305x
+dir
+
+base-files
+dir
+
+rt3883
+dir
+
+patches-3.7
+dir
+
+patches-3.8
+dir
+
+Makefile
+file
+
+
+
+
+2013-03-17T12:12:48.000000Z
+831a4f65472c4d0bc1bcd5b13a3ffc50
+2013-03-03T13:57:40.685516Z
+35860
+juhosg
+
+
+
+
+
+
+
+
+
+
+
+
+
+
+
+
+
+
+
+
+
+691
+
+modules.mk
+file
+
+
+
+
+2013-03-17T12:12:48.000000Z
+a6dab0fffd1d26850a8738c7215f228c
+2012-07-25T15:50:42.343981Z
+32864
+florian
+
+
+
+
+
+
+
+
+
+
+
+
+
+
+
+
+
+
+
+
+
+749
+
diff --git a/target/linux/ramips/.svn/prop-base/base-files.mk.svn-base b/target/linux/ramips/.svn/prop-base/base-files.mk.svn-base
new file mode 100644
index 0000000..bdbd305
--- /dev/null
+++ b/target/linux/ramips/.svn/prop-base/base-files.mk.svn-base
@@ -0,0 +1,5 @@
+K 13
+svn:eol-style
+V 6
+native
+END
diff --git a/target/linux/ramips/.svn/text-base/Makefile.svn-base b/target/linux/ramips/.svn/text-base/Makefile.svn-base
new file mode 100644
index 0000000..80cc960
--- /dev/null
+++ b/target/linux/ramips/.svn/text-base/Makefile.svn-base
@@ -0,0 +1,28 @@
+#
+# Copyright (C) 2008-2011 OpenWrt.org
+#
+# This is free software, licensed under the GNU General Public License v2.
+# See /LICENSE for more information.
+#
+include $(TOPDIR)/rules.mk
+
+ARCH:=mipsel
+BOARD:=ramips
+BOARDNAME:=Ralink RT288x/RT3xxx
+SUBTARGETS:=rt288x rt305x rt3883
+CFLAGS:=-Os -pipe -fno-caller-saves -mno-branch-likely
+FEATURES:=squashfs
+
+LINUX_VERSION:=3.7.10
+
+include $(INCLUDE_DIR)/target.mk
+DEFAULT_PACKAGES+=\
+ kmod-leds-gpio kmod-input-core kmod-input-polldev \
+ kmod-input-gpio-keys-polled kmod-button-hotplug \
+ kmod-rt2800-pci wpad-mini swconfig
+
+define Target/Description
+ Build firmware images for Ralink RT288x/RT3xxx based boards.
+endef
+
+$(eval $(call BuildTarget))
diff --git a/target/linux/ramips/.svn/text-base/base-files.mk.svn-base b/target/linux/ramips/.svn/text-base/base-files.mk.svn-base
new file mode 100644
index 0000000..d6682bd
--- /dev/null
+++ b/target/linux/ramips/.svn/text-base/base-files.mk.svn-base
@@ -0,0 +1,5 @@
+define Package/base-files/install-target
+ rm -f $(1)/etc/config/network
+endef
+
+
diff --git a/target/linux/ramips/.svn/text-base/modules.mk.svn-base b/target/linux/ramips/.svn/text-base/modules.mk.svn-base
new file mode 100644
index 0000000..0d29332
--- /dev/null
+++ b/target/linux/ramips/.svn/text-base/modules.mk.svn-base
@@ -0,0 +1,26 @@
+#
+# Copyright (C) 2006-2012 OpenWrt.org
+#
+# This is free software, licensed under the GNU General Public License v2.
+# See /LICENSE for more information.
+#
+
+define KernelPackage/usb-rt305x-dwc_otg
+ TITLE:=RT305X USB controller driver
+ DEPENDS:=@TARGET_ramips_rt305x
+ KCONFIG:= \
+ CONFIG_DWC_OTG \
+ CONFIG_DWC_OTG_HOST_ONLY=y \
+ CONFIG_DWC_OTG_DEVICE_ONLY=n \
+ CONFIG_DWC_OTG_DEBUG=n
+ FILES:=$(LINUX_DIR)/drivers/usb/dwc_otg/dwc_otg.ko
+ AUTOLOAD:=$(call AutoLoad,54,dwc_otg,1)
+ $(call AddDepends/usb)
+endef
+
+define KernelPackage/usb-rt305x-dwc_otg/description
+ This driver provides USB Device Controller support for the
+ Synopsys DesignWare USB OTG Core used in the Ralink RT305X SoCs.
+endef
+
+$(eval $(call KernelPackage,usb-rt305x-dwc_otg))