aboutsummaryrefslogtreecommitdiffstats
path: root/target/linux/lantiq/xway
diff options
context:
space:
mode:
Diffstat (limited to 'target/linux/lantiq/xway')
-rw-r--r--target/linux/lantiq/xway/.svn/entries99
-rw-r--r--target/linux/lantiq/xway/.svn/text-base/config-default.svn-base32
-rw-r--r--target/linux/lantiq/xway/.svn/text-base/target.mk.svn-base10
-rw-r--r--target/linux/lantiq/xway/config-default32
-rw-r--r--target/linux/lantiq/xway/profiles/.svn/entries232
-rw-r--r--target/linux/lantiq/xway/profiles/.svn/text-base/arv.mk.svn-base116
-rw-r--r--target/linux/lantiq/xway/profiles/.svn/text-base/audiocodes.mk.svn-base9
-rw-r--r--target/linux/lantiq/xway/profiles/.svn/text-base/avm.mk.svn-base21
-rw-r--r--target/linux/lantiq/xway/profiles/.svn/text-base/buffalo.mk.svn-base23
-rw-r--r--target/linux/lantiq/xway/profiles/.svn/text-base/lantiq.mk.svn-base27
-rw-r--r--target/linux/lantiq/xway/profiles/.svn/text-base/netgear.mk.svn-base23
-rw-r--r--target/linux/lantiq/xway/profiles/arv.mk116
-rw-r--r--target/linux/lantiq/xway/profiles/audiocodes.mk9
-rw-r--r--target/linux/lantiq/xway/profiles/avm.mk21
-rw-r--r--target/linux/lantiq/xway/profiles/buffalo.mk23
-rw-r--r--target/linux/lantiq/xway/profiles/lantiq.mk27
-rw-r--r--target/linux/lantiq/xway/profiles/netgear.mk23
-rw-r--r--target/linux/lantiq/xway/target.mk10
18 files changed, 853 insertions, 0 deletions
diff --git a/target/linux/lantiq/xway/.svn/entries b/target/linux/lantiq/xway/.svn/entries
new file mode 100644
index 0000000..a72bca0
--- /dev/null
+++ b/target/linux/lantiq/xway/.svn/entries
@@ -0,0 +1,99 @@
+10
+
+dir
+36060
+svn://svn.openwrt.org/openwrt/trunk/target/linux/lantiq/xway
+svn://svn.openwrt.org/openwrt
+
+
+
+2013-03-14T18:43:44.068412Z
+36028
+blogic
+
+
+
+
+
+
+
+
+
+
+
+
+
+
+3c298f89-4303-0410-b956-a3cf2f4a3e73
+
+profiles
+dir
+
+config-default
+file
+
+
+
+
+2013-03-17T12:12:42.000000Z
+b448deb60484b8cb3178becf4cc1dd76
+2012-12-15T01:59:45.206815Z
+34687
+blogic
+
+
+
+
+
+
+
+
+
+
+
+
+
+
+
+
+
+
+
+
+
+739
+
+target.mk
+file
+
+
+
+
+2013-03-17T12:12:42.000000Z
+2c680350d16a8ba76df920b9e6708927
+2012-12-21T20:04:20.238798Z
+34839
+blogic
+
+
+
+
+
+
+
+
+
+
+
+
+
+
+
+
+
+
+
+
+
+177
+
diff --git a/target/linux/lantiq/xway/.svn/text-base/config-default.svn-base b/target/linux/lantiq/xway/.svn/text-base/config-default.svn-base
new file mode 100644
index 0000000..6ee3a3b
--- /dev/null
+++ b/target/linux/lantiq/xway/.svn/text-base/config-default.svn-base
@@ -0,0 +1,32 @@
+CONFIG_ADM6996_PHY=y
+CONFIG_AR8216_PHY=y
+CONFIG_FIRMWARE_IN_KERNEL=y
+CONFIG_INPUT=y
+CONFIG_INPUT_EVDEV=y
+CONFIG_INPUT_POLLDEV=y
+# CONFIG_ISDN is not set
+CONFIG_LEDS_TRIGGER_HEARTBEAT=y
+CONFIG_M25PXX_USE_FAST_READ=y
+CONFIG_MTD_M25P80=y
+CONFIG_MTD_NAND=y
+CONFIG_MTD_NAND_ECC=y
+CONFIG_MTD_NAND_PLATFORM=y
+CONFIG_MTD_NAND_XWAY=y
+# CONFIG_MTD_PHYSMAP_OF is not set
+# CONFIG_MTD_SM_COMMON is not set
+CONFIG_NLS=y
+# CONFIG_PROC_DEVICETREE is not set
+CONFIG_RTL8306_PHY=y
+CONFIG_RTL8366S_PHY=y
+CONFIG_RTL8367B_PHY=y
+CONFIG_RTL8367_PHY=y
+CONFIG_SPI=y
+CONFIG_SPI_BITBANG=y
+CONFIG_SPI_GPIO=y
+CONFIG_SPI_MASTER=y
+CONFIG_SPI_XWAY=y
+CONFIG_USB=y
+CONFIG_USB_COMMON=y
+# CONFIG_USB_EHCI_HCD is not set
+CONFIG_USB_SUPPORT=y
+# CONFIG_USB_UHCI_HCD is not set
diff --git a/target/linux/lantiq/xway/.svn/text-base/target.mk.svn-base b/target/linux/lantiq/xway/.svn/text-base/target.mk.svn-base
new file mode 100644
index 0000000..e725679
--- /dev/null
+++ b/target/linux/lantiq/xway/.svn/text-base/target.mk.svn-base
@@ -0,0 +1,10 @@
+ARCH:=mips
+SUBTARGET:=xway
+BOARDNAME:=XWAY
+FEATURES:=squashfs jffs2 atm
+
+DEFAULT_PACKAGES+=kmod-leds-gpio kmod-gpio-button-hotplug
+
+define Target/Description
+ Lantiq XWAY
+endef
diff --git a/target/linux/lantiq/xway/config-default b/target/linux/lantiq/xway/config-default
new file mode 100644
index 0000000..6ee3a3b
--- /dev/null
+++ b/target/linux/lantiq/xway/config-default
@@ -0,0 +1,32 @@
+CONFIG_ADM6996_PHY=y
+CONFIG_AR8216_PHY=y
+CONFIG_FIRMWARE_IN_KERNEL=y
+CONFIG_INPUT=y
+CONFIG_INPUT_EVDEV=y
+CONFIG_INPUT_POLLDEV=y
+# CONFIG_ISDN is not set
+CONFIG_LEDS_TRIGGER_HEARTBEAT=y
+CONFIG_M25PXX_USE_FAST_READ=y
+CONFIG_MTD_M25P80=y
+CONFIG_MTD_NAND=y
+CONFIG_MTD_NAND_ECC=y
+CONFIG_MTD_NAND_PLATFORM=y
+CONFIG_MTD_NAND_XWAY=y
+# CONFIG_MTD_PHYSMAP_OF is not set
+# CONFIG_MTD_SM_COMMON is not set
+CONFIG_NLS=y
+# CONFIG_PROC_DEVICETREE is not set
+CONFIG_RTL8306_PHY=y
+CONFIG_RTL8366S_PHY=y
+CONFIG_RTL8367B_PHY=y
+CONFIG_RTL8367_PHY=y
+CONFIG_SPI=y
+CONFIG_SPI_BITBANG=y
+CONFIG_SPI_GPIO=y
+CONFIG_SPI_MASTER=y
+CONFIG_SPI_XWAY=y
+CONFIG_USB=y
+CONFIG_USB_COMMON=y
+# CONFIG_USB_EHCI_HCD is not set
+CONFIG_USB_SUPPORT=y
+# CONFIG_USB_UHCI_HCD is not set
diff --git a/target/linux/lantiq/xway/profiles/.svn/entries b/target/linux/lantiq/xway/profiles/.svn/entries
new file mode 100644
index 0000000..f25d232
--- /dev/null
+++ b/target/linux/lantiq/xway/profiles/.svn/entries
@@ -0,0 +1,232 @@
+10
+
+dir
+36060
+svn://svn.openwrt.org/openwrt/trunk/target/linux/lantiq/xway/profiles
+svn://svn.openwrt.org/openwrt
+
+
+
+2013-03-14T18:43:44.068412Z
+36028
+blogic
+
+
+
+
+
+
+
+
+
+
+
+
+
+
+3c298f89-4303-0410-b956-a3cf2f4a3e73
+
+buffalo.mk
+file
+
+
+
+
+2013-03-17T12:12:42.000000Z
+6875b0d9c94a2ec9d65f06a92a6ebc4b
+2012-12-21T20:03:54.671330Z
+34835
+blogic
+
+
+
+
+
+
+
+
+
+
+
+
+
+
+
+
+
+
+
+
+
+619
+
+audiocodes.mk
+file
+
+
+
+
+2013-03-17T12:12:42.000000Z
+4f5ff1464301a3c0275c539b9ba7fe34
+2013-03-12T13:52:54.702628Z
+35990
+blogic
+
+
+
+
+
+
+
+
+
+
+
+
+
+
+
+
+
+
+
+
+
+246
+
+avm.mk
+file
+
+
+
+
+2013-03-17T12:12:42.000000Z
+460669c4a96f3e136de19b1491e35306
+2013-03-14T18:43:44.068412Z
+36028
+blogic
+
+
+
+
+
+
+
+
+
+
+
+
+
+
+
+
+
+
+
+
+
+578
+
+netgear.mk
+file
+
+
+
+
+2013-03-17T12:12:42.000000Z
+f9785dc6168cef67f4e1423a04b65c87
+2012-12-19T15:17:11.568652Z
+34788
+blogic
+
+
+
+
+
+
+
+
+
+
+
+
+
+
+
+
+
+
+
+
+
+594
+
+arv.mk
+file
+
+
+
+
+2013-03-17T12:12:42.000000Z
+b0dc74fcb87c54c74c94ffdb364cbc90
+2013-01-28T17:42:59.772002Z
+35352
+blogic
+
+
+
+
+
+
+
+
+
+
+
+
+
+
+
+
+
+
+
+
+
+3188
+
+lantiq.mk
+file
+
+
+
+
+2013-03-17T12:12:42.000000Z
+ffacd7b426bfe3e7e22b04fec81951e6
+2013-03-14T18:43:44.068412Z
+36028
+blogic
+
+
+
+
+
+
+
+
+
+
+
+
+
+
+
+
+
+
+
+
+
+695
+
diff --git a/target/linux/lantiq/xway/profiles/.svn/text-base/arv.mk.svn-base b/target/linux/lantiq/xway/profiles/.svn/text-base/arv.mk.svn-base
new file mode 100644
index 0000000..a4f11ca
--- /dev/null
+++ b/target/linux/lantiq/xway/profiles/.svn/text-base/arv.mk.svn-base
@@ -0,0 +1,116 @@
+define Profile/ARV4525PW
+ NAME:=Speedport W502V Typ A - ARV4525PW
+ PACKAGES:=kmod-ath5k wpad-mini \
+ kmod-ltq-adsl-danube-mei kmod-ltq-adsl-danube \
+ kmod-ltq-adsl-danube-fw-b kmod-ltq-atm-danube \
+ ltq-adsl-app ppp-mod-pppoa
+endef
+
+$(eval $(call Profile,ARV4525PW))
+
+define Profile/ARV7525PW
+ NAME:=Speedport W303V Typ A - ARV7525PW
+ PACKAGES:=kmod-rt2800-pci wpad-mini \
+ kmod-ltq-adsl-danube-mei kmod-ltq-adsl-danube \
+ kmod-ltq-adsl-danube-fw-b kmod-ltq-atm-danube \
+ ltq-adsl-app ppp-mod-pppoa
+endef
+
+$(eval $(call Profile,ARV7525PW))
+
+define Profile/ARV4518PWR01
+ NAME:=ARV4518PWR01
+ PACKAGES:=kmod-ltq-hcd-danube kmod-ledtrig-usbdev \
+ kmod-ltq-adsl-danube-mei kmod-ltq-adsl-danube \
+ kmod-ltq-adsl-danube-fw-b kmod-ltq-atm-danube \
+ ltq-adsl-app ppp-mod-pppoa \
+ kmod-ath5k wpad-mini \
+ swconfig
+endef
+
+$(eval $(call Profile,ARV4518PWR01))
+
+define Profile/ARV4518PWR01A
+ NAME:=ARV4518PWR01A
+ PACKAGES:=kmod-ltq-hcd-danube kmod-ledtrig-usbdev \
+ kmod-ltq-adsl-danube-mei kmod-ltq-adsl-danube \
+ kmod-ltq-adsl-danube-fw-b kmod-ltq-atm-danube \
+ ltq-adsl-app ppp-mod-pppoa \
+ kmod-ath5k wpad-mini \
+ swconfig
+endef
+
+$(eval $(call Profile,ARV4518PWR01A))
+
+define Profile/ARV4510PW
+ NAME:=Wippies Homebox - ARV4510PW
+ PACKAGES:=kmod-ledtrig-usbdev kmod-usb2 kmod-usb-uhci \
+ kmod-ltq-adsl-danube-mei kmod-ltq-adsl-danube \
+ kmod-ltq-adsl-danube-fw-b kmod-ltq-atm-danube \
+ ltq-adsl-app ppp-mod-pppoa \
+ kmod-rt61 wpad-mini \
+ swconfig
+endef
+
+$(eval $(call Profile,ARV4510PW))
+
+define Profile/ARV7518PW
+ NAME:=Astoria - ARV7518PW
+ PACKAGES:=kmod-ltq-hcd-danube kmod-ledtrig-usbdev \
+ kmod-ltq-adsl-danube-mei kmod-ltq-adsl-danube \
+ kmod-ltq-adsl-danube-fw-b kmod-ltq-atm-danube \
+ ltq-adsl-app ppp-mod-pppoa \
+ kmod-ath9k wpad-mini \
+ swconfig
+endef
+
+$(eval $(call Profile,ARV7518PW))
+
+define Profile/ARV4520PW
+ NAME:=Easybox 800, WAV-281 - ARV4520PW
+ PACKAGES:=kmod-ltq-hcd-danube kmod-ledtrig-usbdev \
+ kmod-ltq-adsl-danube-mei kmod-ltq-adsl-danube \
+ kmod-ltq-adsl-danube-fw-b kmod-ltq-atm-danube \
+ ltq-adsl-app ppp-mod-pppoa \
+ kmod-rt61-pci wpad-mini \
+ swconfig
+endef
+
+$(eval $(call Profile,ARV4520PW))
+
+define Profile/ARV452CQW
+ NAME:=Easybox 801 - ARV452CQW
+ PACKAGES:=kmod-ltq-hcd-danube kmod-ledtrig-usbdev \
+ kmod-ath5k wpad-mini \
+ kmod-ltq-adsl-danube-mei kmod-ltq-adsl-danube \
+ kmod-ltq-adsl-danube-fw-b kmod-ltq-atm-danube \
+ ltq-adsl-app ppp-mod-pppoa \
+ swconfig
+endef
+
+$(eval $(call Profile,ARV452CQW))
+
+define Profile/ARV752DPW
+ NAME:=Easybox 802 - ARV752DPW
+ PACKAGES:=kmod-ltq-hcd-danube kmod-ledtrig-usbdev \
+ kmod-ltq-adsl-danube-mei kmod-ltq-adsl-danube \
+ kmod-ltq-adsl-danube-fw-b kmod-ltq-atm-danube \
+ ltq-adsl-app ppp-mod-pppoa \
+ kmod-ltq-tapi kmod-ltq-vmmc \
+ kmod-rt2800-pci wpad-mini \
+ swconfig
+endef
+
+$(eval $(call Profile,ARV752DPW))
+
+define Profile/ARV752DPW22
+ NAME:=Easybox 803 - ARV752DPW22
+ PACKAGES:=kmod-usb2 kmod-usb-uhci kmod-ltq-hcd-danube kmod-ledtrig-usbdev \
+ kmod-ltq-adsl-danube-mei kmod-ltq-adsl-danube \
+ kmod-ltq-adsl-danube-fw-b kmod-ltq-atm-danube \
+ ltq-adsl-app ppp-mod-pppoa \
+ kmod-ltq-tapi kmod-ltq-vmmc \
+ swconfig
+endef
+
+$(eval $(call Profile,ARV752DPW22))
diff --git a/target/linux/lantiq/xway/profiles/.svn/text-base/audiocodes.mk.svn-base b/target/linux/lantiq/xway/profiles/.svn/text-base/audiocodes.mk.svn-base
new file mode 100644
index 0000000..5f24dfc
--- /dev/null
+++ b/target/linux/lantiq/xway/profiles/.svn/text-base/audiocodes.mk.svn-base
@@ -0,0 +1,9 @@
+define Profile/ACMP252
+ NAME:=AudioCodes MediaPack MP-252
+ PACKAGES:=kmod-rt2x00 wpad-mini \
+ kmod-ltq-adsl-danube-mei kmod-ltq-adsl-danube \
+ kmod-ltq-adsl-danube-fw-a kmod-ltq-ptm-danube \
+ ltq-adsl-app
+endef
+
+$(eval $(call Profile,ACMP252))
diff --git a/target/linux/lantiq/xway/profiles/.svn/text-base/avm.mk.svn-base b/target/linux/lantiq/xway/profiles/.svn/text-base/avm.mk.svn-base
new file mode 100644
index 0000000..8dba09d
--- /dev/null
+++ b/target/linux/lantiq/xway/profiles/.svn/text-base/avm.mk.svn-base
@@ -0,0 +1,21 @@
+define Profile/FRITZ7320
+ NAME:=1&1 HomeServer - FRITZ7320
+ PACKAGES:=kmod-ath9k wpad-mini \
+ kmod-ltq-adsl-ar9-mei kmod-ltq-adsl-ar9 \
+ kmod-ltq-adsl-ar9-fw-b kmod-ltq-atm-ar9 \
+ ltq-adsl-app ppp-mod-pppoa \
+ kmod-ltq-deu-ar9 kmod-ltq-hcd-ar9
+endef
+
+$(eval $(call Profile,FRITZ7320))
+
+define Profile/FRITZ3370
+ NAME:=Fritz!Box WLan - FRITZ3370
+ PACKAGES:=kmod-ath9k wpad-mini \
+ kmod-ltq-deu-vr9 kmod-ltq-hcd-vr9 \
+ kmod-ltq-vdsl-vr9-mei kmod-ltq-vdsl-vr9 \
+ kmod-ltq-atm-vr9 ltq-vdsl-vr9-fw-installer \
+ ltq-vdsl-app ppp-mod-pppoa
+endef
+
+$(eval $(call Profile,FRITZ3370))
diff --git a/target/linux/lantiq/xway/profiles/.svn/text-base/buffalo.mk.svn-base b/target/linux/lantiq/xway/profiles/.svn/text-base/buffalo.mk.svn-base
new file mode 100644
index 0000000..3567d5f
--- /dev/null
+++ b/target/linux/lantiq/xway/profiles/.svn/text-base/buffalo.mk.svn-base
@@ -0,0 +1,23 @@
+define Profile/WBMRA
+ NAME:=Buffalo WBMR-HP-G300H (A) - WBMR
+ PACKAGES:=kmod-ltq-hcd-ar9 kmod-ledtrig-usbdev \
+ kmod-ltq-adsl-ar9-mei kmod-ltq-adsl-ar9 \
+ kmod-ltq-adsl-ar9-fw-a kmod-ltq-atm-ar9 \
+ ltq-adsl-app ppp-mod-pppoa \
+ kmod-ath9k wpad hostapd-utils \
+ swconfig
+endef
+
+$(eval $(call Profile,WBMRA))
+
+define Profile/WBMRB
+ NAME:=Buffalo WBMR-HP-G300H (B) - WBMR
+ PACKAGES:=kmod-ltq-hcd-ar9 kmod-ledtrig-usbdev \
+ kmod-ltq-adsl-ar9-mei kmod-ltq-adsl-ar9 \
+ kmod-ltq-adsl-ar9-fw-b kmod-ltq-atm-ar9 \
+ ltq-adsl-app ppp-mod-pppoa \
+ kmod-ath9k wpad hostapd-utils \
+ swconfig
+endef
+
+$(eval $(call Profile,WBMRB))
diff --git a/target/linux/lantiq/xway/profiles/.svn/text-base/lantiq.mk.svn-base b/target/linux/lantiq/xway/profiles/.svn/text-base/lantiq.mk.svn-base
new file mode 100644
index 0000000..b4990b6
--- /dev/null
+++ b/target/linux/lantiq/xway/profiles/.svn/text-base/lantiq.mk.svn-base
@@ -0,0 +1,27 @@
+define Profile/EASY50712
+ NAME:=Lantiq Danube - EASY50712
+endef
+
+$(eval $(call Profile,EASY50712))
+
+define Profile/EASY80920NOR
+ NAME:=Lantiq VR9 - EASY80920NOR
+ PACKAGES:=kmod-ath9k wpad-mini \
+ kmod-ltq-deu-vr9 kmod-ltq-hcd-vr9 \
+ kmod-ltq-vdsl-vr9-mei kmod-ltq-vdsl-vr9 \
+ kmod-ltq-atm-vr9 ltq-vdsl-vr9-fw-installer \
+ ltq-vdsl-app ppp-mod-pppoa
+endef
+
+$(eval $(call Profile,EASY80920NOR))
+
+define Profile/EASY80920NAND
+ NAME:=Lantiq VR9 - EASY80920NAND
+ PACKAGES:=kmod-ath9k wpad-mini \
+ kmod-ltq-deu-vr9 kmod-ltq-hcd-vr9 \
+ kmod-ltq-vdsl-vr9-mei kmod-ltq-vdsl-vr9 \
+ kmod-ltq-atm-vr9 ltq-vdsl-vr9-fw-installer \
+ ltq-vdsl-app ppp-mod-pppoa
+endef
+
+$(eval $(call Profile,EASY80920NAND))
diff --git a/target/linux/lantiq/xway/profiles/.svn/text-base/netgear.mk.svn-base b/target/linux/lantiq/xway/profiles/.svn/text-base/netgear.mk.svn-base
new file mode 100644
index 0000000..0c6ee65
--- /dev/null
+++ b/target/linux/lantiq/xway/profiles/.svn/text-base/netgear.mk.svn-base
@@ -0,0 +1,23 @@
+define Profile/DGN3500
+ NAME:=Netgear DGN3500
+ PACKAGES:=kmod-ltq-hcd-ar9 kmod-ledtrig-usbdev \
+ kmod-ath9k wpad-mini \
+ kmod-ltq-adsl-ar9-mei kmod-ltq-adsl-ar9 \
+ kmod-ltq-adsl-ar9-fw-a kmod-ltq-atm-ar9 \
+ ltq-adsl-app ppp-mod-pppoa \
+ kmod-ltq-deu-ar9
+endef
+
+$(eval $(call Profile,DGN3500))
+
+define Profile/DGN3500B
+ NAME:=Netgear DGN3500B
+ PACKAGES:=kmod-ltq-hcd-ar9 kmod-ledtrig-usbdev \
+ kmod-ath9k wpad-mini \
+ kmod-ltq-adsl-ar9-mei kmod-ltq-adsl-ar9 \
+ kmod-ltq-adsl-ar9-fw-b kmod-ltq-atm-ar9 \
+ ltq-adsl-app ppp-mod-pppoa \
+ kmod-ltq-deu-ar9
+endef
+
+$(eval $(call Profile,DGN3500B))
diff --git a/target/linux/lantiq/xway/profiles/arv.mk b/target/linux/lantiq/xway/profiles/arv.mk
new file mode 100644
index 0000000..a4f11ca
--- /dev/null
+++ b/target/linux/lantiq/xway/profiles/arv.mk
@@ -0,0 +1,116 @@
+define Profile/ARV4525PW
+ NAME:=Speedport W502V Typ A - ARV4525PW
+ PACKAGES:=kmod-ath5k wpad-mini \
+ kmod-ltq-adsl-danube-mei kmod-ltq-adsl-danube \
+ kmod-ltq-adsl-danube-fw-b kmod-ltq-atm-danube \
+ ltq-adsl-app ppp-mod-pppoa
+endef
+
+$(eval $(call Profile,ARV4525PW))
+
+define Profile/ARV7525PW
+ NAME:=Speedport W303V Typ A - ARV7525PW
+ PACKAGES:=kmod-rt2800-pci wpad-mini \
+ kmod-ltq-adsl-danube-mei kmod-ltq-adsl-danube \
+ kmod-ltq-adsl-danube-fw-b kmod-ltq-atm-danube \
+ ltq-adsl-app ppp-mod-pppoa
+endef
+
+$(eval $(call Profile,ARV7525PW))
+
+define Profile/ARV4518PWR01
+ NAME:=ARV4518PWR01
+ PACKAGES:=kmod-ltq-hcd-danube kmod-ledtrig-usbdev \
+ kmod-ltq-adsl-danube-mei kmod-ltq-adsl-danube \
+ kmod-ltq-adsl-danube-fw-b kmod-ltq-atm-danube \
+ ltq-adsl-app ppp-mod-pppoa \
+ kmod-ath5k wpad-mini \
+ swconfig
+endef
+
+$(eval $(call Profile,ARV4518PWR01))
+
+define Profile/ARV4518PWR01A
+ NAME:=ARV4518PWR01A
+ PACKAGES:=kmod-ltq-hcd-danube kmod-ledtrig-usbdev \
+ kmod-ltq-adsl-danube-mei kmod-ltq-adsl-danube \
+ kmod-ltq-adsl-danube-fw-b kmod-ltq-atm-danube \
+ ltq-adsl-app ppp-mod-pppoa \
+ kmod-ath5k wpad-mini \
+ swconfig
+endef
+
+$(eval $(call Profile,ARV4518PWR01A))
+
+define Profile/ARV4510PW
+ NAME:=Wippies Homebox - ARV4510PW
+ PACKAGES:=kmod-ledtrig-usbdev kmod-usb2 kmod-usb-uhci \
+ kmod-ltq-adsl-danube-mei kmod-ltq-adsl-danube \
+ kmod-ltq-adsl-danube-fw-b kmod-ltq-atm-danube \
+ ltq-adsl-app ppp-mod-pppoa \
+ kmod-rt61 wpad-mini \
+ swconfig
+endef
+
+$(eval $(call Profile,ARV4510PW))
+
+define Profile/ARV7518PW
+ NAME:=Astoria - ARV7518PW
+ PACKAGES:=kmod-ltq-hcd-danube kmod-ledtrig-usbdev \
+ kmod-ltq-adsl-danube-mei kmod-ltq-adsl-danube \
+ kmod-ltq-adsl-danube-fw-b kmod-ltq-atm-danube \
+ ltq-adsl-app ppp-mod-pppoa \
+ kmod-ath9k wpad-mini \
+ swconfig
+endef
+
+$(eval $(call Profile,ARV7518PW))
+
+define Profile/ARV4520PW
+ NAME:=Easybox 800, WAV-281 - ARV4520PW
+ PACKAGES:=kmod-ltq-hcd-danube kmod-ledtrig-usbdev \
+ kmod-ltq-adsl-danube-mei kmod-ltq-adsl-danube \
+ kmod-ltq-adsl-danube-fw-b kmod-ltq-atm-danube \
+ ltq-adsl-app ppp-mod-pppoa \
+ kmod-rt61-pci wpad-mini \
+ swconfig
+endef
+
+$(eval $(call Profile,ARV4520PW))
+
+define Profile/ARV452CQW
+ NAME:=Easybox 801 - ARV452CQW
+ PACKAGES:=kmod-ltq-hcd-danube kmod-ledtrig-usbdev \
+ kmod-ath5k wpad-mini \
+ kmod-ltq-adsl-danube-mei kmod-ltq-adsl-danube \
+ kmod-ltq-adsl-danube-fw-b kmod-ltq-atm-danube \
+ ltq-adsl-app ppp-mod-pppoa \
+ swconfig
+endef
+
+$(eval $(call Profile,ARV452CQW))
+
+define Profile/ARV752DPW
+ NAME:=Easybox 802 - ARV752DPW
+ PACKAGES:=kmod-ltq-hcd-danube kmod-ledtrig-usbdev \
+ kmod-ltq-adsl-danube-mei kmod-ltq-adsl-danube \
+ kmod-ltq-adsl-danube-fw-b kmod-ltq-atm-danube \
+ ltq-adsl-app ppp-mod-pppoa \
+ kmod-ltq-tapi kmod-ltq-vmmc \
+ kmod-rt2800-pci wpad-mini \
+ swconfig
+endef
+
+$(eval $(call Profile,ARV752DPW))
+
+define Profile/ARV752DPW22
+ NAME:=Easybox 803 - ARV752DPW22
+ PACKAGES:=kmod-usb2 kmod-usb-uhci kmod-ltq-hcd-danube kmod-ledtrig-usbdev \
+ kmod-ltq-adsl-danube-mei kmod-ltq-adsl-danube \
+ kmod-ltq-adsl-danube-fw-b kmod-ltq-atm-danube \
+ ltq-adsl-app ppp-mod-pppoa \
+ kmod-ltq-tapi kmod-ltq-vmmc \
+ swconfig
+endef
+
+$(eval $(call Profile,ARV752DPW22))
diff --git a/target/linux/lantiq/xway/profiles/audiocodes.mk b/target/linux/lantiq/xway/profiles/audiocodes.mk
new file mode 100644
index 0000000..5f24dfc
--- /dev/null
+++ b/target/linux/lantiq/xway/profiles/audiocodes.mk
@@ -0,0 +1,9 @@
+define Profile/ACMP252
+ NAME:=AudioCodes MediaPack MP-252
+ PACKAGES:=kmod-rt2x00 wpad-mini \
+ kmod-ltq-adsl-danube-mei kmod-ltq-adsl-danube \
+ kmod-ltq-adsl-danube-fw-a kmod-ltq-ptm-danube \
+ ltq-adsl-app
+endef
+
+$(eval $(call Profile,ACMP252))
diff --git a/target/linux/lantiq/xway/profiles/avm.mk b/target/linux/lantiq/xway/profiles/avm.mk
new file mode 100644
index 0000000..8dba09d
--- /dev/null
+++ b/target/linux/lantiq/xway/profiles/avm.mk
@@ -0,0 +1,21 @@
+define Profile/FRITZ7320
+ NAME:=1&1 HomeServer - FRITZ7320
+ PACKAGES:=kmod-ath9k wpad-mini \
+ kmod-ltq-adsl-ar9-mei kmod-ltq-adsl-ar9 \
+ kmod-ltq-adsl-ar9-fw-b kmod-ltq-atm-ar9 \
+ ltq-adsl-app ppp-mod-pppoa \
+ kmod-ltq-deu-ar9 kmod-ltq-hcd-ar9
+endef
+
+$(eval $(call Profile,FRITZ7320))
+
+define Profile/FRITZ3370
+ NAME:=Fritz!Box WLan - FRITZ3370
+ PACKAGES:=kmod-ath9k wpad-mini \
+ kmod-ltq-deu-vr9 kmod-ltq-hcd-vr9 \
+ kmod-ltq-vdsl-vr9-mei kmod-ltq-vdsl-vr9 \
+ kmod-ltq-atm-vr9 ltq-vdsl-vr9-fw-installer \
+ ltq-vdsl-app ppp-mod-pppoa
+endef
+
+$(eval $(call Profile,FRITZ3370))
diff --git a/target/linux/lantiq/xway/profiles/buffalo.mk b/target/linux/lantiq/xway/profiles/buffalo.mk
new file mode 100644
index 0000000..3567d5f
--- /dev/null
+++ b/target/linux/lantiq/xway/profiles/buffalo.mk
@@ -0,0 +1,23 @@
+define Profile/WBMRA
+ NAME:=Buffalo WBMR-HP-G300H (A) - WBMR
+ PACKAGES:=kmod-ltq-hcd-ar9 kmod-ledtrig-usbdev \
+ kmod-ltq-adsl-ar9-mei kmod-ltq-adsl-ar9 \
+ kmod-ltq-adsl-ar9-fw-a kmod-ltq-atm-ar9 \
+ ltq-adsl-app ppp-mod-pppoa \
+ kmod-ath9k wpad hostapd-utils \
+ swconfig
+endef
+
+$(eval $(call Profile,WBMRA))
+
+define Profile/WBMRB
+ NAME:=Buffalo WBMR-HP-G300H (B) - WBMR
+ PACKAGES:=kmod-ltq-hcd-ar9 kmod-ledtrig-usbdev \
+ kmod-ltq-adsl-ar9-mei kmod-ltq-adsl-ar9 \
+ kmod-ltq-adsl-ar9-fw-b kmod-ltq-atm-ar9 \
+ ltq-adsl-app ppp-mod-pppoa \
+ kmod-ath9k wpad hostapd-utils \
+ swconfig
+endef
+
+$(eval $(call Profile,WBMRB))
diff --git a/target/linux/lantiq/xway/profiles/lantiq.mk b/target/linux/lantiq/xway/profiles/lantiq.mk
new file mode 100644
index 0000000..b4990b6
--- /dev/null
+++ b/target/linux/lantiq/xway/profiles/lantiq.mk
@@ -0,0 +1,27 @@
+define Profile/EASY50712
+ NAME:=Lantiq Danube - EASY50712
+endef
+
+$(eval $(call Profile,EASY50712))
+
+define Profile/EASY80920NOR
+ NAME:=Lantiq VR9 - EASY80920NOR
+ PACKAGES:=kmod-ath9k wpad-mini \
+ kmod-ltq-deu-vr9 kmod-ltq-hcd-vr9 \
+ kmod-ltq-vdsl-vr9-mei kmod-ltq-vdsl-vr9 \
+ kmod-ltq-atm-vr9 ltq-vdsl-vr9-fw-installer \
+ ltq-vdsl-app ppp-mod-pppoa
+endef
+
+$(eval $(call Profile,EASY80920NOR))
+
+define Profile/EASY80920NAND
+ NAME:=Lantiq VR9 - EASY80920NAND
+ PACKAGES:=kmod-ath9k wpad-mini \
+ kmod-ltq-deu-vr9 kmod-ltq-hcd-vr9 \
+ kmod-ltq-vdsl-vr9-mei kmod-ltq-vdsl-vr9 \
+ kmod-ltq-atm-vr9 ltq-vdsl-vr9-fw-installer \
+ ltq-vdsl-app ppp-mod-pppoa
+endef
+
+$(eval $(call Profile,EASY80920NAND))
diff --git a/target/linux/lantiq/xway/profiles/netgear.mk b/target/linux/lantiq/xway/profiles/netgear.mk
new file mode 100644
index 0000000..0c6ee65
--- /dev/null
+++ b/target/linux/lantiq/xway/profiles/netgear.mk
@@ -0,0 +1,23 @@
+define Profile/DGN3500
+ NAME:=Netgear DGN3500
+ PACKAGES:=kmod-ltq-hcd-ar9 kmod-ledtrig-usbdev \
+ kmod-ath9k wpad-mini \
+ kmod-ltq-adsl-ar9-mei kmod-ltq-adsl-ar9 \
+ kmod-ltq-adsl-ar9-fw-a kmod-ltq-atm-ar9 \
+ ltq-adsl-app ppp-mod-pppoa \
+ kmod-ltq-deu-ar9
+endef
+
+$(eval $(call Profile,DGN3500))
+
+define Profile/DGN3500B
+ NAME:=Netgear DGN3500B
+ PACKAGES:=kmod-ltq-hcd-ar9 kmod-ledtrig-usbdev \
+ kmod-ath9k wpad-mini \
+ kmod-ltq-adsl-ar9-mei kmod-ltq-adsl-ar9 \
+ kmod-ltq-adsl-ar9-fw-b kmod-ltq-atm-ar9 \
+ ltq-adsl-app ppp-mod-pppoa \
+ kmod-ltq-deu-ar9
+endef
+
+$(eval $(call Profile,DGN3500B))
diff --git a/target/linux/lantiq/xway/target.mk b/target/linux/lantiq/xway/target.mk
new file mode 100644
index 0000000..e725679
--- /dev/null
+++ b/target/linux/lantiq/xway/target.mk
@@ -0,0 +1,10 @@
+ARCH:=mips
+SUBTARGET:=xway
+BOARDNAME:=XWAY
+FEATURES:=squashfs jffs2 atm
+
+DEFAULT_PACKAGES+=kmod-leds-gpio kmod-gpio-button-hotplug
+
+define Target/Description
+ Lantiq XWAY
+endef