aboutsummaryrefslogtreecommitdiffstats
path: root/target/linux/at91/image/.svn
diff options
context:
space:
mode:
Diffstat (limited to 'target/linux/at91/image/.svn')
-rw-r--r--target/linux/at91/image/.svn/entries102
-rw-r--r--target/linux/at91/image/.svn/text-base/Config.in.svn-base37
-rw-r--r--target/linux/at91/image/.svn/text-base/Makefile.svn-base38
3 files changed, 177 insertions, 0 deletions
diff --git a/target/linux/at91/image/.svn/entries b/target/linux/at91/image/.svn/entries
new file mode 100644
index 0000000..36735e7
--- /dev/null
+++ b/target/linux/at91/image/.svn/entries
@@ -0,0 +1,102 @@
+10
+
+dir
+36060
+svn://svn.openwrt.org/openwrt/trunk/target/linux/at91/image
+svn://svn.openwrt.org/openwrt
+
+
+
+2012-04-20T13:27:16.979200Z
+31370
+claudio
+
+
+
+
+
+
+
+
+
+
+
+
+
+
+3c298f89-4303-0410-b956-a3cf2f4a3e73
+
+u-boot
+dir
+
+Config.in
+file
+
+
+
+
+2013-03-17T12:13:05.000000Z
+c49c966616e28906084da14c7b43c4a7
+2011-07-03T18:51:59.804324Z
+27412
+blogic
+
+
+
+
+
+
+
+
+
+
+
+
+
+
+
+
+
+
+
+
+
+798
+
+dfboot
+dir
+
+Makefile
+file
+
+
+
+
+2013-03-17T12:13:05.000000Z
+540fc3c256b92c10da065ccb6e842f9b
+2012-04-20T13:27:16.979200Z
+31370
+claudio
+
+
+
+
+
+
+
+
+
+
+
+
+
+
+
+
+
+
+
+
+
+877
+
diff --git a/target/linux/at91/image/.svn/text-base/Config.in.svn-base b/target/linux/at91/image/.svn/text-base/Config.in.svn-base
new file mode 100644
index 0000000..917398f
--- /dev/null
+++ b/target/linux/at91/image/.svn/text-base/Config.in.svn-base
@@ -0,0 +1,37 @@
+config AT91_DFBOOT
+ bool "Build dataflashboot loader"
+ depends TARGET_at91
+ default n
+
+config AT91_UBOOT
+ bool "Build U-Boot bootloader"
+ depends TARGET_at91
+ default n
+
+config UBOOT_TARGET
+ string "U-Boot target board"
+ depends AT91_UBOOT
+ default "netusg20"
+ help
+ For all supported boards there are ready-to-use default
+ configurations available; just type "<board_name>".
+
+config UBOOT_IPADDR
+ string "IP Address for U-Boot"
+ depends AT91_UBOOT
+ default "192.168.0.178"
+ help
+ IP address of device to be used in U-Boot
+
+config UBOOT_SERVERIP
+ string "IP Address of TFTP server"
+ depends AT91_UBOOT
+ default "192.168.0.232"
+ help
+ IP address of TFTP server for U-Boot
+
+config FLEXIBITY_ROOT
+ bool "Build Flexibity RootFS (with embedded kernel)"
+ depends TARGET_at91_flexibity
+ default n
+
diff --git a/target/linux/at91/image/.svn/text-base/Makefile.svn-base b/target/linux/at91/image/.svn/text-base/Makefile.svn-base
new file mode 100644
index 0000000..97723bb
--- /dev/null
+++ b/target/linux/at91/image/.svn/text-base/Makefile.svn-base
@@ -0,0 +1,38 @@
+#
+# Copyright (C) 2006-2010 OpenWrt.org
+#
+# This is free software, licensed under the GNU General Public License v2.
+# See /LICENSE for more information.
+#
+include $(TOPDIR)/rules.mk
+include $(INCLUDE_DIR)/image.mk
+
+define Build/Clean
+ $(MAKE) -C u-boot clean
+endef
+
+define Build/Compile
+ if [ $(CONFIG_AT91_UBOOT) ]; then \
+ $(MAKE) -C u-boot compile; \
+ fi
+endef
+
+define Image/Prepare
+endef
+
+define Image/BuildKernel
+ mkdir -p $(BIN_DIR)
+ mkimage -A arm -T kernel -C none -a 0x20008000 -e 0x20008000 -n linux-2.6 \
+ -d $(LINUX_DIR)/arch/arm/boot/Image $(BIN_DIR)/$(IMG_PREFIX)-uImage
+ if [ $(CONFIG_FLEXIBITY_ROOT) ]; then \
+ $(INSTALL_BIN) $(BIN_DIR)/$(IMG_PREFIX)-uImage $(TARGET_DIR)/uImage ; \
+ fi
+endef
+
+define Image/Build
+ $(call Image/Build/$(1),$(1))
+ mkdir -p $(BIN_DIR)
+ cp $(KDIR)/root.$(1) $(BIN_DIR)/$(IMG_PREFIX)-root.$(1)
+endef
+
+$(eval $(call BuildImage))