aboutsummaryrefslogtreecommitdiffstats
path: root/package/platform/lantiq/ltq-adsl-app/.svn
diff options
context:
space:
mode:
Diffstat (limited to 'package/platform/lantiq/ltq-adsl-app/.svn')
-rw-r--r--package/platform/lantiq/ltq-adsl-app/.svn/entries99
-rw-r--r--package/platform/lantiq/ltq-adsl-app/.svn/text-base/Config.in.svn-base9
-rw-r--r--package/platform/lantiq/ltq-adsl-app/.svn/text-base/Makefile.svn-base98
3 files changed, 206 insertions, 0 deletions
diff --git a/package/platform/lantiq/ltq-adsl-app/.svn/entries b/package/platform/lantiq/ltq-adsl-app/.svn/entries
new file mode 100644
index 0000000..1fef17e
--- /dev/null
+++ b/package/platform/lantiq/ltq-adsl-app/.svn/entries
@@ -0,0 +1,99 @@
+10
+
+dir
+36060
+svn://svn.openwrt.org/openwrt/trunk/package/platform/lantiq/ltq-adsl-app
+svn://svn.openwrt.org/openwrt
+
+
+
+2012-12-21T13:47:25.499676Z
+34818
+blogic
+
+
+
+
+
+
+
+
+
+
+
+
+
+
+3c298f89-4303-0410-b956-a3cf2f4a3e73
+
+files
+dir
+
+Config.in
+file
+
+
+
+
+2013-03-17T12:13:13.000000Z
+6dd12ecbeb4480e456ee3ff8c16b3018
+2012-12-15T02:00:39.596852Z
+34694
+blogic
+
+
+
+
+
+
+
+
+
+
+
+
+
+
+
+
+
+
+
+
+
+220
+
+Makefile
+file
+
+
+
+
+2013-03-17T12:13:13.000000Z
+3c1580e91b167dbb9375cc12167f205e
+2012-12-15T02:00:39.596852Z
+34694
+blogic
+
+
+
+
+
+
+
+
+
+
+
+
+
+
+
+
+
+
+
+
+
+2640
+
diff --git a/package/platform/lantiq/ltq-adsl-app/.svn/text-base/Config.in.svn-base b/package/platform/lantiq/ltq-adsl-app/.svn/text-base/Config.in.svn-base
new file mode 100644
index 0000000..728fe65
--- /dev/null
+++ b/package/platform/lantiq/ltq-adsl-app/.svn/text-base/Config.in.svn-base
@@ -0,0 +1,9 @@
+config LTQ_DSL_ENABLE_SOAP
+ bool "Enable SOAP support"
+ depends on PACKAGE_ltq-dsl-app
+ default n
+
+config LTQ_DSL_ENABLE_DSL_EVENT_POLLING
+ bool "Include Event Polling support"
+ depends on PACKAGE_ltq-dsl-app
+ default n
diff --git a/package/platform/lantiq/ltq-adsl-app/.svn/text-base/Makefile.svn-base b/package/platform/lantiq/ltq-adsl-app/.svn/text-base/Makefile.svn-base
new file mode 100644
index 0000000..92445e5
--- /dev/null
+++ b/package/platform/lantiq/ltq-adsl-app/.svn/text-base/Makefile.svn-base
@@ -0,0 +1,98 @@
+#
+# Copyright (C) 2011-2012 OpenWrt.org
+#
+# This is free software, licensed under the GNU General Public License v2.
+# See /LICENSE for more information.
+#
+
+include $(TOPDIR)/rules.mk
+include $(INCLUDE_DIR)/kernel.mk
+
+PKG_NAME:=dsl_cpe_control_danube
+PKG_VERSION:=3.24.4.4
+PKG_RELEASE:=2
+PKG_SOURCE:=$(PKG_NAME)-$(PKG_VERSION).tar.gz
+PKG_BUILD_DIR:=$(BUILD_DIR)/dsl_cpe_control-$(PKG_VERSION)
+PKG_SOURCE_URL:=http://mirror2.openwrt.org/sources/
+PKG_MD5SUM:=ee315306626b68794d3d3636dabfe161
+PKG_MAINTAINER:=John Crispin <blogic@openwrt.org>
+
+PKG_FIXUP:=autoreconf
+
+PKG_CONFIG_DEPENDS:=\
+ CONFIG_LTQ_DSL_ENABLE_SOAP \
+ CONFIG_LTQ_DSL_ENABLE_DSL_EVENT_POLLING
+
+PKG_BUILD_DEPENDS:=TARGET_lantiq_xway:kmod-ltq-adsl-danube TARGET_lantiq_ase:kmod-ltq-adsl-ase
+
+include $(INCLUDE_DIR)/package.mk
+
+define Package/ltq-adsl-app
+ SECTION:=net
+ CATEGORY:=Network
+ TITLE:=Lantiq DSL userland tool
+ URL:=http://www.lantiq.com/
+ DEPENDS:=@(TARGET_lantiq_xway||TARGET_lantiq_ase) +libpthread
+ MENU:=1
+endef
+
+define Package/ltq-adsl-app/description
+ Infineon DSL CPE API for Amazon SE, Danube and Vinax.
+endef
+
+define Package/ltq-adsl-app/config
+ source "$(SOURCE)/Config.in"
+endef
+
+LTQ_DSL_MAX_DEVICE=1
+LTQ_DSL_LINES_PER_DEVICE=1
+LTQ_DSL_CHANNELS_PER_LINE=1
+
+CONFIGURE_ARGS += \
+ --with-max-device="$(LTQ_DSL_MAX_DEVICE)" \
+ --with-lines-per-device="$(LTQ_DSL_LINES_PER_DEVICE)" \
+ --with-channels-per-line="$(LTQ_DSL_CHANNELS_PER_LINE)" \
+ --enable-danube \
+ --enable-driver-include="-I$(STAGING_DIR)/usr/include/adsl/" \
+ --enable-debug-prints \
+ --enable-add-appl-cflags="-DMAX_CLI_PIPES=2" \
+ --enable-cli-support \
+ --enable-cmv-scripts \
+ --enable-debug-tool-interface \
+ --enable-adsl-led \
+ --enable-dsl-ceoc \
+ --enable-script-notification \
+ --enable-dsl-pm \
+ --enable-dsl-pm-total \
+ --enable-dsl-pm-history \
+ --enable-dsl-pm-showtime \
+ --enable-dsl-pm-channel-counters \
+ --enable-dsl-pm-datapath-counters \
+ --enable-dsl-pm-line-counters \
+ --enable-dsl-pm-channel-thresholds \
+ --enable-dsl-pm-datapath-thresholds \
+ --enable-dsl-pm-line-thresholds \
+ --enable-dsl-pm-optional-parameters
+
+ifeq ($(CONFIG_LTQ_DSL_ENABLE_SOAP),y)
+CONFIGURE_ARGS += \
+ --enable-soap-support
+endif
+
+ifeq ($(CONFIG_LTQ_DSL_ENABLE_DSL_EVENT_POLLING),y)
+CONFIGURE_ARGS += \
+ --enable-dsl-event-polling
+endif
+
+TARGET_CFLAGS += -I$(LINUX_DIR)/include
+
+define Package/ltq-adsl-app/install
+ $(INSTALL_DIR) $(1)/etc/init.d
+ $(INSTALL_BIN) ./files/dsl_control $(1)/etc/init.d/
+
+ $(INSTALL_DIR) $(1)/sbin
+ $(INSTALL_BIN) $(PKG_BUILD_DIR)/src/dsl_cpe_control $(1)/sbin
+ $(INSTALL_BIN) ./files/dsl_notify.sh $(1)/sbin
+endef
+
+$(eval $(call BuildPackage,ltq-adsl-app))