aboutsummaryrefslogtreecommitdiffstats
path: root/package/network/utils/xtables-addons/patches-1.x/002-fix-kernel-version-detection.patch
diff options
context:
space:
mode:
Diffstat (limited to 'package/network/utils/xtables-addons/patches-1.x/002-fix-kernel-version-detection.patch')
-rw-r--r--package/network/utils/xtables-addons/patches-1.x/002-fix-kernel-version-detection.patch22
1 files changed, 22 insertions, 0 deletions
diff --git a/package/network/utils/xtables-addons/patches-1.x/002-fix-kernel-version-detection.patch b/package/network/utils/xtables-addons/patches-1.x/002-fix-kernel-version-detection.patch
new file mode 100644
index 0000000..b31f9f1
--- /dev/null
+++ b/package/network/utils/xtables-addons/patches-1.x/002-fix-kernel-version-detection.patch
@@ -0,0 +1,22 @@
+--- a/configure
++++ b/configure
+@@ -11780,7 +11780,7 @@ regular_CFLAGS="-Wall -Waggregate-return
+ if test -n "$kbuilddir"; then
+ { $as_echo "$as_me:${as_lineno-$LINENO}: checking kernel version that we will build against" >&5
+ $as_echo_n "checking kernel version that we will build against... " >&6; }
+- krel="$(make -sC "$kbuilddir" M=$PWD kernelrelease)";
++ krel="$(make -sC "$kbuilddir" M=$PWD kernelversion)";
+ kmajor="${krel%%[^0-9]*}";
+ kmajor="$(($kmajor+0))";
+ krel="${krel:${#kmajor}}";
+--- a/configure.ac
++++ b/configure.ac
+@@ -44,7 +44,7 @@ regular_CFLAGS="-Wall -Waggregate-return
+
+ if test -n "$kbuilddir"; then
+ AC_MSG_CHECKING([kernel version that we will build against])
+- krel="$(make -sC "$kbuilddir" M=$PWD kernelrelease)";
++ krel="$(make -sC "$kbuilddir" M=$PWD kernelversion)";
+ kmajor="${krel%%[[^0-9]]*}";
+ kmajor="$(($kmajor+0))";
+ krel="${krel:${#kmajor}}";