aboutsummaryrefslogtreecommitdiffstats
path: root/package/network/utils/conntrack-tools
diff options
context:
space:
mode:
Diffstat (limited to 'package/network/utils/conntrack-tools')
-rw-r--r--package/network/utils/conntrack-tools/.svn/entries62
-rw-r--r--package/network/utils/conntrack-tools/.svn/text-base/Makefile.svn-base61
-rw-r--r--package/network/utils/conntrack-tools/Makefile61
3 files changed, 184 insertions, 0 deletions
diff --git a/package/network/utils/conntrack-tools/.svn/entries b/package/network/utils/conntrack-tools/.svn/entries
new file mode 100644
index 0000000..fbc9d25
--- /dev/null
+++ b/package/network/utils/conntrack-tools/.svn/entries
@@ -0,0 +1,62 @@
+10
+
+dir
+36060
+svn://svn.openwrt.org/openwrt/trunk/package/network/utils/conntrack-tools
+svn://svn.openwrt.org/openwrt
+
+
+
+2012-10-10T13:19:43.677179Z
+33701
+jow
+
+
+
+
+
+
+
+
+
+
+
+
+
+
+3c298f89-4303-0410-b956-a3cf2f4a3e73
+
+Makefile
+file
+
+
+
+
+2013-03-17T12:13:17.000000Z
+3f396c540bc0758317bd7fe17a4c39a7
+2012-10-10T13:19:43.677179Z
+33701
+jow
+
+
+
+
+
+
+
+
+
+
+
+
+
+
+
+
+
+
+
+
+
+1688
+
diff --git a/package/network/utils/conntrack-tools/.svn/text-base/Makefile.svn-base b/package/network/utils/conntrack-tools/.svn/text-base/Makefile.svn-base
new file mode 100644
index 0000000..3c52441
--- /dev/null
+++ b/package/network/utils/conntrack-tools/.svn/text-base/Makefile.svn-base
@@ -0,0 +1,61 @@
+#
+# Copyright (C) 2009-2011 OpenWrt.org
+#
+# This is free software, licensed under the GNU General Public License v2.
+# See /LICENSE for more information.
+#
+
+include $(TOPDIR)/rules.mk
+
+PKG_NAME:=conntrack-tools
+PKG_VERSION:=1.0.0
+PKG_RELEASE:=1
+
+PKG_SOURCE:=$(PKG_NAME)-$(PKG_VERSION).tar.bz2
+PKG_SOURCE_URL:= \
+ http://www.netfilter.org/projects/conntrack-tools/files \
+ ftp://ftp.netfilter.org/pub/conntrack-tools \
+ http://mirrors.evolva.ro/netfilter.org/conntrack-tools
+PKG_MD5SUM:=5add24d4761baf17af630d5627a71752
+
+PKG_MAINTAINER:=Jo-Philipp Wich <jow@openwrt.org>
+
+PKG_FIXUP:=autoreconf
+PKG_INSTALL:=1
+
+include $(INCLUDE_DIR)/package.mk
+
+define Package/conntrack-tools
+ SECTION:=net
+ CATEGORY:=Network
+ DEPENDS:=+libnetfilter-conntrack
+ SUBMENU:=Firewall
+ TITLE:=Connection tracking userspace tools
+ URL:=http://conntrack-tools.netfilter.org/
+endef
+
+define Package/conntrack-tools/description
+ The conntrack-tools are a set of free software userspace tools for Linux
+ that allow system administrators interact with the Connection Tracking
+ System, which is the module that provides stateful packet inspection for
+ iptables. The conntrack-tools are the userspace daemon conntrackd and the
+ command line interface conntrack.
+endef
+
+define Package/conntrack-tools/conffiles
+/etc/conntrackd/conntrackd.conf
+endef
+
+define Package/conntrack-tools/install
+ $(INSTALL_DIR) $(1)/etc/conntrackd
+ $(INSTALL_CONF) \
+ $(PKG_BUILD_DIR)/doc/stats/conntrackd.conf \
+ $(1)/etc/conntrackd/
+ $(INSTALL_DIR) $(1)/usr/sbin
+ $(INSTALL_BIN) \
+ $(PKG_INSTALL_DIR)/usr/sbin/conntrack \
+ $(PKG_INSTALL_DIR)/usr/sbin/conntrackd \
+ $(1)/usr/sbin/
+endef
+
+$(eval $(call BuildPackage,conntrack-tools))
diff --git a/package/network/utils/conntrack-tools/Makefile b/package/network/utils/conntrack-tools/Makefile
new file mode 100644
index 0000000..3c52441
--- /dev/null
+++ b/package/network/utils/conntrack-tools/Makefile
@@ -0,0 +1,61 @@
+#
+# Copyright (C) 2009-2011 OpenWrt.org
+#
+# This is free software, licensed under the GNU General Public License v2.
+# See /LICENSE for more information.
+#
+
+include $(TOPDIR)/rules.mk
+
+PKG_NAME:=conntrack-tools
+PKG_VERSION:=1.0.0
+PKG_RELEASE:=1
+
+PKG_SOURCE:=$(PKG_NAME)-$(PKG_VERSION).tar.bz2
+PKG_SOURCE_URL:= \
+ http://www.netfilter.org/projects/conntrack-tools/files \
+ ftp://ftp.netfilter.org/pub/conntrack-tools \
+ http://mirrors.evolva.ro/netfilter.org/conntrack-tools
+PKG_MD5SUM:=5add24d4761baf17af630d5627a71752
+
+PKG_MAINTAINER:=Jo-Philipp Wich <jow@openwrt.org>
+
+PKG_FIXUP:=autoreconf
+PKG_INSTALL:=1
+
+include $(INCLUDE_DIR)/package.mk
+
+define Package/conntrack-tools
+ SECTION:=net
+ CATEGORY:=Network
+ DEPENDS:=+libnetfilter-conntrack
+ SUBMENU:=Firewall
+ TITLE:=Connection tracking userspace tools
+ URL:=http://conntrack-tools.netfilter.org/
+endef
+
+define Package/conntrack-tools/description
+ The conntrack-tools are a set of free software userspace tools for Linux
+ that allow system administrators interact with the Connection Tracking
+ System, which is the module that provides stateful packet inspection for
+ iptables. The conntrack-tools are the userspace daemon conntrackd and the
+ command line interface conntrack.
+endef
+
+define Package/conntrack-tools/conffiles
+/etc/conntrackd/conntrackd.conf
+endef
+
+define Package/conntrack-tools/install
+ $(INSTALL_DIR) $(1)/etc/conntrackd
+ $(INSTALL_CONF) \
+ $(PKG_BUILD_DIR)/doc/stats/conntrackd.conf \
+ $(1)/etc/conntrackd/
+ $(INSTALL_DIR) $(1)/usr/sbin
+ $(INSTALL_BIN) \
+ $(PKG_INSTALL_DIR)/usr/sbin/conntrack \
+ $(PKG_INSTALL_DIR)/usr/sbin/conntrackd \
+ $(1)/usr/sbin/
+endef
+
+$(eval $(call BuildPackage,conntrack-tools))