aboutsummaryrefslogtreecommitdiffstats
path: root/package/network/services/ppp/patches/.svn/text-base/300-filter-pcap-includes-lib.patch.svn-base
diff options
context:
space:
mode:
Diffstat (limited to 'package/network/services/ppp/patches/.svn/text-base/300-filter-pcap-includes-lib.patch.svn-base')
-rw-r--r--package/network/services/ppp/patches/.svn/text-base/300-filter-pcap-includes-lib.patch.svn-base20
1 files changed, 20 insertions, 0 deletions
diff --git a/package/network/services/ppp/patches/.svn/text-base/300-filter-pcap-includes-lib.patch.svn-base b/package/network/services/ppp/patches/.svn/text-base/300-filter-pcap-includes-lib.patch.svn-base
new file mode 100644
index 0000000..d8dcc64
--- /dev/null
+++ b/package/network/services/ppp/patches/.svn/text-base/300-filter-pcap-includes-lib.patch.svn-base
@@ -0,0 +1,20 @@
+build: Add required CFLAGS for libpcap
+
+This patch adds some flags to required to properly link libpcap within the
+OpenWrt environment.
+
+Signed-off-by: Jo-Philipp Wich <jow@openwrt.org>
+
+--- a/pppd/Makefile.linux
++++ b/pppd/Makefile.linux
+@@ -170,8 +170,8 @@ endif
+
+ ifdef FILTER
+ ifneq ($(wildcard /usr/include/pcap-bpf.h),)
+-LIBS += -lpcap
+-CFLAGS += -DPPP_FILTER
++LIBS += -lpcap -L$(STAGING_DIR)/usr/lib
++CFLAGS += -DPPP_FILTER -I$(STAGING_DIR)/usr/include
+ endif
+ endif
+