aboutsummaryrefslogtreecommitdiffstats
path: root/package/libs/popt/.svn
diff options
context:
space:
mode:
Diffstat (limited to 'package/libs/popt/.svn')
-rw-r--r--package/libs/popt/.svn/entries65
-rw-r--r--package/libs/popt/.svn/prop-base/Makefile.svn-base13
-rw-r--r--package/libs/popt/.svn/text-base/Makefile.svn-base59
3 files changed, 137 insertions, 0 deletions
diff --git a/package/libs/popt/.svn/entries b/package/libs/popt/.svn/entries
new file mode 100644
index 0000000..ef0e2c9
--- /dev/null
+++ b/package/libs/popt/.svn/entries
@@ -0,0 +1,65 @@
+10
+
+dir
+36060
+svn://svn.openwrt.org/openwrt/trunk/package/libs/popt
+svn://svn.openwrt.org/openwrt
+
+
+
+2012-10-10T13:26:27.622493Z
+33705
+nbd
+
+
+
+
+
+
+
+
+
+
+
+
+
+
+3c298f89-4303-0410-b956-a3cf2f4a3e73
+
+patches
+dir
+
+Makefile
+file
+
+
+
+
+2013-03-17T12:13:08.000000Z
+3b43d1e057fa5702952029e94747c2f5
+2012-06-11T21:18:33.553794Z
+32206
+jow
+has-props
+
+
+
+
+
+
+
+
+
+
+
+
+
+
+
+
+
+
+
+
+1330
+
diff --git a/package/libs/popt/.svn/prop-base/Makefile.svn-base b/package/libs/popt/.svn/prop-base/Makefile.svn-base
new file mode 100644
index 0000000..f899379
--- /dev/null
+++ b/package/libs/popt/.svn/prop-base/Makefile.svn-base
@@ -0,0 +1,13 @@
+K 9
+copyright
+V 30
+Copyright (C) 2006 OpenWrt.org
+K 7
+licence
+V 5
+GPLv2
+K 13
+svn:eol-style
+V 6
+native
+END
diff --git a/package/libs/popt/.svn/text-base/Makefile.svn-base b/package/libs/popt/.svn/text-base/Makefile.svn-base
new file mode 100644
index 0000000..1cdcc40
--- /dev/null
+++ b/package/libs/popt/.svn/text-base/Makefile.svn-base
@@ -0,0 +1,59 @@
+#
+# Copyright (C) 2006-2010 OpenWrt.org
+#
+# This is free software, licensed under the GNU General Public License v2.
+# See /LICENSE for more information.
+#
+
+include $(TOPDIR)/rules.mk
+
+PKG_NAME:=popt
+PKG_VERSION:=1.7
+PKG_RELEASE:=5
+
+PKG_SOURCE:=$(PKG_NAME)-$(PKG_VERSION).tar.gz
+PKG_SOURCE_URL:=http://downloads.openwrt.org/sources/
+PKG_MD5SUM:=5988e7aeb0ae4dac8d83561265984cc9
+
+PKG_FIXUP:=autoreconf
+PKG_REMOVE_FILES:=autogen.sh aclocal.m4
+
+PKG_INSTALL:=1
+PKG_BUILD_PARALLEL:=1
+
+include $(INCLUDE_DIR)/package.mk
+
+TARGET_CFLAGS += $(FPIC)
+
+define Package/libpopt
+ SECTION:=libs
+ CATEGORY:=Libraries
+ TITLE:=A command line option parsing library
+ URL:=http://rpm5.org/files/popt/
+endef
+
+define Build/Configure
+ $(call Build/Configure/Default, \
+ --enable-shared \
+ --enable-static \
+ )
+endef
+
+define Build/InstallDev
+ $(INSTALL_DIR) $(1)/usr/include
+ $(CP) $(PKG_INSTALL_DIR)/usr/include/popt.h $(1)/usr/include/
+ $(INSTALL_DIR) $(1)/usr/lib
+ $(CP) $(PKG_INSTALL_DIR)/usr/lib/libpopt.{a,so*} $(1)/usr/lib/
+endef
+
+define Package/libpopt/install
+ $(INSTALL_DIR) $(1)/usr/lib
+ $(CP) $(PKG_INSTALL_DIR)/usr/lib/libpopt.so.* $(1)/usr/lib/
+endef
+
+$(eval $(call RequireCommand,xgettext, \
+ $(PKG_NAME) requires the GNU gettext development package installed on the local system to build. \
+))
+
+$(eval $(call BuildPackage,libpopt))
+