aboutsummaryrefslogtreecommitdiffstats
path: root/package/libs/cyassl/.svn
diff options
context:
space:
mode:
Diffstat (limited to 'package/libs/cyassl/.svn')
-rw-r--r--package/libs/cyassl/.svn/entries65
-rw-r--r--package/libs/cyassl/.svn/text-base/Makefile.svn-base56
2 files changed, 121 insertions, 0 deletions
diff --git a/package/libs/cyassl/.svn/entries b/package/libs/cyassl/.svn/entries
new file mode 100644
index 0000000..9ba2e15
--- /dev/null
+++ b/package/libs/cyassl/.svn/entries
@@ -0,0 +1,65 @@
+10
+
+dir
+36060
+svn://svn.openwrt.org/openwrt/trunk/package/libs/cyassl
+svn://svn.openwrt.org/openwrt
+
+
+
+2012-10-09T16:41:36.278401Z
+33675
+jow
+
+
+
+
+
+
+
+
+
+
+
+
+
+
+3c298f89-4303-0410-b956-a3cf2f4a3e73
+
+patches
+dir
+
+Makefile
+file
+
+
+
+
+2013-03-17T12:13:06.000000Z
+98972ee67cc12252dfc30892d770b8c9
+2012-10-09T16:41:36.278401Z
+33675
+jow
+
+
+
+
+
+
+
+
+
+
+
+
+
+
+
+
+
+
+
+
+
+1214
+
diff --git a/package/libs/cyassl/.svn/text-base/Makefile.svn-base b/package/libs/cyassl/.svn/text-base/Makefile.svn-base
new file mode 100644
index 0000000..063e572
--- /dev/null
+++ b/package/libs/cyassl/.svn/text-base/Makefile.svn-base
@@ -0,0 +1,56 @@
+#
+# Copyright (C) 2006-2012 OpenWrt.org
+#
+# This is free software, licensed under the GNU General Public License v2.
+# See /LICENSE for more information.
+#
+
+include $(TOPDIR)/rules.mk
+
+PKG_NAME:=cyassl
+PKG_VERSION:=1.6.5
+PKG_RELEASE:=2
+
+PKG_SOURCE:=$(PKG_NAME)-$(PKG_VERSION).zip
+PKG_SOURCE_URL:=http://www.yassl.com/
+PKG_MD5SUM:=98c2c6350acf1d089756a1de9ccb9903
+
+PKG_FIXUP:=patch-libtool
+PKG_INSTALL:=1
+PKG_BUILD_PARALLEL:=1
+
+include $(INCLUDE_DIR)/package.mk
+
+define Package/libcyassl
+ SECTION:=libs
+ SUBMENU:=SSL
+ CATEGORY:=Libraries
+ TITLE:=CyaSSL library
+ URL:=http://www.yassl.com/
+endef
+
+define Package/libcyassl/description
+CyaSSL is an SSL library optimized for small footprint, both on disk and for
+memory use.
+endef
+
+TARGET_CFLAGS += $(FPIC)
+
+CONFIGURE_ARGS += \
+ --without-zlib \
+ --enable-singleThreaded
+
+define Build/InstallDev
+ $(INSTALL_DIR) $(1)/usr/include
+ $(CP) $(PKG_INSTALL_DIR)/usr/include/* $(1)/usr/include/
+
+ $(INSTALL_DIR) $(1)/usr/lib
+ $(CP) $(PKG_INSTALL_DIR)/usr/lib/libcyassl.{a,so*,la} $(1)/usr/lib/
+endef
+
+define Package/libcyassl/install
+ $(INSTALL_DIR) $(1)/usr/lib
+ $(CP) $(PKG_INSTALL_DIR)/usr/lib/libcyassl.so* $(1)/usr/lib/
+endef
+
+$(eval $(call BuildPackage,libcyassl))