aboutsummaryrefslogtreecommitdiffstats
path: root/package/boot/kexec-tools/.svn
diff options
context:
space:
mode:
Diffstat (limited to 'package/boot/kexec-tools/.svn')
-rw-r--r--package/boot/kexec-tools/.svn/entries99
-rw-r--r--package/boot/kexec-tools/.svn/prop-base/Config.in.svn-base5
-rw-r--r--package/boot/kexec-tools/.svn/prop-base/Makefile.svn-base9
-rw-r--r--package/boot/kexec-tools/.svn/text-base/Config.in.svn-base21
-rw-r--r--package/boot/kexec-tools/.svn/text-base/Makefile.svn-base80
5 files changed, 214 insertions, 0 deletions
diff --git a/package/boot/kexec-tools/.svn/entries b/package/boot/kexec-tools/.svn/entries
new file mode 100644
index 0000000..491df3a
--- /dev/null
+++ b/package/boot/kexec-tools/.svn/entries
@@ -0,0 +1,99 @@
+10
+
+dir
+36060
+svn://svn.openwrt.org/openwrt/trunk/package/boot/kexec-tools
+svn://svn.openwrt.org/openwrt
+
+
+
+2012-10-16T13:44:25.630275Z
+33781
+blogic
+
+
+
+
+
+
+
+
+
+
+
+
+
+
+3c298f89-4303-0410-b956-a3cf2f4a3e73
+
+patches
+dir
+
+Config.in
+file
+
+
+
+
+2013-03-17T12:13:21.000000Z
+feb1f5431985cc3122a22da7a6949801
+2012-10-16T13:44:25.630275Z
+33781
+blogic
+has-props
+
+
+
+
+
+
+
+
+
+
+
+
+
+
+
+
+
+
+
+
+450
+
+Makefile
+file
+
+
+
+
+2013-03-17T12:13:21.000000Z
+9cf805153359d6a9fd758b0ba696c92c
+2012-10-16T13:44:25.630275Z
+33781
+blogic
+has-props
+
+
+
+
+
+
+
+
+
+
+
+
+
+
+
+
+
+
+
+
+1988
+
diff --git a/package/boot/kexec-tools/.svn/prop-base/Config.in.svn-base b/package/boot/kexec-tools/.svn/prop-base/Config.in.svn-base
new file mode 100644
index 0000000..3160658
--- /dev/null
+++ b/package/boot/kexec-tools/.svn/prop-base/Config.in.svn-base
@@ -0,0 +1,5 @@
+K 13
+svn:mergeinfo
+V 0
+
+END
diff --git a/package/boot/kexec-tools/.svn/prop-base/Makefile.svn-base b/package/boot/kexec-tools/.svn/prop-base/Makefile.svn-base
new file mode 100644
index 0000000..8e522ae
--- /dev/null
+++ b/package/boot/kexec-tools/.svn/prop-base/Makefile.svn-base
@@ -0,0 +1,9 @@
+K 13
+svn:copyright
+V 30
+Copyright (C) 2006 OpenWrt.org
+K 13
+svn:eol-style
+V 6
+native
+END
diff --git a/package/boot/kexec-tools/.svn/text-base/Config.in.svn-base b/package/boot/kexec-tools/.svn/text-base/Config.in.svn-base
new file mode 100644
index 0000000..60c819d
--- /dev/null
+++ b/package/boot/kexec-tools/.svn/text-base/Config.in.svn-base
@@ -0,0 +1,21 @@
+menu "Configuration"
+ depends on PACKAGE_kexec-tools
+
+config KEXEC_TOOLS_TARGET_NAME
+ string
+ prompt "Target name for kexec kernel"
+ default EXTRA_TARGET_ARCH_NAME if powerpc64
+ default ARCH
+ help
+ Defines the target type of the kernels that kexec deals
+ with. This should be the target specification of
+ the kernel you're booting.
+
+config KEXEC_TOOLS_kdump
+ bool
+ prompt "kdump support"
+ default n
+ help
+ Include the kdump utility.
+
+endmenu
diff --git a/package/boot/kexec-tools/.svn/text-base/Makefile.svn-base b/package/boot/kexec-tools/.svn/text-base/Makefile.svn-base
new file mode 100644
index 0000000..fa4f4d8
--- /dev/null
+++ b/package/boot/kexec-tools/.svn/text-base/Makefile.svn-base
@@ -0,0 +1,80 @@
+#
+# Copyright (C) 2006-2012 OpenWrt.org
+#
+# This is free software, licensed under the GNU General Public License v2.
+# See /LICENSE for more information.
+#
+
+include $(TOPDIR)/rules.mk
+
+PKG_NAME:=kexec-tools
+PKG_VERSION:=2.0.3
+PKG_RELEASE:=1
+
+PKG_SOURCE:=$(PKG_NAME)-$(PKG_VERSION).tar.bz2
+PKG_SOURCE_URL:=@KERNEL/linux/utils/kernel/kexec
+PKG_MD5SUM:=b3ced2097ce3981abba38ceedc84f939
+
+PKG_FIXUP:=autoreconf
+
+include $(INCLUDE_DIR)/package.mk
+
+define Package/kexec-tools
+ SECTION:=utils
+ CATEGORY:=Utilities
+ DEPENDS:=@armeb||@arm||@i386||@powerpc64||@mipsel||@mips +zlib
+ TITLE:=Kernel boots kernel
+ URL:=http://kernel.org/pub/linux/kernel/people/horms/kexec-tools/
+ MAINTAINER:=Florian Fainelli <florian@openwrt.org>
+ MENU:=1
+endef
+
+define Package/kexec-tools/description
+ kexec is a set of systems call that allows you to load
+ another kernel from the currently executing Linux kernel.
+endef
+
+define Package/kexec-tools/config
+ source "$(SOURCE)/Config.in"
+endef
+
+KEXEC_TARGET_NAME:=$(call qstrip,$(CONFIG_KEXEC_TOOLS_TARGET_NAME))-linux-$(TARGET_SUFFIX)
+
+CONFIGURE_ARGS = \
+ --target=$(KEXEC_TARGET_NAME) \
+ --host=$(REAL_GNU_TARGET_NAME) \
+ --build=$(GNU_HOST_NAME) \
+ --program-prefix="" \
+ --program-suffix="" \
+ --prefix=/usr \
+ --exec-prefix=/usr \
+ --bindir=/usr/bin \
+ --sbindir=/usr/sbin \
+ --libexecdir=/usr/lib \
+ --sysconfdir=/etc
+
+CONFIGURE_VARS += \
+ BUILD_CC="$(HOSTCC)" \
+ TARGET_CC="$(TARGET_CC)"
+
+kexec-extra-sbin-$(CONFIG_KEXEC_TOOLS_kdump) += kdump
+
+define Build/Compile
+ $(MAKE) -C $(PKG_BUILD_DIR) DESTDIR="$(PKG_INSTALL_DIR)" all install
+endef
+
+define Package/kexec-tools/install
+ $(INSTALL_DIR) $(1)/usr/sbin
+ $(INSTALL_BIN) \
+ $(addprefix $(PKG_INSTALL_DIR)/usr/sbin/, \
+ $(kexec-extra-sbin-y)) \
+ $(kexec-extra-bin-y) \
+ $(PKG_INSTALL_DIR)/usr/sbin/kexec \
+ $(1)/usr/sbin
+
+# make a link for compatability with other distros
+ $(INSTALL_DIR) $(1)/sbin
+ ln -s /usr/sbin/kexec $(1)/sbin/kexec
+endef
+
+$(eval $(call BuildPackage,kexec-tools))