aboutsummaryrefslogtreecommitdiffstats
path: root/include/kernel-version.mk
diff options
context:
space:
mode:
Diffstat (limited to 'include/kernel-version.mk')
-rw-r--r--include/kernel-version.mk30
1 files changed, 30 insertions, 0 deletions
diff --git a/include/kernel-version.mk b/include/kernel-version.mk
new file mode 100644
index 0000000..f5021be
--- /dev/null
+++ b/include/kernel-version.mk
@@ -0,0 +1,30 @@
+# Use the default kernel version if the Makefile doesn't override it
+
+LINUX_RELEASE?=1
+
+ifeq ($(LINUX_VERSION),3.3.8)
+ LINUX_KERNEL_MD5SUM:=f1058f64eed085deb44f10cee8541d50
+endif
+ifeq ($(LINUX_VERSION),3.6.11)
+ LINUX_KERNEL_MD5SUM:=3d602ad7f7984509c3e923a5ae90bc54
+endif
+ifeq ($(LINUX_VERSION),3.7.10)
+ LINUX_KERNEL_MD5SUM:=09624c3702107076efcac5e1cd8a18ec
+endif
+ifeq ($(LINUX_VERSION),3.8.3)
+ LINUX_KERNEL_MD5SUM:=eb59b1fc7343db96e20c85a9cf2baa9f
+endif
+
+# disable the md5sum check for unknown kernel versions
+LINUX_KERNEL_MD5SUM?=x
+
+split_version=$(subst ., ,$(1))
+merge_version=$(subst $(space),.,$(1))
+KERNEL_BASE=$(firstword $(subst -, ,$(LINUX_VERSION)))
+KERNEL=$(call merge_version,$(wordlist 1,2,$(call split_version,$(KERNEL_BASE))))
+ifeq ($(firstword $(call split_version,$(KERNEL_BASE))),2)
+ KERNEL_PATCHVER=$(call merge_version,$(wordlist 1,3,$(call split_version,$(KERNEL_BASE))))
+else
+ KERNEL_PATCHVER=$(KERNEL)
+endif
+