aboutsummaryrefslogtreecommitdiffstats
path: root/tools/xz
diff options
context:
space:
mode:
authorJames <>2013-03-17 12:16:37 +0000
committerJames <>2013-03-17 12:16:37 +0000
commit27b76ab0671089c47506615a796a261e993896a7 (patch)
tree61213d67e7fa87b20356b23798558e2c4212c42f /tools/xz
downloadtrunk-36060-master.tar.gz
trunk-36060-master.tar.bz2
trunk-36060-master.zip
Diffstat (limited to 'tools/xz')
-rw-r--r--tools/xz/.svn/entries62
-rw-r--r--tools/xz/.svn/text-base/Makefile.svn-base27
-rw-r--r--tools/xz/Makefile27
3 files changed, 116 insertions, 0 deletions
diff --git a/tools/xz/.svn/entries b/tools/xz/.svn/entries
new file mode 100644
index 0000000..fdf68a3
--- /dev/null
+++ b/tools/xz/.svn/entries
@@ -0,0 +1,62 @@
+10
+
+dir
+36060
+svn://svn.openwrt.org/openwrt/trunk/tools/xz
+svn://svn.openwrt.org/openwrt
+
+
+
+2012-09-23T09:50:01.636378Z
+33523
+nbd
+
+
+
+
+
+
+
+
+
+
+
+
+
+
+3c298f89-4303-0410-b956-a3cf2f4a3e73
+
+Makefile
+file
+
+
+
+
+2013-03-17T12:13:23.000000Z
+190a9461ba535e11de62e9f10af235b6
+2012-09-23T09:50:01.636378Z
+33523
+nbd
+
+
+
+
+
+
+
+
+
+
+
+
+
+
+
+
+
+
+
+
+
+635
+
diff --git a/tools/xz/.svn/text-base/Makefile.svn-base b/tools/xz/.svn/text-base/Makefile.svn-base
new file mode 100644
index 0000000..9999006
--- /dev/null
+++ b/tools/xz/.svn/text-base/Makefile.svn-base
@@ -0,0 +1,27 @@
+#
+# Copyright (C) 2006-2012 OpenWrt.org
+#
+# This is free software, licensed under the GNU General Public License v2.
+# See /LICENSE for more information.
+#
+include $(TOPDIR)/rules.mk
+
+PKG_NAME:=xz
+PKG_VERSION:=5.0.4
+
+PKG_SOURCE:=$(PKG_NAME)-$(PKG_VERSION).tar.bz2
+PKG_SOURCE_URL:=http://tukaani.org/xz
+PKG_MD5SUM:=741cd3a5f64b23b7bac56ec5b2258715
+
+HOST_BUILD_PARALLEL:=1
+
+include $(INCLUDE_DIR)/host-build.mk
+
+HOST_LDFLAGS += $(HOST_STATIC_LINKING)
+
+define Host/Install
+ +$(MAKE) $(HOST_JOBS) -C $(HOST_BUILD_DIR) install xzlinks="unxz xzcat" \
+ AM_LDFLAGS="$(if $(HOST_STATIC_LINKING),-all-static)"
+endef
+
+$(eval $(call HostBuild))
diff --git a/tools/xz/Makefile b/tools/xz/Makefile
new file mode 100644
index 0000000..9999006
--- /dev/null
+++ b/tools/xz/Makefile
@@ -0,0 +1,27 @@
+#
+# Copyright (C) 2006-2012 OpenWrt.org
+#
+# This is free software, licensed under the GNU General Public License v2.
+# See /LICENSE for more information.
+#
+include $(TOPDIR)/rules.mk
+
+PKG_NAME:=xz
+PKG_VERSION:=5.0.4
+
+PKG_SOURCE:=$(PKG_NAME)-$(PKG_VERSION).tar.bz2
+PKG_SOURCE_URL:=http://tukaani.org/xz
+PKG_MD5SUM:=741cd3a5f64b23b7bac56ec5b2258715
+
+HOST_BUILD_PARALLEL:=1
+
+include $(INCLUDE_DIR)/host-build.mk
+
+HOST_LDFLAGS += $(HOST_STATIC_LINKING)
+
+define Host/Install
+ +$(MAKE) $(HOST_JOBS) -C $(HOST_BUILD_DIR) install xzlinks="unxz xzcat" \
+ AM_LDFLAGS="$(if $(HOST_STATIC_LINKING),-all-static)"
+endef
+
+$(eval $(call HostBuild))