aboutsummaryrefslogtreecommitdiffstats
path: root/tools/scons
diff options
context:
space:
mode:
authorJames <>2013-03-17 12:16:37 +0000
committerJames <>2013-03-17 12:16:37 +0000
commit27b76ab0671089c47506615a796a261e993896a7 (patch)
tree61213d67e7fa87b20356b23798558e2c4212c42f /tools/scons
downloadtrunk-36060-master.tar.gz
trunk-36060-master.tar.bz2
trunk-36060-master.zip
Diffstat (limited to 'tools/scons')
-rw-r--r--tools/scons/.svn/entries68
-rw-r--r--tools/scons/.svn/text-base/Makefile.svn-base34
-rw-r--r--tools/scons/Makefile34
-rw-r--r--tools/scons/files/.svn/entries62
-rw-r--r--tools/scons/files/.svn/prop-base/pywrap.sh.svn-base5
-rw-r--r--tools/scons/files/.svn/text-base/pywrap.sh.svn-base15
-rwxr-xr-xtools/scons/files/pywrap.sh15
-rw-r--r--tools/scons/patches/.svn/entries62
-rw-r--r--tools/scons/patches/.svn/text-base/001-platform_env.patch.svn-base11
-rw-r--r--tools/scons/patches/001-platform_env.patch11
10 files changed, 317 insertions, 0 deletions
diff --git a/tools/scons/.svn/entries b/tools/scons/.svn/entries
new file mode 100644
index 0000000..10b5422
--- /dev/null
+++ b/tools/scons/.svn/entries
@@ -0,0 +1,68 @@
+10
+
+dir
+36060
+svn://svn.openwrt.org/openwrt/trunk/tools/scons
+svn://svn.openwrt.org/openwrt
+
+
+
+2012-05-15T20:29:32.846704Z
+31743
+jow
+
+
+
+
+
+
+
+
+
+
+
+
+
+
+3c298f89-4303-0410-b956-a3cf2f4a3e73
+
+files
+dir
+
+patches
+dir
+
+Makefile
+file
+
+
+
+
+2013-03-17T12:13:23.000000Z
+f0c5724d342dac53a0801e217dffa796
+2012-05-15T20:04:07.059115Z
+31742
+jow
+
+
+
+
+
+
+
+
+
+
+
+
+
+
+
+
+
+
+
+
+
+752
+
diff --git a/tools/scons/.svn/text-base/Makefile.svn-base b/tools/scons/.svn/text-base/Makefile.svn-base
new file mode 100644
index 0000000..83c1c58
--- /dev/null
+++ b/tools/scons/.svn/text-base/Makefile.svn-base
@@ -0,0 +1,34 @@
+#
+# Copyright (C) 2011 OpenWrt.org
+#
+# This is free software, licensed under the GNU General Public License v2.
+# See /LICENSE for more information.
+#
+
+include $(TOPDIR)/rules.mk
+
+PKG_NAME:=scons
+PKG_VERSION:=2.1.0
+
+PKG_SOURCE:=$(PKG_NAME)-$(PKG_VERSION).tar.gz
+PKG_SOURCE_URL:=@SF/scons
+PKG_MD5SUM:=47daf989e303a045b76c11236df719df
+
+include $(INCLUDE_DIR)/host-build.mk
+
+define Host/Configure
+endef
+
+define Host/Compile
+endef
+
+define Host/Install
+ ./files/pywrap.sh $(HOST_BUILD_DIR)/setup.py install --prefix=$(STAGING_DIR_HOST)
+ rm -f $(STAGING_DIR_HOST)/bin/scons*.py
+ for bin in $(STAGING_DIR_HOST)/bin/scons*; do \
+ mv "$$$$bin" "$$$$bin.py"; \
+ cp ./files/pywrap.sh "$$$$bin"; \
+ done
+endef
+
+$(eval $(call HostBuild))
diff --git a/tools/scons/Makefile b/tools/scons/Makefile
new file mode 100644
index 0000000..83c1c58
--- /dev/null
+++ b/tools/scons/Makefile
@@ -0,0 +1,34 @@
+#
+# Copyright (C) 2011 OpenWrt.org
+#
+# This is free software, licensed under the GNU General Public License v2.
+# See /LICENSE for more information.
+#
+
+include $(TOPDIR)/rules.mk
+
+PKG_NAME:=scons
+PKG_VERSION:=2.1.0
+
+PKG_SOURCE:=$(PKG_NAME)-$(PKG_VERSION).tar.gz
+PKG_SOURCE_URL:=@SF/scons
+PKG_MD5SUM:=47daf989e303a045b76c11236df719df
+
+include $(INCLUDE_DIR)/host-build.mk
+
+define Host/Configure
+endef
+
+define Host/Compile
+endef
+
+define Host/Install
+ ./files/pywrap.sh $(HOST_BUILD_DIR)/setup.py install --prefix=$(STAGING_DIR_HOST)
+ rm -f $(STAGING_DIR_HOST)/bin/scons*.py
+ for bin in $(STAGING_DIR_HOST)/bin/scons*; do \
+ mv "$$$$bin" "$$$$bin.py"; \
+ cp ./files/pywrap.sh "$$$$bin"; \
+ done
+endef
+
+$(eval $(call HostBuild))
diff --git a/tools/scons/files/.svn/entries b/tools/scons/files/.svn/entries
new file mode 100644
index 0000000..d7c80a7
--- /dev/null
+++ b/tools/scons/files/.svn/entries
@@ -0,0 +1,62 @@
+10
+
+dir
+36060
+svn://svn.openwrt.org/openwrt/trunk/tools/scons/files
+svn://svn.openwrt.org/openwrt
+
+
+
+2012-05-15T20:29:32.846704Z
+31743
+jow
+
+
+
+
+
+
+
+
+
+
+
+
+
+
+3c298f89-4303-0410-b956-a3cf2f4a3e73
+
+pywrap.sh
+file
+
+
+
+
+2013-03-17T12:13:23.000000Z
+c969cc0565cc5bfdc3e749c4f84803c7
+2012-05-15T20:29:32.846704Z
+31743
+jow
+has-props
+
+
+
+
+
+
+
+
+
+
+
+
+
+
+
+
+
+
+
+
+340
+
diff --git a/tools/scons/files/.svn/prop-base/pywrap.sh.svn-base b/tools/scons/files/.svn/prop-base/pywrap.sh.svn-base
new file mode 100644
index 0000000..869ac71
--- /dev/null
+++ b/tools/scons/files/.svn/prop-base/pywrap.sh.svn-base
@@ -0,0 +1,5 @@
+K 14
+svn:executable
+V 1
+*
+END
diff --git a/tools/scons/files/.svn/text-base/pywrap.sh.svn-base b/tools/scons/files/.svn/text-base/pywrap.sh.svn-base
new file mode 100644
index 0000000..f62f590
--- /dev/null
+++ b/tools/scons/files/.svn/text-base/pywrap.sh.svn-base
@@ -0,0 +1,15 @@
+#!/usr/bin/env bash
+
+case "${0##*/}" in
+ pywrap.sh) arg1="";;
+ *) arg1="$0.py" ;;
+esac
+
+for bin in python python2 python2.7 python2.6 python2.5 python2.4; do
+ case "$($bin -V 2>&1)" in
+ "Python 2"*) exec $bin $arg1 "$@" ;;
+ esac
+done
+
+echo "Unable to find a Python 2.x interpreter for executing ${arg1:+$arg1 }$@ !" >&2
+exit 1
diff --git a/tools/scons/files/pywrap.sh b/tools/scons/files/pywrap.sh
new file mode 100755
index 0000000..f62f590
--- /dev/null
+++ b/tools/scons/files/pywrap.sh
@@ -0,0 +1,15 @@
+#!/usr/bin/env bash
+
+case "${0##*/}" in
+ pywrap.sh) arg1="";;
+ *) arg1="$0.py" ;;
+esac
+
+for bin in python python2 python2.7 python2.6 python2.5 python2.4; do
+ case "$($bin -V 2>&1)" in
+ "Python 2"*) exec $bin $arg1 "$@" ;;
+ esac
+done
+
+echo "Unable to find a Python 2.x interpreter for executing ${arg1:+$arg1 }$@ !" >&2
+exit 1
diff --git a/tools/scons/patches/.svn/entries b/tools/scons/patches/.svn/entries
new file mode 100644
index 0000000..421ac73
--- /dev/null
+++ b/tools/scons/patches/.svn/entries
@@ -0,0 +1,62 @@
+10
+
+dir
+36060
+svn://svn.openwrt.org/openwrt/trunk/tools/scons/patches
+svn://svn.openwrt.org/openwrt
+
+
+
+2012-05-15T13:42:36.976615Z
+31741
+nbd
+
+
+
+
+
+
+
+
+
+
+
+
+
+
+3c298f89-4303-0410-b956-a3cf2f4a3e73
+
+001-platform_env.patch
+file
+
+
+
+
+2013-03-17T12:13:23.000000Z
+b700bd509ac40c87dc61f7b6e8172f70
+2012-05-05T21:02:35.091976Z
+31620
+nbd
+
+
+
+
+
+
+
+
+
+
+
+
+
+
+
+
+
+
+
+
+
+350
+
diff --git a/tools/scons/patches/.svn/text-base/001-platform_env.patch.svn-base b/tools/scons/patches/.svn/text-base/001-platform_env.patch.svn-base
new file mode 100644
index 0000000..8aab904
--- /dev/null
+++ b/tools/scons/patches/.svn/text-base/001-platform_env.patch.svn-base
@@ -0,0 +1,11 @@
+--- a/engine/SCons/Platform/__init__.py
++++ b/engine/SCons/Platform/__init__.py
+@@ -63,6 +63,8 @@ def platform_default():
+ care about the machine architecture.
+ """
+ osname = os.name
++ if 'PLATFORM' in os.environ:
++ return os.environ['PLATFORM']
+ if osname == 'java':
+ osname = os._osType
+ if osname == 'posix':
diff --git a/tools/scons/patches/001-platform_env.patch b/tools/scons/patches/001-platform_env.patch
new file mode 100644
index 0000000..8aab904
--- /dev/null
+++ b/tools/scons/patches/001-platform_env.patch
@@ -0,0 +1,11 @@
+--- a/engine/SCons/Platform/__init__.py
++++ b/engine/SCons/Platform/__init__.py
+@@ -63,6 +63,8 @@ def platform_default():
+ care about the machine architecture.
+ """
+ osname = os.name
++ if 'PLATFORM' in os.environ:
++ return os.environ['PLATFORM']
+ if osname == 'java':
+ osname = os._osType
+ if osname == 'posix':