aboutsummaryrefslogtreecommitdiffstats
path: root/tools/pkg-config
diff options
context:
space:
mode:
authorJames <>2013-03-17 12:16:37 +0000
committerJames <>2013-03-17 12:16:37 +0000
commit27b76ab0671089c47506615a796a261e993896a7 (patch)
tree61213d67e7fa87b20356b23798558e2c4212c42f /tools/pkg-config
downloadtrunk-36060-master.tar.gz
trunk-36060-master.tar.bz2
trunk-36060-master.zip
Diffstat (limited to 'tools/pkg-config')
-rw-r--r--tools/pkg-config/.svn/entries68
-rw-r--r--tools/pkg-config/.svn/text-base/Makefile.svn-base34
-rw-r--r--tools/pkg-config/Makefile34
-rw-r--r--tools/pkg-config/files/.svn/entries62
-rw-r--r--tools/pkg-config/files/.svn/prop-base/pkg-config.svn-base5
-rw-r--r--tools/pkg-config/files/.svn/text-base/pkg-config.svn-base3
-rwxr-xr-xtools/pkg-config/files/pkg-config3
-rw-r--r--tools/pkg-config/patches/.svn/entries62
-rw-r--r--tools/pkg-config/patches/.svn/text-base/100-disable_compat_cmd.patch.svn-base22
-rw-r--r--tools/pkg-config/patches/100-disable_compat_cmd.patch22
10 files changed, 315 insertions, 0 deletions
diff --git a/tools/pkg-config/.svn/entries b/tools/pkg-config/.svn/entries
new file mode 100644
index 0000000..ced8842
--- /dev/null
+++ b/tools/pkg-config/.svn/entries
@@ -0,0 +1,68 @@
+10
+
+dir
+36060
+svn://svn.openwrt.org/openwrt/trunk/tools/pkg-config
+svn://svn.openwrt.org/openwrt
+
+
+
+2012-09-15T14:17:37.139624Z
+33430
+nbd
+
+
+
+
+
+
+
+
+
+
+
+
+
+
+3c298f89-4303-0410-b956-a3cf2f4a3e73
+
+files
+dir
+
+patches
+dir
+
+Makefile
+file
+
+
+
+
+2013-03-17T12:13:22.000000Z
+ccf1dafca9eaf16e04ebee1e089ec8a0
+2012-09-15T14:17:37.139624Z
+33430
+nbd
+
+
+
+
+
+
+
+
+
+
+
+
+
+
+
+
+
+
+
+
+
+865
+
diff --git a/tools/pkg-config/.svn/text-base/Makefile.svn-base b/tools/pkg-config/.svn/text-base/Makefile.svn-base
new file mode 100644
index 0000000..b72f3ce
--- /dev/null
+++ b/tools/pkg-config/.svn/text-base/Makefile.svn-base
@@ -0,0 +1,34 @@
+#
+# Copyright (C) 2006 OpenWrt.org
+#
+# This is free software, licensed under the GNU General Public License v2.
+# See /LICENSE for more information.
+#
+include $(TOPDIR)/rules.mk
+
+PKG_NAME:=pkg-config
+PKG_VERSION:=0.25
+
+PKG_SOURCE:=$(PKG_NAME)-$(PKG_VERSION).tar.gz
+PKG_SOURCE_URL:=http://pkgconfig.freedesktop.org/releases/
+PKG_MD5SUM:=a3270bab3f4b69b7dc6dbdacbcae9745
+
+HOST_BUILD_PARALLEL:=1
+
+include $(INCLUDE_DIR)/host-build.mk
+
+HOST_LDFLAGS += $(HOST_STATIC_LINKING)
+
+define Host/Install
+ $(MAKE) -C $(HOST_BUILD_DIR) install \
+ AM_LDFLAGS="$(if $(HOST_STATIC_LINKING),-all-static)"
+ mv $(STAGING_DIR_HOST)/bin/pkg-config $(STAGING_DIR_HOST)/bin/pkg-config.real
+ $(INSTALL_BIN) ./files/pkg-config $(STAGING_DIR_HOST)/bin/pkg-config
+endef
+
+define Host/Clean
+ -$(MAKE) -C $(HOST_BUILD_DIR) uninstall
+ $(call Host/Clean/Default)
+endef
+
+$(eval $(call HostBuild))
diff --git a/tools/pkg-config/Makefile b/tools/pkg-config/Makefile
new file mode 100644
index 0000000..b72f3ce
--- /dev/null
+++ b/tools/pkg-config/Makefile
@@ -0,0 +1,34 @@
+#
+# Copyright (C) 2006 OpenWrt.org
+#
+# This is free software, licensed under the GNU General Public License v2.
+# See /LICENSE for more information.
+#
+include $(TOPDIR)/rules.mk
+
+PKG_NAME:=pkg-config
+PKG_VERSION:=0.25
+
+PKG_SOURCE:=$(PKG_NAME)-$(PKG_VERSION).tar.gz
+PKG_SOURCE_URL:=http://pkgconfig.freedesktop.org/releases/
+PKG_MD5SUM:=a3270bab3f4b69b7dc6dbdacbcae9745
+
+HOST_BUILD_PARALLEL:=1
+
+include $(INCLUDE_DIR)/host-build.mk
+
+HOST_LDFLAGS += $(HOST_STATIC_LINKING)
+
+define Host/Install
+ $(MAKE) -C $(HOST_BUILD_DIR) install \
+ AM_LDFLAGS="$(if $(HOST_STATIC_LINKING),-all-static)"
+ mv $(STAGING_DIR_HOST)/bin/pkg-config $(STAGING_DIR_HOST)/bin/pkg-config.real
+ $(INSTALL_BIN) ./files/pkg-config $(STAGING_DIR_HOST)/bin/pkg-config
+endef
+
+define Host/Clean
+ -$(MAKE) -C $(HOST_BUILD_DIR) uninstall
+ $(call Host/Clean/Default)
+endef
+
+$(eval $(call HostBuild))
diff --git a/tools/pkg-config/files/.svn/entries b/tools/pkg-config/files/.svn/entries
new file mode 100644
index 0000000..78a5e5b
--- /dev/null
+++ b/tools/pkg-config/files/.svn/entries
@@ -0,0 +1,62 @@
+10
+
+dir
+36060
+svn://svn.openwrt.org/openwrt/trunk/tools/pkg-config/files
+svn://svn.openwrt.org/openwrt
+
+
+
+2011-07-24T09:02:49.152125Z
+27744
+nbd
+
+
+
+
+
+
+
+
+
+
+
+
+
+
+3c298f89-4303-0410-b956-a3cf2f4a3e73
+
+pkg-config
+file
+
+
+
+
+2013-03-17T12:13:22.000000Z
+4255d430d6306b586c3a7e44e992fb24
+2011-07-24T09:02:49.152125Z
+27744
+nbd
+has-props
+
+
+
+
+
+
+
+
+
+
+
+
+
+
+
+
+
+
+
+
+121
+
diff --git a/tools/pkg-config/files/.svn/prop-base/pkg-config.svn-base b/tools/pkg-config/files/.svn/prop-base/pkg-config.svn-base
new file mode 100644
index 0000000..869ac71
--- /dev/null
+++ b/tools/pkg-config/files/.svn/prop-base/pkg-config.svn-base
@@ -0,0 +1,5 @@
+K 14
+svn:executable
+V 1
+*
+END
diff --git a/tools/pkg-config/files/.svn/text-base/pkg-config.svn-base b/tools/pkg-config/files/.svn/text-base/pkg-config.svn-base
new file mode 100644
index 0000000..e58b132
--- /dev/null
+++ b/tools/pkg-config/files/.svn/text-base/pkg-config.svn-base
@@ -0,0 +1,3 @@
+#!/bin/sh
+
+pkg-config.real $@ --define-variable=prefix=${STAGING_PREFIX} --define-variable=exec_prefix=${STAGING_PREFIX}
diff --git a/tools/pkg-config/files/pkg-config b/tools/pkg-config/files/pkg-config
new file mode 100755
index 0000000..e58b132
--- /dev/null
+++ b/tools/pkg-config/files/pkg-config
@@ -0,0 +1,3 @@
+#!/bin/sh
+
+pkg-config.real $@ --define-variable=prefix=${STAGING_PREFIX} --define-variable=exec_prefix=${STAGING_PREFIX}
diff --git a/tools/pkg-config/patches/.svn/entries b/tools/pkg-config/patches/.svn/entries
new file mode 100644
index 0000000..dcebcea
--- /dev/null
+++ b/tools/pkg-config/patches/.svn/entries
@@ -0,0 +1,62 @@
+10
+
+dir
+36060
+svn://svn.openwrt.org/openwrt/trunk/tools/pkg-config/patches
+svn://svn.openwrt.org/openwrt
+
+
+
+2009-03-24T22:27:22.410267Z
+15026
+nbd
+
+
+
+
+
+
+
+
+
+
+
+
+
+
+3c298f89-4303-0410-b956-a3cf2f4a3e73
+
+100-disable_compat_cmd.patch
+file
+
+
+
+
+2013-03-17T12:13:22.000000Z
+179c187372c52effc130251079d31cd3
+2009-03-24T22:27:22.410267Z
+15026
+nbd
+
+
+
+
+
+
+
+
+
+
+
+
+
+
+
+
+
+
+
+
+
+602
+
diff --git a/tools/pkg-config/patches/.svn/text-base/100-disable_compat_cmd.patch.svn-base b/tools/pkg-config/patches/.svn/text-base/100-disable_compat_cmd.patch.svn-base
new file mode 100644
index 0000000..9907840
--- /dev/null
+++ b/tools/pkg-config/patches/.svn/text-base/100-disable_compat_cmd.patch.svn-base
@@ -0,0 +1,22 @@
+--- a/parse.c
++++ b/parse.c
+@@ -1187,15 +1187,12 @@ try_command (const char *command)
+ Package *
+ get_compat_package (const char *name)
+ {
+-#ifdef G_OS_WIN32
+- /* There has never been any of these legacy *-config scripts on
+- * Windows as far as I know. No use trying to execute them, will
+- * only confuse users to see the "blabla is not recognized as an
+- * internal or external command, operable program or batch file"
+- * messages.
++ /*
++ * We don't need this compatibility stuff on a system
++ * that is free of legacy stuff
+ */
+ return NULL;
+-#else
++#if 0
+
+ Package *pkg;
+
diff --git a/tools/pkg-config/patches/100-disable_compat_cmd.patch b/tools/pkg-config/patches/100-disable_compat_cmd.patch
new file mode 100644
index 0000000..9907840
--- /dev/null
+++ b/tools/pkg-config/patches/100-disable_compat_cmd.patch
@@ -0,0 +1,22 @@
+--- a/parse.c
++++ b/parse.c
+@@ -1187,15 +1187,12 @@ try_command (const char *command)
+ Package *
+ get_compat_package (const char *name)
+ {
+-#ifdef G_OS_WIN32
+- /* There has never been any of these legacy *-config scripts on
+- * Windows as far as I know. No use trying to execute them, will
+- * only confuse users to see the "blabla is not recognized as an
+- * internal or external command, operable program or batch file"
+- * messages.
++ /*
++ * We don't need this compatibility stuff on a system
++ * that is free of legacy stuff
+ */
+ return NULL;
+-#else
++#if 0
+
+ Package *pkg;
+