aboutsummaryrefslogtreecommitdiffstats
path: root/tools/mtools
diff options
context:
space:
mode:
authorJames <>2013-03-17 12:16:37 +0000
committerJames <>2013-03-17 12:16:37 +0000
commit27b76ab0671089c47506615a796a261e993896a7 (patch)
tree61213d67e7fa87b20356b23798558e2c4212c42f /tools/mtools
downloadtrunk-36060-master.tar.gz
trunk-36060-master.tar.bz2
trunk-36060-master.zip
Diffstat (limited to 'tools/mtools')
-rw-r--r--tools/mtools/.svn/entries62
-rw-r--r--tools/mtools/.svn/text-base/Makefile.svn-base33
-rw-r--r--tools/mtools/Makefile33
3 files changed, 128 insertions, 0 deletions
diff --git a/tools/mtools/.svn/entries b/tools/mtools/.svn/entries
new file mode 100644
index 0000000..6aaba1a
--- /dev/null
+++ b/tools/mtools/.svn/entries
@@ -0,0 +1,62 @@
+10
+
+dir
+36060
+svn://svn.openwrt.org/openwrt/trunk/tools/mtools
+svn://svn.openwrt.org/openwrt
+
+
+
+2012-08-12T12:34:30.330423Z
+33140
+jow
+
+
+
+
+
+
+
+
+
+
+
+
+
+
+3c298f89-4303-0410-b956-a3cf2f4a3e73
+
+Makefile
+file
+
+
+
+
+2013-03-17T12:13:23.000000Z
+3a90f2a00c3c554cf34f67ab1969c5d4
+2012-08-12T12:34:30.330423Z
+33140
+jow
+
+
+
+
+
+
+
+
+
+
+
+
+
+
+
+
+
+
+
+
+
+678
+
diff --git a/tools/mtools/.svn/text-base/Makefile.svn-base b/tools/mtools/.svn/text-base/Makefile.svn-base
new file mode 100644
index 0000000..8d227c1
--- /dev/null
+++ b/tools/mtools/.svn/text-base/Makefile.svn-base
@@ -0,0 +1,33 @@
+#
+# Copyright (C) 2012 OpenWrt.org
+#
+# This is free software, licensed under the GNU General Public License v2.
+# See /LICENSE for more information.
+#
+include $(TOPDIR)/rules.mk
+
+PKG_NAME:=mtools
+PKG_VERSION:=4.0.17
+
+PKG_SOURCE:=$(PKG_NAME)-$(PKG_VERSION).tar.gz
+PKG_SOURCE_URL:=@GNU/$(PKG_NAME)
+PKG_MD5SUM:=231741ac95802d03aa32f44edb768171
+PKG_CAT:=zcat
+
+include $(INCLUDE_DIR)/host-build.mk
+
+HOST_LDFLAGS += $(HOST_STATIC_LINKING)
+
+define Host/Compile
+ $(MAKE) -C $(HOST_BUILD_DIR) mcopy
+endef
+
+define Host/Install
+ $(INSTALL_BIN) $(HOST_BUILD_DIR)/mcopy $(STAGING_DIR_HOST)/bin/
+endef
+
+define Host/Clean
+ rm -f $(STAGING_DIR_HOST)/bin/mcopy
+endef
+
+$(eval $(call HostBuild))
diff --git a/tools/mtools/Makefile b/tools/mtools/Makefile
new file mode 100644
index 0000000..8d227c1
--- /dev/null
+++ b/tools/mtools/Makefile
@@ -0,0 +1,33 @@
+#
+# Copyright (C) 2012 OpenWrt.org
+#
+# This is free software, licensed under the GNU General Public License v2.
+# See /LICENSE for more information.
+#
+include $(TOPDIR)/rules.mk
+
+PKG_NAME:=mtools
+PKG_VERSION:=4.0.17
+
+PKG_SOURCE:=$(PKG_NAME)-$(PKG_VERSION).tar.gz
+PKG_SOURCE_URL:=@GNU/$(PKG_NAME)
+PKG_MD5SUM:=231741ac95802d03aa32f44edb768171
+PKG_CAT:=zcat
+
+include $(INCLUDE_DIR)/host-build.mk
+
+HOST_LDFLAGS += $(HOST_STATIC_LINKING)
+
+define Host/Compile
+ $(MAKE) -C $(HOST_BUILD_DIR) mcopy
+endef
+
+define Host/Install
+ $(INSTALL_BIN) $(HOST_BUILD_DIR)/mcopy $(STAGING_DIR_HOST)/bin/
+endef
+
+define Host/Clean
+ rm -f $(STAGING_DIR_HOST)/bin/mcopy
+endef
+
+$(eval $(call HostBuild))