aboutsummaryrefslogtreecommitdiffstats
path: root/tools/mpfr
diff options
context:
space:
mode:
authorJames <>2013-03-17 12:16:37 +0000
committerJames <>2013-03-17 12:16:37 +0000
commit27b76ab0671089c47506615a796a261e993896a7 (patch)
tree61213d67e7fa87b20356b23798558e2c4212c42f /tools/mpfr
downloadtrunk-36060-master.tar.gz
trunk-36060-master.tar.bz2
trunk-36060-master.zip
Diffstat (limited to 'tools/mpfr')
-rw-r--r--tools/mpfr/.svn/entries65
-rw-r--r--tools/mpfr/.svn/text-base/Makefile.svn-base26
-rw-r--r--tools/mpfr/Makefile26
-rw-r--r--tools/mpfr/patches/.svn/entries62
-rw-r--r--tools/mpfr/patches/.svn/text-base/001-only_src.patch.svn-base22
-rw-r--r--tools/mpfr/patches/001-only_src.patch22
6 files changed, 223 insertions, 0 deletions
diff --git a/tools/mpfr/.svn/entries b/tools/mpfr/.svn/entries
new file mode 100644
index 0000000..45f719c
--- /dev/null
+++ b/tools/mpfr/.svn/entries
@@ -0,0 +1,65 @@
+10
+
+dir
+36060
+svn://svn.openwrt.org/openwrt/trunk/tools/mpfr
+svn://svn.openwrt.org/openwrt
+
+
+
+2013-02-28T00:52:36.046930Z
+35828
+luka
+
+
+
+
+
+
+
+
+
+
+
+
+
+
+3c298f89-4303-0410-b956-a3cf2f4a3e73
+
+patches
+dir
+
+Makefile
+file
+
+
+
+
+2013-03-17T12:13:22.000000Z
+3c463efa7c4034c09c52ca2ce4d24f6d
+2013-02-28T00:52:36.046930Z
+35828
+luka
+
+
+
+
+
+
+
+
+
+
+
+
+
+
+
+
+
+
+
+
+
+576
+
diff --git a/tools/mpfr/.svn/text-base/Makefile.svn-base b/tools/mpfr/.svn/text-base/Makefile.svn-base
new file mode 100644
index 0000000..e34830a
--- /dev/null
+++ b/tools/mpfr/.svn/text-base/Makefile.svn-base
@@ -0,0 +1,26 @@
+#
+# Copyright (C) 2009-2013 OpenWrt.org
+#
+# This is free software, licensed under the GNU General Public License v2.
+# See /LICENSE for more information.
+#
+include $(TOPDIR)/rules.mk
+
+PKG_NAME:=mpfr
+PKG_VERSION:=3.1.1
+
+PKG_SOURCE_URL:=http://www.mpfr.org/mpfr-$(PKG_VERSION)
+PKG_SOURCE:=$(PKG_NAME)-$(PKG_VERSION).tar.bz2
+PKG_MD5SUM:=e90e0075bb1b5f626c6e31aaa9c64e3b
+
+HOST_BUILD_PARALLEL:=1
+HOST_FIXUP:=autoreconf
+
+include $(INCLUDE_DIR)/host-build.mk
+
+HOST_CONFIGURE_ARGS += \
+ --enable-static \
+ --disable-shared \
+ --with-gmp=$(STAGING_DIR_HOST)
+
+$(eval $(call HostBuild))
diff --git a/tools/mpfr/Makefile b/tools/mpfr/Makefile
new file mode 100644
index 0000000..e34830a
--- /dev/null
+++ b/tools/mpfr/Makefile
@@ -0,0 +1,26 @@
+#
+# Copyright (C) 2009-2013 OpenWrt.org
+#
+# This is free software, licensed under the GNU General Public License v2.
+# See /LICENSE for more information.
+#
+include $(TOPDIR)/rules.mk
+
+PKG_NAME:=mpfr
+PKG_VERSION:=3.1.1
+
+PKG_SOURCE_URL:=http://www.mpfr.org/mpfr-$(PKG_VERSION)
+PKG_SOURCE:=$(PKG_NAME)-$(PKG_VERSION).tar.bz2
+PKG_MD5SUM:=e90e0075bb1b5f626c6e31aaa9c64e3b
+
+HOST_BUILD_PARALLEL:=1
+HOST_FIXUP:=autoreconf
+
+include $(INCLUDE_DIR)/host-build.mk
+
+HOST_CONFIGURE_ARGS += \
+ --enable-static \
+ --disable-shared \
+ --with-gmp=$(STAGING_DIR_HOST)
+
+$(eval $(call HostBuild))
diff --git a/tools/mpfr/patches/.svn/entries b/tools/mpfr/patches/.svn/entries
new file mode 100644
index 0000000..a6c4542
--- /dev/null
+++ b/tools/mpfr/patches/.svn/entries
@@ -0,0 +1,62 @@
+10
+
+dir
+36060
+svn://svn.openwrt.org/openwrt/trunk/tools/mpfr/patches
+svn://svn.openwrt.org/openwrt
+
+
+
+2013-02-28T00:52:36.046930Z
+35828
+luka
+
+
+
+
+
+
+
+
+
+
+
+
+
+
+3c298f89-4303-0410-b956-a3cf2f4a3e73
+
+001-only_src.patch
+file
+
+
+
+
+2013-03-17T12:13:22.000000Z
+533c33190be16e9886629d08a39def4a
+2013-02-28T00:52:36.046930Z
+35828
+luka
+
+
+
+
+
+
+
+
+
+
+
+
+
+
+
+
+
+
+
+
+
+683
+
diff --git a/tools/mpfr/patches/.svn/text-base/001-only_src.patch.svn-base b/tools/mpfr/patches/.svn/text-base/001-only_src.patch.svn-base
new file mode 100644
index 0000000..e6579b2
--- /dev/null
+++ b/tools/mpfr/patches/.svn/text-base/001-only_src.patch.svn-base
@@ -0,0 +1,22 @@
+--- a/Makefile.am
++++ b/Makefile.am
+@@ -12,7 +12,7 @@
+ AUTOMAKE_OPTIONS = gnu
+ ACLOCAL_AMFLAGS = -I m4
+
+-SUBDIRS = doc src tests tune
++SUBDIRS = src
+
+ nobase_dist_doc_DATA = AUTHORS BUGS COPYING COPYING.LESSER NEWS TODO \
+ examples/ReadMe examples/divworst.c examples/rndo-add.c examples/sample.c \
+--- a/Makefile.in
++++ b/Makefile.in
+@@ -294,7 +294,7 @@ top_builddir = @top_builddir@
+ top_srcdir = @top_srcdir@
+ AUTOMAKE_OPTIONS = gnu
+ ACLOCAL_AMFLAGS = -I m4
+-SUBDIRS = doc src tests tune
++SUBDIRS = src
+ nobase_dist_doc_DATA = AUTHORS BUGS COPYING COPYING.LESSER NEWS TODO \
+ examples/ReadMe examples/divworst.c examples/rndo-add.c examples/sample.c \
+ examples/version.c
diff --git a/tools/mpfr/patches/001-only_src.patch b/tools/mpfr/patches/001-only_src.patch
new file mode 100644
index 0000000..e6579b2
--- /dev/null
+++ b/tools/mpfr/patches/001-only_src.patch
@@ -0,0 +1,22 @@
+--- a/Makefile.am
++++ b/Makefile.am
+@@ -12,7 +12,7 @@
+ AUTOMAKE_OPTIONS = gnu
+ ACLOCAL_AMFLAGS = -I m4
+
+-SUBDIRS = doc src tests tune
++SUBDIRS = src
+
+ nobase_dist_doc_DATA = AUTHORS BUGS COPYING COPYING.LESSER NEWS TODO \
+ examples/ReadMe examples/divworst.c examples/rndo-add.c examples/sample.c \
+--- a/Makefile.in
++++ b/Makefile.in
+@@ -294,7 +294,7 @@ top_builddir = @top_builddir@
+ top_srcdir = @top_srcdir@
+ AUTOMAKE_OPTIONS = gnu
+ ACLOCAL_AMFLAGS = -I m4
+-SUBDIRS = doc src tests tune
++SUBDIRS = src
+ nobase_dist_doc_DATA = AUTHORS BUGS COPYING COPYING.LESSER NEWS TODO \
+ examples/ReadMe examples/divworst.c examples/rndo-add.c examples/sample.c \
+ examples/version.c