aboutsummaryrefslogtreecommitdiffstats
path: root/tools/m4
diff options
context:
space:
mode:
authorJames <>2013-03-17 12:16:37 +0000
committerJames <>2013-03-17 12:16:37 +0000
commit27b76ab0671089c47506615a796a261e993896a7 (patch)
tree61213d67e7fa87b20356b23798558e2c4212c42f /tools/m4
downloadtrunk-36060-27b76ab0671089c47506615a796a261e993896a7.tar.gz
trunk-36060-27b76ab0671089c47506615a796a261e993896a7.tar.bz2
trunk-36060-27b76ab0671089c47506615a796a261e993896a7.zip
Diffstat (limited to 'tools/m4')
-rw-r--r--tools/m4/.svn/entries65
-rw-r--r--tools/m4/.svn/text-base/Makefile.svn-base30
-rw-r--r--tools/m4/Makefile30
-rw-r--r--tools/m4/patches/.svn/entries62
-rw-r--r--tools/m4/patches/.svn/text-base/100-fix-gets-removal.patch.svn-base15
-rw-r--r--tools/m4/patches/100-fix-gets-removal.patch15
6 files changed, 217 insertions, 0 deletions
diff --git a/tools/m4/.svn/entries b/tools/m4/.svn/entries
new file mode 100644
index 0000000..44d044d
--- /dev/null
+++ b/tools/m4/.svn/entries
@@ -0,0 +1,65 @@
+10
+
+dir
+36060
+svn://svn.openwrt.org/openwrt/trunk/tools/m4
+svn://svn.openwrt.org/openwrt
+
+
+
+2012-09-15T14:17:28.144915Z
+33427
+nbd
+
+
+
+
+
+
+
+
+
+
+
+
+
+
+3c298f89-4303-0410-b956-a3cf2f4a3e73
+
+patches
+dir
+
+Makefile
+file
+
+
+
+
+2013-03-17T12:13:22.000000Z
+21d1cee10f9e6ade6296083dbdded34d
+2012-09-15T14:17:28.144915Z
+33427
+nbd
+
+
+
+
+
+
+
+
+
+
+
+
+
+
+
+
+
+
+
+
+
+632
+
diff --git a/tools/m4/.svn/text-base/Makefile.svn-base b/tools/m4/.svn/text-base/Makefile.svn-base
new file mode 100644
index 0000000..080eb5d
--- /dev/null
+++ b/tools/m4/.svn/text-base/Makefile.svn-base
@@ -0,0 +1,30 @@
+#
+# Copyright (C) 2008-2012 OpenWrt.org
+#
+# This is free software, licensed under the GNU General Public License v2.
+# See /LICENSE for more information.
+#
+include $(TOPDIR)/rules.mk
+
+PKG_NAME:=m4
+PKG_VERSION:=1.4.16
+
+PKG_SOURCE:=$(PKG_NAME)-$(PKG_VERSION).tar.gz
+PKG_SOURCE_URL:=@GNU/$(PKG_NAME)
+PKG_MD5SUM:=a5dfb4f2b7370e9d34293d23fd09b280
+PKG_CAT:=zcat
+
+HOST_BUILD_PARALLEL:=1
+
+include $(INCLUDE_DIR)/host-build.mk
+
+HOST_CONFIGURE_VARS += gl_cv_func_strstr_linear=no
+
+HOST_LDFLAGS += $(HOST_STATIC_LINKING)
+
+define Host/Clean
+ -$(MAKE) -C $(HOST_BUILD_DIR) uninstall
+ $(call Host/Clean/Default)
+endef
+
+$(eval $(call HostBuild))
diff --git a/tools/m4/Makefile b/tools/m4/Makefile
new file mode 100644
index 0000000..080eb5d
--- /dev/null
+++ b/tools/m4/Makefile
@@ -0,0 +1,30 @@
+#
+# Copyright (C) 2008-2012 OpenWrt.org
+#
+# This is free software, licensed under the GNU General Public License v2.
+# See /LICENSE for more information.
+#
+include $(TOPDIR)/rules.mk
+
+PKG_NAME:=m4
+PKG_VERSION:=1.4.16
+
+PKG_SOURCE:=$(PKG_NAME)-$(PKG_VERSION).tar.gz
+PKG_SOURCE_URL:=@GNU/$(PKG_NAME)
+PKG_MD5SUM:=a5dfb4f2b7370e9d34293d23fd09b280
+PKG_CAT:=zcat
+
+HOST_BUILD_PARALLEL:=1
+
+include $(INCLUDE_DIR)/host-build.mk
+
+HOST_CONFIGURE_VARS += gl_cv_func_strstr_linear=no
+
+HOST_LDFLAGS += $(HOST_STATIC_LINKING)
+
+define Host/Clean
+ -$(MAKE) -C $(HOST_BUILD_DIR) uninstall
+ $(call Host/Clean/Default)
+endef
+
+$(eval $(call HostBuild))
diff --git a/tools/m4/patches/.svn/entries b/tools/m4/patches/.svn/entries
new file mode 100644
index 0000000..94605e7
--- /dev/null
+++ b/tools/m4/patches/.svn/entries
@@ -0,0 +1,62 @@
+10
+
+dir
+36060
+svn://svn.openwrt.org/openwrt/trunk/tools/m4/patches
+svn://svn.openwrt.org/openwrt
+
+
+
+2012-07-08T15:28:44.919107Z
+32648
+jow
+
+
+
+
+
+
+
+
+
+
+
+
+
+
+3c298f89-4303-0410-b956-a3cf2f4a3e73
+
+100-fix-gets-removal.patch
+file
+
+
+
+
+2013-03-17T12:13:22.000000Z
+c80bc23bcb6549a61e621a01bf2d3ba2
+2012-07-08T15:28:44.919107Z
+32648
+jow
+
+
+
+
+
+
+
+
+
+
+
+
+
+
+
+
+
+
+
+
+
+575
+
diff --git a/tools/m4/patches/.svn/text-base/100-fix-gets-removal.patch.svn-base b/tools/m4/patches/.svn/text-base/100-fix-gets-removal.patch.svn-base
new file mode 100644
index 0000000..be0ea85
--- /dev/null
+++ b/tools/m4/patches/.svn/text-base/100-fix-gets-removal.patch.svn-base
@@ -0,0 +1,15 @@
+--- a/lib/stdio.in.h
++++ b/lib/stdio.in.h
+@@ -158,12 +158,6 @@ _GL_WARN_ON_USE (fflush, "fflush is not
+ "use gnulib module fflush for portable POSIX compliance");
+ #endif
+
+-/* It is very rare that the developer ever has full control of stdin,
+- so any use of gets warrants an unconditional warning. Assume it is
+- always declared, since it is required by C89. */
+-#undef gets
+-_GL_WARN_ON_USE (gets, "gets is a security hole - use fgets instead");
+-
+ #if @GNULIB_FOPEN@
+ # if @REPLACE_FOPEN@
+ # if !(defined __cplusplus && defined GNULIB_NAMESPACE)
diff --git a/tools/m4/patches/100-fix-gets-removal.patch b/tools/m4/patches/100-fix-gets-removal.patch
new file mode 100644
index 0000000..be0ea85
--- /dev/null
+++ b/tools/m4/patches/100-fix-gets-removal.patch
@@ -0,0 +1,15 @@
+--- a/lib/stdio.in.h
++++ b/lib/stdio.in.h
+@@ -158,12 +158,6 @@ _GL_WARN_ON_USE (fflush, "fflush is not
+ "use gnulib module fflush for portable POSIX compliance");
+ #endif
+
+-/* It is very rare that the developer ever has full control of stdin,
+- so any use of gets warrants an unconditional warning. Assume it is
+- always declared, since it is required by C89. */
+-#undef gets
+-_GL_WARN_ON_USE (gets, "gets is a security hole - use fgets instead");
+-
+ #if @GNULIB_FOPEN@
+ # if @REPLACE_FOPEN@
+ # if !(defined __cplusplus && defined GNULIB_NAMESPACE)