aboutsummaryrefslogtreecommitdiffstats
path: root/tools/cloog
diff options
context:
space:
mode:
authorJames <>2013-03-17 12:16:37 +0000
committerJames <>2013-03-17 12:16:37 +0000
commit27b76ab0671089c47506615a796a261e993896a7 (patch)
tree61213d67e7fa87b20356b23798558e2c4212c42f /tools/cloog
downloadtrunk-36060-27b76ab0671089c47506615a796a261e993896a7.tar.gz
trunk-36060-27b76ab0671089c47506615a796a261e993896a7.tar.bz2
trunk-36060-27b76ab0671089c47506615a796a261e993896a7.zip
Diffstat (limited to 'tools/cloog')
-rw-r--r--tools/cloog/.svn/entries62
-rw-r--r--tools/cloog/.svn/text-base/Makefile.svn-base39
-rw-r--r--tools/cloog/Makefile39
3 files changed, 140 insertions, 0 deletions
diff --git a/tools/cloog/.svn/entries b/tools/cloog/.svn/entries
new file mode 100644
index 0000000..14e414a
--- /dev/null
+++ b/tools/cloog/.svn/entries
@@ -0,0 +1,62 @@
+10
+
+dir
+36060
+svn://svn.openwrt.org/openwrt/trunk/tools/cloog
+svn://svn.openwrt.org/openwrt
+
+
+
+2012-04-02T16:25:20.144464Z
+31170
+florian
+
+
+
+
+
+
+
+
+
+
+
+
+
+
+3c298f89-4303-0410-b956-a3cf2f4a3e73
+
+Makefile
+file
+
+
+
+
+2013-03-17T12:13:22.000000Z
+902c2c55a670e1d8423edd8195af55b5
+2012-04-02T16:25:20.144464Z
+31170
+florian
+
+
+
+
+
+
+
+
+
+
+
+
+
+
+
+
+
+
+
+
+
+756
+
diff --git a/tools/cloog/.svn/text-base/Makefile.svn-base b/tools/cloog/.svn/text-base/Makefile.svn-base
new file mode 100644
index 0000000..140d4db
--- /dev/null
+++ b/tools/cloog/.svn/text-base/Makefile.svn-base
@@ -0,0 +1,39 @@
+#
+# Copyright (C) 2009 OpenWrt.org
+#
+# This is free software, licensed under the GNU General Public License v2.
+# See /LICENSE for more information.
+#
+include $(TOPDIR)/rules.mk
+
+PKG_NAME:=cloog-ppl
+PKG_VERSION:=0.15.11
+
+PKG_SOURCE_URL:=ftp://gcc.gnu.org/pub/gcc/infrastructure
+PKG_SOURCE:=$(PKG_NAME)-$(PKG_VERSION).tar.gz
+PKG_MD5SUM:=060ae4df6fb8176e021b4d033a6c0b9e
+
+HOST_FIXUP:=autoreconf
+
+include $(INCLUDE_DIR)/host-build.mk
+
+unexport CFLAGS
+
+HOST_CONFIGURE_VARS += \
+ LIBS=-lstdc++
+
+HOST_CONFIGURE_ARGS += \
+ --enable-static \
+ --disable-shared \
+ --with-ppl=$(BUILD_DIR_HOST)
+
+define Host/Configure
+ (cd $(HOST_BUILD_DIR)/$(3); \
+ $(HOST_CONFIGURE_CMD) \
+ $(HOST_CONFIGURE_VARS) \
+ $(HOST_CONFIGURE_ARGS); \
+ )
+endef
+
+
+$(eval $(call HostBuild))
diff --git a/tools/cloog/Makefile b/tools/cloog/Makefile
new file mode 100644
index 0000000..140d4db
--- /dev/null
+++ b/tools/cloog/Makefile
@@ -0,0 +1,39 @@
+#
+# Copyright (C) 2009 OpenWrt.org
+#
+# This is free software, licensed under the GNU General Public License v2.
+# See /LICENSE for more information.
+#
+include $(TOPDIR)/rules.mk
+
+PKG_NAME:=cloog-ppl
+PKG_VERSION:=0.15.11
+
+PKG_SOURCE_URL:=ftp://gcc.gnu.org/pub/gcc/infrastructure
+PKG_SOURCE:=$(PKG_NAME)-$(PKG_VERSION).tar.gz
+PKG_MD5SUM:=060ae4df6fb8176e021b4d033a6c0b9e
+
+HOST_FIXUP:=autoreconf
+
+include $(INCLUDE_DIR)/host-build.mk
+
+unexport CFLAGS
+
+HOST_CONFIGURE_VARS += \
+ LIBS=-lstdc++
+
+HOST_CONFIGURE_ARGS += \
+ --enable-static \
+ --disable-shared \
+ --with-ppl=$(BUILD_DIR_HOST)
+
+define Host/Configure
+ (cd $(HOST_BUILD_DIR)/$(3); \
+ $(HOST_CONFIGURE_CMD) \
+ $(HOST_CONFIGURE_VARS) \
+ $(HOST_CONFIGURE_ARGS); \
+ )
+endef
+
+
+$(eval $(call HostBuild))