aboutsummaryrefslogtreecommitdiffstats
path: root/tools/ccache
diff options
context:
space:
mode:
authorJames <>2013-03-17 12:16:37 +0000
committerJames <>2013-03-17 12:16:37 +0000
commit27b76ab0671089c47506615a796a261e993896a7 (patch)
tree61213d67e7fa87b20356b23798558e2c4212c42f /tools/ccache
downloadtrunk-36060-master.tar.gz
trunk-36060-master.tar.bz2
trunk-36060-master.zip
Diffstat (limited to 'tools/ccache')
-rw-r--r--tools/ccache/.svn/entries65
-rw-r--r--tools/ccache/.svn/text-base/Makefile.svn-base52
-rw-r--r--tools/ccache/Makefile52
-rw-r--r--tools/ccache/files/.svn/entries96
-rw-r--r--tools/ccache/files/.svn/prop-base/ccache_cc.svn-base5
-rw-r--r--tools/ccache/files/.svn/prop-base/ccache_cxx.svn-base5
-rw-r--r--tools/ccache/files/.svn/text-base/ccache_cc.svn-base2
-rw-r--r--tools/ccache/files/.svn/text-base/ccache_cxx.svn-base2
-rwxr-xr-xtools/ccache/files/ccache_cc2
-rwxr-xr-xtools/ccache/files/ccache_cxx2
10 files changed, 283 insertions, 0 deletions
diff --git a/tools/ccache/.svn/entries b/tools/ccache/.svn/entries
new file mode 100644
index 0000000..41f403f
--- /dev/null
+++ b/tools/ccache/.svn/entries
@@ -0,0 +1,65 @@
+10
+
+dir
+36060
+svn://svn.openwrt.org/openwrt/trunk/tools/ccache
+svn://svn.openwrt.org/openwrt
+
+
+
+2013-02-27T23:08:02.911935Z
+35821
+luka
+
+
+
+
+
+
+
+
+
+
+
+
+
+
+3c298f89-4303-0410-b956-a3cf2f4a3e73
+
+files
+dir
+
+Makefile
+file
+
+
+
+
+2013-03-17T12:13:22.000000Z
+4ba2fc1ea78cc6591237702456abfd40
+2013-02-27T23:08:02.911935Z
+35821
+luka
+
+
+
+
+
+
+
+
+
+
+
+
+
+
+
+
+
+
+
+
+
+1132
+
diff --git a/tools/ccache/.svn/text-base/Makefile.svn-base b/tools/ccache/.svn/text-base/Makefile.svn-base
new file mode 100644
index 0000000..aeac393
--- /dev/null
+++ b/tools/ccache/.svn/text-base/Makefile.svn-base
@@ -0,0 +1,52 @@
+#
+# Copyright (C) 2006-2013 OpenWrt.org
+#
+# This is free software, licensed under the GNU General Public License v2.
+# See /LICENSE for more information.
+#
+include $(TOPDIR)/rules.mk
+include $(INCLUDE_DIR)/target.mk
+
+PKG_NAME:=ccache
+PKG_VERSION:=3.1.9
+
+PKG_SOURCE:=$(PKG_NAME)-$(PKG_VERSION).tar.xz
+PKG_SOURCE_URL:=http://samba.org/ftp/ccache/
+PKG_MD5SUM:=522a6016bda56892653612bbdefff3e0
+
+include $(INCLUDE_DIR)/host-build.mk
+
+HOST_LDFLAGS += $(HOST_STATIC_LINKING)
+HOST_CONFIGURE_VARS += CC="$(HOSTCC_NOCACHE)"
+
+define Host/Install/ccache
+ $(INSTALL_DIR) $(STAGING_DIR_HOST)/bin/
+ $(CP) ./files/* $(STAGING_DIR_HOST)/bin/
+endef
+
+ifneq ($(strip $(shell which ccache >/dev/null && echo found)),found)
+ define Host/Clean
+ -$(MAKE) -C $(HOST_BUILD_DIR) uninstall
+ $(call Host/Clean/Default)
+ endef
+ define Host/Install
+ $(call Host/Install/Default)
+ $(call Host/Install/ccache)
+ endef
+else
+ define Host/Prepare
+ endef
+ define Host/Configure
+ endef
+ define Host/Compile
+ endef
+ define Host/Install
+ $(call Host/Install/ccache)
+ endef
+ define Host/Clean
+ endef
+ define Download
+ endef
+endif
+
+$(eval $(call HostBuild))
diff --git a/tools/ccache/Makefile b/tools/ccache/Makefile
new file mode 100644
index 0000000..aeac393
--- /dev/null
+++ b/tools/ccache/Makefile
@@ -0,0 +1,52 @@
+#
+# Copyright (C) 2006-2013 OpenWrt.org
+#
+# This is free software, licensed under the GNU General Public License v2.
+# See /LICENSE for more information.
+#
+include $(TOPDIR)/rules.mk
+include $(INCLUDE_DIR)/target.mk
+
+PKG_NAME:=ccache
+PKG_VERSION:=3.1.9
+
+PKG_SOURCE:=$(PKG_NAME)-$(PKG_VERSION).tar.xz
+PKG_SOURCE_URL:=http://samba.org/ftp/ccache/
+PKG_MD5SUM:=522a6016bda56892653612bbdefff3e0
+
+include $(INCLUDE_DIR)/host-build.mk
+
+HOST_LDFLAGS += $(HOST_STATIC_LINKING)
+HOST_CONFIGURE_VARS += CC="$(HOSTCC_NOCACHE)"
+
+define Host/Install/ccache
+ $(INSTALL_DIR) $(STAGING_DIR_HOST)/bin/
+ $(CP) ./files/* $(STAGING_DIR_HOST)/bin/
+endef
+
+ifneq ($(strip $(shell which ccache >/dev/null && echo found)),found)
+ define Host/Clean
+ -$(MAKE) -C $(HOST_BUILD_DIR) uninstall
+ $(call Host/Clean/Default)
+ endef
+ define Host/Install
+ $(call Host/Install/Default)
+ $(call Host/Install/ccache)
+ endef
+else
+ define Host/Prepare
+ endef
+ define Host/Configure
+ endef
+ define Host/Compile
+ endef
+ define Host/Install
+ $(call Host/Install/ccache)
+ endef
+ define Host/Clean
+ endef
+ define Download
+ endef
+endif
+
+$(eval $(call HostBuild))
diff --git a/tools/ccache/files/.svn/entries b/tools/ccache/files/.svn/entries
new file mode 100644
index 0000000..f4f41a2
--- /dev/null
+++ b/tools/ccache/files/.svn/entries
@@ -0,0 +1,96 @@
+10
+
+dir
+36060
+svn://svn.openwrt.org/openwrt/trunk/tools/ccache/files
+svn://svn.openwrt.org/openwrt
+
+
+
+2012-06-06T13:27:11.585623Z
+32075
+blogic
+
+
+
+
+
+
+
+
+
+
+
+
+
+
+3c298f89-4303-0410-b956-a3cf2f4a3e73
+
+ccache_cxx
+file
+
+
+
+
+2013-03-17T12:13:22.000000Z
+b114c928783a72763b0c338becaf69ae
+2012-06-06T13:27:11.585623Z
+32075
+blogic
+has-props
+
+
+
+
+
+
+
+
+
+
+
+
+
+
+
+
+
+
+
+
+51
+
+ccache_cc
+file
+
+
+
+
+2013-03-17T12:13:22.000000Z
+7594b0f4383f116e67d3421420ad02ae
+2012-06-06T13:27:11.585623Z
+32075
+blogic
+has-props
+
+
+
+
+
+
+
+
+
+
+
+
+
+
+
+
+
+
+
+
+50
+
diff --git a/tools/ccache/files/.svn/prop-base/ccache_cc.svn-base b/tools/ccache/files/.svn/prop-base/ccache_cc.svn-base
new file mode 100644
index 0000000..869ac71
--- /dev/null
+++ b/tools/ccache/files/.svn/prop-base/ccache_cc.svn-base
@@ -0,0 +1,5 @@
+K 14
+svn:executable
+V 1
+*
+END
diff --git a/tools/ccache/files/.svn/prop-base/ccache_cxx.svn-base b/tools/ccache/files/.svn/prop-base/ccache_cxx.svn-base
new file mode 100644
index 0000000..869ac71
--- /dev/null
+++ b/tools/ccache/files/.svn/prop-base/ccache_cxx.svn-base
@@ -0,0 +1,5 @@
+K 14
+svn:executable
+V 1
+*
+END
diff --git a/tools/ccache/files/.svn/text-base/ccache_cc.svn-base b/tools/ccache/files/.svn/text-base/ccache_cc.svn-base
new file mode 100644
index 0000000..01c4ad4
--- /dev/null
+++ b/tools/ccache/files/.svn/text-base/ccache_cc.svn-base
@@ -0,0 +1,2 @@
+#!/bin/sh
+exec ccache "${TARGET_CC_NOCACHE}" "$@"
diff --git a/tools/ccache/files/.svn/text-base/ccache_cxx.svn-base b/tools/ccache/files/.svn/text-base/ccache_cxx.svn-base
new file mode 100644
index 0000000..cc60eb3
--- /dev/null
+++ b/tools/ccache/files/.svn/text-base/ccache_cxx.svn-base
@@ -0,0 +1,2 @@
+#!/bin/sh
+exec ccache "${TARGET_CXX_NOCACHE}" "$@"
diff --git a/tools/ccache/files/ccache_cc b/tools/ccache/files/ccache_cc
new file mode 100755
index 0000000..01c4ad4
--- /dev/null
+++ b/tools/ccache/files/ccache_cc
@@ -0,0 +1,2 @@
+#!/bin/sh
+exec ccache "${TARGET_CC_NOCACHE}" "$@"
diff --git a/tools/ccache/files/ccache_cxx b/tools/ccache/files/ccache_cxx
new file mode 100755
index 0000000..cc60eb3
--- /dev/null
+++ b/tools/ccache/files/ccache_cxx
@@ -0,0 +1,2 @@
+#!/bin/sh
+exec ccache "${TARGET_CXX_NOCACHE}" "$@"