aboutsummaryrefslogtreecommitdiffstats
path: root/toolchain/gdb
diff options
context:
space:
mode:
authorJames <>2013-03-17 12:16:37 +0000
committerJames <>2013-03-17 12:16:37 +0000
commit27b76ab0671089c47506615a796a261e993896a7 (patch)
tree61213d67e7fa87b20356b23798558e2c4212c42f /toolchain/gdb
downloadtrunk-36060-master.tar.gz
trunk-36060-master.tar.bz2
trunk-36060-master.zip
Diffstat (limited to 'toolchain/gdb')
-rw-r--r--toolchain/gdb/.svn/dir-prop-base6
-rw-r--r--toolchain/gdb/.svn/entries65
-rw-r--r--toolchain/gdb/.svn/prop-base/Makefile.svn-base5
-rw-r--r--toolchain/gdb/.svn/text-base/Makefile.svn-base54
-rw-r--r--toolchain/gdb/Makefile54
-rw-r--r--toolchain/gdb/patches/.svn/entries130
-rw-r--r--toolchain/gdb/patches/.svn/text-base/100-ppc_compile_fix.patch.svn-base11
-rw-r--r--toolchain/gdb/patches/.svn/text-base/200-linux_musl.patch.svn-base22
-rw-r--r--toolchain/gdb/patches/.svn/text-base/600-fix-compile-flag-mismatch.patch.svn-base32
-rw-r--r--toolchain/gdb/patches/100-ppc_compile_fix.patch11
-rw-r--r--toolchain/gdb/patches/200-linux_musl.patch22
-rw-r--r--toolchain/gdb/patches/600-fix-compile-flag-mismatch.patch32
12 files changed, 444 insertions, 0 deletions
diff --git a/toolchain/gdb/.svn/dir-prop-base b/toolchain/gdb/.svn/dir-prop-base
new file mode 100644
index 0000000..9832dc3
--- /dev/null
+++ b/toolchain/gdb/.svn/dir-prop-base
@@ -0,0 +1,6 @@
+K 10
+svn:ignore
+V 5
+*gdb
+
+END
diff --git a/toolchain/gdb/.svn/entries b/toolchain/gdb/.svn/entries
new file mode 100644
index 0000000..8d994fa
--- /dev/null
+++ b/toolchain/gdb/.svn/entries
@@ -0,0 +1,65 @@
+10
+
+dir
+36060
+svn://svn.openwrt.org/openwrt/trunk/toolchain/gdb
+svn://svn.openwrt.org/openwrt
+
+
+
+2012-11-23T20:02:29.961566Z
+34314
+florian
+has-props
+
+
+
+
+
+
+
+
+
+
+
+
+
+3c298f89-4303-0410-b956-a3cf2f4a3e73
+
+patches
+dir
+
+Makefile
+file
+
+
+
+
+2013-03-17T12:13:25.000000Z
+9fd0275936d28b16b70e45257683b1d3
+2012-10-13T19:19:34.732938Z
+33757
+florian
+has-props
+
+
+
+
+
+
+
+
+
+
+
+
+
+
+
+
+
+
+
+
+1376
+
diff --git a/toolchain/gdb/.svn/prop-base/Makefile.svn-base b/toolchain/gdb/.svn/prop-base/Makefile.svn-base
new file mode 100644
index 0000000..bdbd305
--- /dev/null
+++ b/toolchain/gdb/.svn/prop-base/Makefile.svn-base
@@ -0,0 +1,5 @@
+K 13
+svn:eol-style
+V 6
+native
+END
diff --git a/toolchain/gdb/.svn/text-base/Makefile.svn-base b/toolchain/gdb/.svn/text-base/Makefile.svn-base
new file mode 100644
index 0000000..89f73ef
--- /dev/null
+++ b/toolchain/gdb/.svn/text-base/Makefile.svn-base
@@ -0,0 +1,54 @@
+#
+# Copyright (C) 2006-2011 OpenWrt.org
+#
+# This is free software, licensed under the GNU General Public License v2.
+# See /LICENSE for more information.
+#
+include $(TOPDIR)/rules.mk
+
+PKG_NAME:=gdb
+PKG_REV:=7.5-2012.09
+PKG_VERSION_MAJOR:=7.5
+PKG_VERSION:=linaro-$(PKG_REV)
+
+PKG_SOURCE:=$(PKG_NAME)-$(PKG_VERSION).tar.bz2
+PKG_MD5SUM:=758c2da97c27f7b50ca48cb803eaa9aa
+PKG_SOURCE_URL:=http://launchpad.net/gdb-linaro/$(PKG_VERSION_MAJOR)/$(PKG_REV)/+download/
+
+HOST_BUILD_PARALLEL:=1
+
+include $(INCLUDE_DIR)/toolchain-build.mk
+
+define Host/Configure
+ (cd $(HOST_BUILD_DIR); \
+ gdb_cv_func_sigsetjmp=yes \
+ CFLAGS="-O2" \
+ $(HOST_BUILD_DIR)/configure \
+ --prefix=$(TOOLCHAIN_DIR) \
+ --build=$(GNU_HOST_NAME) \
+ --host=$(GNU_HOST_NAME) \
+ --target=$(REAL_GNU_TARGET_NAME) \
+ --disable-werror \
+ $(DISABLE_NLS) \
+ --without-uiout \
+ --disable-tui --disable-gdbtk --without-x \
+ --without-included-gettext \
+ --enable-threads \
+ );
+endef
+
+define Host/Install
+ mkdir -p $(TOOLCHAIN_DIR)/bin
+ $(INSTALL_BIN) $(HOST_BUILD_DIR)/gdb/gdb $(TOOLCHAIN_DIR)/bin/$(TARGET_CROSS)gdb
+ ln -fs $(TARGET_CROSS)gdb $(TOOLCHAIN_DIR)/bin/$(GNU_TARGET_NAME)-gdb
+ strip $(TOOLCHAIN_DIR)/bin/$(TARGET_CROSS)gdb
+endef
+
+define Host/Clean
+ rm -rf \
+ $(HOST_BUILD_DIR) \
+ $(TOOLCHAIN_DIR)/bin/$(TARGET_CROSS)gdb \
+ $(TOOLCHAIN_DIR)/bin/$(GNU_TARGET_NAME)-gdb
+endef
+
+$(eval $(call HostBuild))
diff --git a/toolchain/gdb/Makefile b/toolchain/gdb/Makefile
new file mode 100644
index 0000000..89f73ef
--- /dev/null
+++ b/toolchain/gdb/Makefile
@@ -0,0 +1,54 @@
+#
+# Copyright (C) 2006-2011 OpenWrt.org
+#
+# This is free software, licensed under the GNU General Public License v2.
+# See /LICENSE for more information.
+#
+include $(TOPDIR)/rules.mk
+
+PKG_NAME:=gdb
+PKG_REV:=7.5-2012.09
+PKG_VERSION_MAJOR:=7.5
+PKG_VERSION:=linaro-$(PKG_REV)
+
+PKG_SOURCE:=$(PKG_NAME)-$(PKG_VERSION).tar.bz2
+PKG_MD5SUM:=758c2da97c27f7b50ca48cb803eaa9aa
+PKG_SOURCE_URL:=http://launchpad.net/gdb-linaro/$(PKG_VERSION_MAJOR)/$(PKG_REV)/+download/
+
+HOST_BUILD_PARALLEL:=1
+
+include $(INCLUDE_DIR)/toolchain-build.mk
+
+define Host/Configure
+ (cd $(HOST_BUILD_DIR); \
+ gdb_cv_func_sigsetjmp=yes \
+ CFLAGS="-O2" \
+ $(HOST_BUILD_DIR)/configure \
+ --prefix=$(TOOLCHAIN_DIR) \
+ --build=$(GNU_HOST_NAME) \
+ --host=$(GNU_HOST_NAME) \
+ --target=$(REAL_GNU_TARGET_NAME) \
+ --disable-werror \
+ $(DISABLE_NLS) \
+ --without-uiout \
+ --disable-tui --disable-gdbtk --without-x \
+ --without-included-gettext \
+ --enable-threads \
+ );
+endef
+
+define Host/Install
+ mkdir -p $(TOOLCHAIN_DIR)/bin
+ $(INSTALL_BIN) $(HOST_BUILD_DIR)/gdb/gdb $(TOOLCHAIN_DIR)/bin/$(TARGET_CROSS)gdb
+ ln -fs $(TARGET_CROSS)gdb $(TOOLCHAIN_DIR)/bin/$(GNU_TARGET_NAME)-gdb
+ strip $(TOOLCHAIN_DIR)/bin/$(TARGET_CROSS)gdb
+endef
+
+define Host/Clean
+ rm -rf \
+ $(HOST_BUILD_DIR) \
+ $(TOOLCHAIN_DIR)/bin/$(TARGET_CROSS)gdb \
+ $(TOOLCHAIN_DIR)/bin/$(GNU_TARGET_NAME)-gdb
+endef
+
+$(eval $(call HostBuild))
diff --git a/toolchain/gdb/patches/.svn/entries b/toolchain/gdb/patches/.svn/entries
new file mode 100644
index 0000000..c6f9124
--- /dev/null
+++ b/toolchain/gdb/patches/.svn/entries
@@ -0,0 +1,130 @@
+10
+
+dir
+36060
+svn://svn.openwrt.org/openwrt/trunk/toolchain/gdb/patches
+svn://svn.openwrt.org/openwrt
+
+
+
+2012-11-23T20:02:29.961566Z
+34314
+florian
+
+
+
+
+
+
+
+
+
+
+
+
+
+
+3c298f89-4303-0410-b956-a3cf2f4a3e73
+
+600-fix-compile-flag-mismatch.patch
+file
+
+
+
+
+2013-03-17T12:13:25.000000Z
+2acda1e1c4c105efe60979d3a9ad1639
+2012-10-13T19:19:34.732938Z
+33757
+florian
+
+
+
+
+
+
+
+
+
+
+
+
+
+
+
+
+
+
+
+
+
+831
+
+100-ppc_compile_fix.patch
+file
+
+
+
+
+2013-03-17T12:13:25.000000Z
+54276bfdbd62121c88a0488b72a8e714
+2011-06-11T13:25:00.030737Z
+27155
+nbd
+
+
+
+
+
+
+
+
+
+
+
+
+
+
+
+
+
+
+
+
+
+419
+
+200-linux_musl.patch
+file
+
+
+
+
+2013-03-17T12:13:25.000000Z
+71feedd31fff88d5779b966bc155e1d9
+2012-11-23T20:02:29.961566Z
+34314
+florian
+
+
+
+
+
+
+
+
+
+
+
+
+
+
+
+
+
+
+
+
+
+1071
+
diff --git a/toolchain/gdb/patches/.svn/text-base/100-ppc_compile_fix.patch.svn-base b/toolchain/gdb/patches/.svn/text-base/100-ppc_compile_fix.patch.svn-base
new file mode 100644
index 0000000..4c5cb4e
--- /dev/null
+++ b/toolchain/gdb/patches/.svn/text-base/100-ppc_compile_fix.patch.svn-base
@@ -0,0 +1,11 @@
+--- a/sim/ppc/Makefile.in
++++ b/sim/ppc/Makefile.in
+@@ -551,7 +551,7 @@ PACKAGE_SRC = @sim_pk_src@
+ PACKAGE_OBJ = @sim_pk_obj@
+
+
+-psim: $(TARGETLIB) main.o $(LIBIBERTY_LIB) $(BFD_LIB) $(LIBS) $(LIBINTL_DEP)
++psim: $(TARGETLIB) main.o $(LIBIBERTY_LIB) $(BFD_LIB) $(LIBINTL_DEP)
+ $(CC) $(CFLAGS) $(SIM_CFLAGS) $(LDFLAGS) -o psim$(EXEEXT) main.o $(TARGETLIB) $(BFD_LIB) $(LIBINTL) $(LIBIBERTY_LIB) $(LIBS)
+
+ run: psim
diff --git a/toolchain/gdb/patches/.svn/text-base/200-linux_musl.patch.svn-base b/toolchain/gdb/patches/.svn/text-base/200-linux_musl.patch.svn-base
new file mode 100644
index 0000000..738bc8b
--- /dev/null
+++ b/toolchain/gdb/patches/.svn/text-base/200-linux_musl.patch.svn-base
@@ -0,0 +1,22 @@
+diff -urN gdb-linaro-7.5-2012.09/config.sub gdb-linaro-7.5-2012.09.new/config.sub
+--- gdb-linaro-7.5-2012.09/config.sub 2012-09-13 16:01:23.000000000 +0200
++++ gdb-linaro-7.5-2012.09.new/config.sub 2012-11-21 18:19:43.516916352 +0100
+@@ -126,7 +126,8 @@
+ linux-uclibc* | uclinux-uclibc* | uclinux-gnu* | kfreebsd*-gnu* | \
+ knetbsd*-gnu* | netbsd*-gnu* | \
+ kopensolaris*-gnu* | \
+- storm-chaos* | os2-emx* | rtmk-nova*)
++ storm-chaos* | os2-emx* | rtmk-nova* | \
++ linux-musl*)
+ os=-$maybe_os
+ basic_machine=`echo $1 | sed 's/^\(.*\)-\([^-]*-[^-]*\)$/\1/'`
+ ;;
+@@ -1360,7 +1361,7 @@
+ | -chorusos* | -chorusrdb* | -cegcc* \
+ | -cygwin* | -msys* | -pe* | -psos* | -moss* | -proelf* | -rtems* \
+ | -mingw32* | -linux-gnu* | -linux-android* \
+- | -linux-newlib* | -linux-uclibc* \
++ | -linux-newlib* | -linux-uclibc* | -linux-musl* \
+ | -uxpv* | -beos* | -mpeix* | -udk* \
+ | -interix* | -uwin* | -mks* | -rhapsody* | -darwin* | -opened* \
+ | -openstep* | -oskit* | -conix* | -pw32* | -nonstopux* \
diff --git a/toolchain/gdb/patches/.svn/text-base/600-fix-compile-flag-mismatch.patch.svn-base b/toolchain/gdb/patches/.svn/text-base/600-fix-compile-flag-mismatch.patch.svn-base
new file mode 100644
index 0000000..517cf12
--- /dev/null
+++ b/toolchain/gdb/patches/.svn/text-base/600-fix-compile-flag-mismatch.patch.svn-base
@@ -0,0 +1,32 @@
+--- a/gdb/configure 2012-09-13 16:01:22.000000000 +0200
++++ b/gdb/configure 2012-10-12 17:48:06.863908023 +0200
+@@ -828,8 +828,7 @@
+ YACC
+ YFLAGS
+ XMKMF'
+-ac_subdirs_all='testsuite
+-gdbtk
++ac_subdirs_all='gdbtk
+ multi-ice
+ gdbserver'
+
+@@ -5023,7 +5022,7 @@
+
+
+
+-subdirs="$subdirs testsuite"
++subdirs="$subdirs"
+
+
+ # Check whether to support alternative target configurations
+--- a/gdb/gdbserver/configure 2012-09-13 16:01:22.000000000 +0200
++++ b/gdb/gdbserver/configure 2012-10-12 17:49:29.775910147 +0200
+@@ -2173,7 +2173,7 @@
+ ac_cache_corrupted=: ;;
+ ,);;
+ *)
+- if test "x$ac_old_val" != "x$ac_new_val"; then
++ if test "`echo x$ac_old_val`" != "`echo x$ac_new_val`"; then
+ # differences in whitespace do not lead to failure.
+ ac_old_val_w=`echo x $ac_old_val`
+ ac_new_val_w=`echo x $ac_new_val`
diff --git a/toolchain/gdb/patches/100-ppc_compile_fix.patch b/toolchain/gdb/patches/100-ppc_compile_fix.patch
new file mode 100644
index 0000000..4c5cb4e
--- /dev/null
+++ b/toolchain/gdb/patches/100-ppc_compile_fix.patch
@@ -0,0 +1,11 @@
+--- a/sim/ppc/Makefile.in
++++ b/sim/ppc/Makefile.in
+@@ -551,7 +551,7 @@ PACKAGE_SRC = @sim_pk_src@
+ PACKAGE_OBJ = @sim_pk_obj@
+
+
+-psim: $(TARGETLIB) main.o $(LIBIBERTY_LIB) $(BFD_LIB) $(LIBS) $(LIBINTL_DEP)
++psim: $(TARGETLIB) main.o $(LIBIBERTY_LIB) $(BFD_LIB) $(LIBINTL_DEP)
+ $(CC) $(CFLAGS) $(SIM_CFLAGS) $(LDFLAGS) -o psim$(EXEEXT) main.o $(TARGETLIB) $(BFD_LIB) $(LIBINTL) $(LIBIBERTY_LIB) $(LIBS)
+
+ run: psim
diff --git a/toolchain/gdb/patches/200-linux_musl.patch b/toolchain/gdb/patches/200-linux_musl.patch
new file mode 100644
index 0000000..738bc8b
--- /dev/null
+++ b/toolchain/gdb/patches/200-linux_musl.patch
@@ -0,0 +1,22 @@
+diff -urN gdb-linaro-7.5-2012.09/config.sub gdb-linaro-7.5-2012.09.new/config.sub
+--- gdb-linaro-7.5-2012.09/config.sub 2012-09-13 16:01:23.000000000 +0200
++++ gdb-linaro-7.5-2012.09.new/config.sub 2012-11-21 18:19:43.516916352 +0100
+@@ -126,7 +126,8 @@
+ linux-uclibc* | uclinux-uclibc* | uclinux-gnu* | kfreebsd*-gnu* | \
+ knetbsd*-gnu* | netbsd*-gnu* | \
+ kopensolaris*-gnu* | \
+- storm-chaos* | os2-emx* | rtmk-nova*)
++ storm-chaos* | os2-emx* | rtmk-nova* | \
++ linux-musl*)
+ os=-$maybe_os
+ basic_machine=`echo $1 | sed 's/^\(.*\)-\([^-]*-[^-]*\)$/\1/'`
+ ;;
+@@ -1360,7 +1361,7 @@
+ | -chorusos* | -chorusrdb* | -cegcc* \
+ | -cygwin* | -msys* | -pe* | -psos* | -moss* | -proelf* | -rtems* \
+ | -mingw32* | -linux-gnu* | -linux-android* \
+- | -linux-newlib* | -linux-uclibc* \
++ | -linux-newlib* | -linux-uclibc* | -linux-musl* \
+ | -uxpv* | -beos* | -mpeix* | -udk* \
+ | -interix* | -uwin* | -mks* | -rhapsody* | -darwin* | -opened* \
+ | -openstep* | -oskit* | -conix* | -pw32* | -nonstopux* \
diff --git a/toolchain/gdb/patches/600-fix-compile-flag-mismatch.patch b/toolchain/gdb/patches/600-fix-compile-flag-mismatch.patch
new file mode 100644
index 0000000..517cf12
--- /dev/null
+++ b/toolchain/gdb/patches/600-fix-compile-flag-mismatch.patch
@@ -0,0 +1,32 @@
+--- a/gdb/configure 2012-09-13 16:01:22.000000000 +0200
++++ b/gdb/configure 2012-10-12 17:48:06.863908023 +0200
+@@ -828,8 +828,7 @@
+ YACC
+ YFLAGS
+ XMKMF'
+-ac_subdirs_all='testsuite
+-gdbtk
++ac_subdirs_all='gdbtk
+ multi-ice
+ gdbserver'
+
+@@ -5023,7 +5022,7 @@
+
+
+
+-subdirs="$subdirs testsuite"
++subdirs="$subdirs"
+
+
+ # Check whether to support alternative target configurations
+--- a/gdb/gdbserver/configure 2012-09-13 16:01:22.000000000 +0200
++++ b/gdb/gdbserver/configure 2012-10-12 17:49:29.775910147 +0200
+@@ -2173,7 +2173,7 @@
+ ac_cache_corrupted=: ;;
+ ,);;
+ *)
+- if test "x$ac_old_val" != "x$ac_new_val"; then
++ if test "`echo x$ac_old_val`" != "`echo x$ac_new_val`"; then
+ # differences in whitespace do not lead to failure.
+ ac_old_val_w=`echo x $ac_old_val`
+ ac_new_val_w=`echo x $ac_new_val`