aboutsummaryrefslogtreecommitdiffstats
path: root/toolchain/.svn
diff options
context:
space:
mode:
authorJames <>2013-03-17 12:16:37 +0000
committerJames <>2013-03-17 12:16:37 +0000
commit27b76ab0671089c47506615a796a261e993896a7 (patch)
tree61213d67e7fa87b20356b23798558e2c4212c42f /toolchain/.svn
downloadtrunk-36060-master.tar.gz
trunk-36060-master.tar.bz2
trunk-36060-master.zip
Diffstat (limited to 'toolchain/.svn')
-rw-r--r--toolchain/.svn/entries160
-rw-r--r--toolchain/.svn/prop-base/Config.in.svn-base5
-rw-r--r--toolchain/.svn/prop-base/Makefile.svn-base5
-rw-r--r--toolchain/.svn/text-base/Config.in.svn-base220
-rw-r--r--toolchain/.svn/text-base/Makefile.svn-base86
-rw-r--r--toolchain/.svn/text-base/info.mk.svn-base6
6 files changed, 482 insertions, 0 deletions
diff --git a/toolchain/.svn/entries b/toolchain/.svn/entries
new file mode 100644
index 0000000..971c275
--- /dev/null
+++ b/toolchain/.svn/entries
@@ -0,0 +1,160 @@
+10
+
+dir
+36060
+svn://svn.openwrt.org/openwrt/trunk/toolchain
+svn://svn.openwrt.org/openwrt
+
+
+
+2013-02-26T16:52:36.963466Z
+35816
+florian
+
+
+
+
+
+
+
+
+
+
+
+
+
+
+3c298f89-4303-0410-b956-a3cf2f4a3e73
+
+musl
+dir
+
+wrapper
+dir
+
+uClibc
+dir
+
+info.mk
+file
+
+
+
+
+2013-03-17T12:13:25.000000Z
+a3482af05526d378e63039473d6227fe
+2009-04-24T02:07:24.046924Z
+15368
+nico
+
+
+
+
+
+
+
+
+
+
+
+
+
+
+
+
+
+
+
+
+
+114
+
+eglibc
+dir
+
+insight
+dir
+
+binutils
+dir
+
+kernel-headers
+dir
+
+llvm
+dir
+
+Config.in
+file
+
+
+
+
+2013-03-17T12:13:25.000000Z
+27905aa2401ddb7eeccef9509344e387
+2013-02-20T15:06:10.027599Z
+35703
+jow
+has-props
+
+
+
+
+
+
+
+
+
+
+
+
+
+
+
+
+
+
+
+
+6238
+
+gcc
+dir
+
+gdb
+dir
+
+Makefile
+file
+
+
+
+
+2013-03-17T12:13:25.000000Z
+47ead6563d9be82a05fcc2b1c4a1e339
+2012-07-03T14:23:32.719514Z
+32584
+nbd
+has-props
+
+
+
+
+
+
+
+
+
+
+
+
+
+
+
+
+
+
+
+
+2952
+
diff --git a/toolchain/.svn/prop-base/Config.in.svn-base b/toolchain/.svn/prop-base/Config.in.svn-base
new file mode 100644
index 0000000..abd5821
--- /dev/null
+++ b/toolchain/.svn/prop-base/Config.in.svn-base
@@ -0,0 +1,5 @@
+K 13
+svn:eol-style
+V 2
+LF
+END
diff --git a/toolchain/.svn/prop-base/Makefile.svn-base b/toolchain/.svn/prop-base/Makefile.svn-base
new file mode 100644
index 0000000..bdbd305
--- /dev/null
+++ b/toolchain/.svn/prop-base/Makefile.svn-base
@@ -0,0 +1,5 @@
+K 13
+svn:eol-style
+V 6
+native
+END
diff --git a/toolchain/.svn/text-base/Config.in.svn-base b/toolchain/.svn/text-base/Config.in.svn-base
new file mode 100644
index 0000000..8677b87
--- /dev/null
+++ b/toolchain/.svn/text-base/Config.in.svn-base
@@ -0,0 +1,220 @@
+#
+
+menuconfig EXTERNAL_TOOLCHAIN
+ bool
+ prompt "Use external toolchain" if DEVEL
+ help
+ If enabled, OpenWrt will compile using an existing toolchain instead of compiling one
+
+ config NATIVE_TOOLCHAIN
+ bool
+ prompt "Use host's toolchain" if DEVEL
+ depends EXTERNAL_TOOLCHAIN
+ select NO_STRIP
+ help
+ If enabled, OpenWrt will compile using the native toolchain for your host instead of compiling one
+
+ config TARGET_NAME
+ string
+ prompt "Target name" if DEVEL
+ depends EXTERNAL_TOOLCHAIN && !NATIVE_TOOLCHAIN
+ default "arm-unknown-linux-gnu" if arm
+ default "armeb-unknown-linux-gnu" if armeb
+ default "i486-unknown-linux-gnu" if i386
+ default "mips-unknown-linux-gnu" if mips
+ default "mipsel-unknown-linux-gnu" if mipsel
+ default "powerpc-unknown-linux-gnu" if powerpc
+ default "x86_64-unknown-linux-gnu" if x86_64
+
+ config TOOLCHAIN_PREFIX
+ string
+ prompt "Toolchain prefix" if DEVEL
+ depends EXTERNAL_TOOLCHAIN && !NATIVE_TOOLCHAIN
+ default "arm-unknown-linux-gnu-" if arm
+ default "armeb-unknown-linux-gnu-" if armeb
+ default "i486-unknown-linux-gnu-" if i386
+ default "mips-unknown-linux-gnu-" if mips
+ default "mipsel-unknown-linux-gnu-" if mipsel
+ default "powerpc-unknown-linux-gnu-" if powerpc
+ default "x86_64-unknown-linux-gnu-" if x86_64
+
+ config TOOLCHAIN_ROOT
+ string
+ prompt "Toolchain root" if DEVEL
+ depends EXTERNAL_TOOLCHAIN && !NATIVE_TOOLCHAIN
+ default "/opt/cross/arm-unknown-linux-gnu" if arm
+ default "/opt/cross/armeb-unknown-linux-gnu" if armeb
+ default "/opt/cross/i486-unknown-linux-gnu" if i386
+ default "/opt/cross/mips-unknown-linux-gnu" if mips
+ default "/opt/cross/mipsel-unknown-linux-gnu" if mipsel
+ default "/opt/cross/powerpc-unknown-linux-gnu" if powerpc
+ default "/opt/cross/x86_64-unknown-linux-gnu" if x86_64
+
+ config TOOLCHAIN_LIBC
+ string
+ prompt "Toolchain libc" if DEVEL
+ depends EXTERNAL_TOOLCHAIN && !NATIVE_TOOLCHAIN
+ default "uclibc"
+ help
+ Specify the libc type used by the external toolchain. The given value us passed as -m
+ flag to all gcc and g++ invocations. This is mainly intended for multilib toolchains
+ which support glibc and uclibc at the same time. If no value is specified, no -m flag
+ is passed.
+
+ config TOOLCHAIN_BIN_PATH
+ string
+ prompt "Toolchain program path" if DEVEL
+ depends EXTERNAL_TOOLCHAIN && !NATIVE_TOOLCHAIN
+ default "./usr/bin ./bin"
+ help
+ Specify additional directories searched for toolchain binaries (override PATH)
+ Use ./DIR for directories relative to the root above
+
+ config TOOLCHAIN_INC_PATH
+ string
+ prompt "Toolchain include path" if DEVEL
+ depends EXTERNAL_TOOLCHAIN && !NATIVE_TOOLCHAIN
+ default "./usr/include ./include"
+ help
+ Specify additional directories searched for header files (override CPPFLAGS)
+ Use ./DIR for directories relative to the root above
+
+ config TOOLCHAIN_LIB_PATH
+ string
+ prompt "Toolchain library path" if DEVEL
+ depends EXTERNAL_TOOLCHAIN && !NATIVE_TOOLCHAIN
+ default "./usr/lib ./lib"
+ help
+ Specify additional directories searched for libraries (override LDFLAGS)
+ Use ./DIR for directories relative to the root above
+
+config NEED_TOOLCHAIN
+ bool
+ depends DEVEL
+ default y if !EXTERNAL_TOOLCHAIN
+
+menuconfig TOOLCHAINOPTS
+ bool "Toolchain Options" if DEVEL
+ depends NEED_TOOLCHAIN
+
+menuconfig EXTRA_TARGET_ARCH
+ bool
+ prompt "Enable an extra toolchain target architecture" if TOOLCHAINOPTS
+ depends !sparc
+ default y if powerpc64
+ default n
+ help
+ Some builds may require a 'biarch' toolchain. This option
+ allows you to specify an additional target arch.
+
+ Most people will answer N here.
+
+ config EXTRA_TARGET_ARCH_NAME
+ string
+ default "powerpc64" if powerpc64
+ prompt "Extra architecture name" if EXTRA_TARGET_ARCH
+ help
+ Specify the cpu name (eg powerpc64 or x86_64) of the
+ additional target architecture.
+
+ config EXTRA_TARGET_ARCH_OPTS
+ string
+ default "-m64" if powerpc64
+ prompt "Extra architecture compiler options" if EXTRA_TARGET_ARCH
+ help
+ If you're specifying an addition target architecture,
+ you'll probably need to also provide options to make
+ the compiler use this alternate arch.
+
+ For example, if you're building a compiler that can build
+ both powerpc and powerpc64 binaries, you'll need to
+ specify -m64 here.
+
+comment "Binary tools"
+ depends TOOLCHAINOPTS
+
+source "toolchain/binutils/Config.in"
+
+comment "Compiler"
+ depends TOOLCHAINOPTS
+
+source "toolchain/gcc/Config.in"
+
+comment "C Library"
+ depends TOOLCHAINOPTS
+
+choice
+ prompt "C Library implementation" if TOOLCHAINOPTS
+ default USE_UCLIBC
+ help
+ Select the C library implementation.
+
+ config USE_EGLIBC
+ bool "Use eglibc"
+ depends !avr32
+
+ config USE_UCLIBC
+ bool "Use uClibc"
+
+ config USE_MUSL
+ bool "Use musl"
+
+endchoice
+
+source "toolchain/eglibc/Config.in"
+source "toolchain/uClibc/Config.in"
+source "toolchain/musl/Config.in"
+
+comment "Debuggers"
+ depends TOOLCHAINOPTS
+
+config GDB
+ bool
+ depends !avr32
+ prompt "Build gdb" if TOOLCHAINOPTS
+ default y
+ help
+ Enable if you want to build the gdb
+
+config INSIGHT
+ bool
+ prompt "Build insight-gdb" if TOOLCHAINOPTS
+ select GDB
+ default n
+ help
+ Enable if you want to build insight-gdb
+
+config USE_UCLIBC
+ bool
+ default y if !TOOLCHAINOPTS && !EXTERNAL_TOOLCHAIN && !NATIVE_TOOLCHAIN
+
+config USE_EXTERNAL_LIBC
+ bool
+ default y if EXTERNAL_TOOLCHAIN || NATIVE_TOOLCHAIN
+
+source "toolchain/gcc/Config.version"
+
+source "toolchain/eglibc/Config.version"
+source "toolchain/uClibc/Config.version"
+source "toolchain/musl/Config.version"
+
+config LIBC
+ string
+ default "eglibc" if USE_EGLIBC
+ default "uClibc" if USE_UCLIBC
+ default "musl" if USE_MUSL
+
+config LIBC_VERSION
+ string
+ default EGLIBC_VERSION if USE_EGLIBC
+ default UCLIBC_VERSION if USE_UCLIBC
+ default MUSL_VERSION if USE_MUSL
+
+config TARGET_SUFFIX
+ string
+ default "gnueabi" if USE_EGLIBC && (arm || armeb)
+ default "gnu" if USE_EGLIBC && !(arm || armeb)
+ default "uclibcgnueabi" if USE_UCLIBC && (arm || armeb)
+ default "uclibc" if USE_UCLIBC && !(arm || armeb)
+ default "muslgnueabi" if USE_MUSL && (arm || armeb)
+ default "musl" if USE_MUSL && !(arm || armeb)
diff --git a/toolchain/.svn/text-base/Makefile.svn-base b/toolchain/.svn/text-base/Makefile.svn-base
new file mode 100644
index 0000000..bdfb29e
--- /dev/null
+++ b/toolchain/.svn/text-base/Makefile.svn-base
@@ -0,0 +1,86 @@
+#
+# Copyright (C) 2007-2009 OpenWrt.org
+#
+# This is free software, licensed under the GNU General Public License v2.
+# See /LICENSE for more information.
+#
+# Main makefile for the toolchain
+#
+# Steps:
+# 1) toolchain/binutils/install
+# build & install binutils
+# 2) toolchain/gcc/prepare
+# build & install a minimal gcc, needed for steps 3 & 4
+# 3) toolchain/kernel-headers/install
+# install kernel headers, needed for step 4
+# 4) toolchain/libc/prepare
+# build & install libc headers & support files, needed for step 5
+# 5) toolchain/gcc/compile
+# build & install an initial gcc, needed for step 6
+# 6) toolchain/libc/compile
+# build & install the final libc
+# 7) toolchain/gcc/install
+# build & install the final gcc
+# 8) toolchain/libc/install
+# build & install libc utilities
+#
+
+curdir:=toolchain
+
+# subdirectories to descend into
+$(curdir)/builddirs := $(if $(CONFIG_GDB),gdb) $(if $(CONFIG_INSIGHT),insight) $(if $(CONFIG_EXTERNAL_TOOLCHAIN),wrapper,kernel-headers binutils gcc/minimal gcc/initial gcc/final $(LIBC)/headers $(LIBC))
+ifdef CONFIG_USE_UCLIBC
+ $(curdir)/builddirs += $(LIBC)/utils
+endif
+$(curdir)/builddirs-compile:=$($(curdir)/builddirs-prepare)
+$(curdir)/builddirs-install:=$($(curdir)/builddirs-compile)
+
+# builddir dependencies
+ifeq ($(CONFIG_EXTERNAL_TOOLCHAIN),)
+ $(curdir)/gcc/minimal/compile:=$(curdir)/binutils/install
+ $(curdir)/kernel-headers/install:=$(curdir)/gcc/minimal/install
+ $(curdir)/gcc/initial/prepare:=$(curdir)/gcc/minimal/prepare
+ $(curdir)/gcc/final/prepare:=$(curdir)/gcc/initial/prepare
+
+ $(curdir)/$(LIBC)/headers/compile:=$(curdir)/kernel-headers/install
+ $(curdir)/gcc/initial/compile:=$(curdir)/$(LIBC)/headers/install
+ $(curdir)/$(LIBC)/compile:=$(curdir)/gcc/initial/install
+ $(curdir)/gcc/final/compile:=$(curdir)/$(LIBC)/install
+ $(curdir)/$(LIBC)/utils/compile:=$(curdir)/gcc/final/install
+ $(curdir)/$(LIBC)/prepare:=$(curdir)/$(LIBC)/headers/prepare
+ $(curdir)/$(LIBC)/utils/prepare:=$(curdir)/$(LIBC)/headers/prepare
+endif
+
+ifdef CONFIG_GCC_VERSION_LLVM
+ $(curdir)/builddirs += llvm
+ $(curdir)/gcc/minimal/compile += $(curdir)/llvm/install
+endif
+
+ifndef DUMP_TARGET_DB
+ifneq ($(ARCH),)
+ $(TOOLCHAIN_DIR)/info.mk: .config
+ @for dir in $(TOOLCHAIN_DIR); do ( \
+ $(if $(QUIET),,set -x;) \
+ mkdir -p "$$dir"; \
+ cd "$$dir"; \
+ ln -sf lib lib64; \
+ mkdir -p stamp lib usr/include usr/lib ; \
+ ); done
+ @grep GCC_VERSION $@ >/dev/null 2>&1 || $(INSTALL_DATA) $(TOPDIR)/toolchain/info.mk $@
+ @touch $@
+endif
+endif
+
+# prerequisites for the individual targets
+$(curdir)/ := .config prereq
+$(curdir)//prepare = $(STAGING_DIR)/.prepared $(TOOLCHAIN_DIR)/info.mk
+$(curdir)//compile = $(1)/prepare
+$(curdir)//install = $(1)/compile
+
+ifndef DUMP_TARGET_DB
+$(TOOLCHAIN_DIR)/stamp/.gcc-initial_installed:
+endif
+
+$(eval $(call stampfile,$(curdir),toolchain,install,$(TOOLCHAIN_DIR)/stamp/.gcc-initial_installed,,$(TOOLCHAIN_DIR)))
+$(eval $(call subdir,$(curdir)))
+
diff --git a/toolchain/.svn/text-base/info.mk.svn-base b/toolchain/.svn/text-base/info.mk.svn-base
new file mode 100644
index 0000000..4f311c5
--- /dev/null
+++ b/toolchain/.svn/text-base/info.mk.svn-base
@@ -0,0 +1,6 @@
+TARGET_CROSS=
+GCC_VERSION=unknown
+LIBC_TYPE=unknown
+LIBC_URL=unknown
+LIBC_VERSION=unknown
+LIBC_SO_VERSION=unknown