aboutsummaryrefslogtreecommitdiffstats
path: root/target/linux/uml/.svn
diff options
context:
space:
mode:
authorJames <>2013-03-17 12:16:37 +0000
committerJames <>2013-03-17 12:16:37 +0000
commit27b76ab0671089c47506615a796a261e993896a7 (patch)
tree61213d67e7fa87b20356b23798558e2c4212c42f /target/linux/uml/.svn
downloadtrunk-36060-master.tar.gz
trunk-36060-master.tar.bz2
trunk-36060-master.zip
Diffstat (limited to 'target/linux/uml/.svn')
-rw-r--r--target/linux/uml/.svn/entries111
-rw-r--r--target/linux/uml/.svn/prop-base/Makefile.svn-base9
-rw-r--r--target/linux/uml/.svn/prop-base/README.svn-base5
-rw-r--r--target/linux/uml/.svn/text-base/Makefile.svn-base36
-rw-r--r--target/linux/uml/.svn/text-base/README.svn-base45
5 files changed, 206 insertions, 0 deletions
diff --git a/target/linux/uml/.svn/entries b/target/linux/uml/.svn/entries
new file mode 100644
index 0000000..d1233a6
--- /dev/null
+++ b/target/linux/uml/.svn/entries
@@ -0,0 +1,111 @@
+10
+
+dir
+36060
+svn://svn.openwrt.org/openwrt/trunk/target/linux/uml
+svn://svn.openwrt.org/openwrt
+
+
+
+2012-12-18T14:41:16.198551Z
+34748
+juhosg
+
+
+
+
+
+
+
+
+
+
+
+
+
+
+3c298f89-4303-0410-b956-a3cf2f4a3e73
+
+image
+dir
+
+config
+dir
+
+patches-3.2
+dir
+
+patches-3.3
+dir
+
+patches-3.6
+dir
+
+Makefile
+file
+
+
+
+
+2013-03-17T12:12:48.000000Z
+d662a6296110621d4048a2a618305a8b
+2012-12-18T14:41:16.198551Z
+34748
+juhosg
+has-props
+
+
+
+
+
+
+
+
+
+
+
+
+
+
+
+
+
+
+
+
+743
+
+README
+file
+
+
+
+
+2013-03-17T12:12:48.000000Z
+1485347bacaa3923981be434c294bfe4
+2011-02-12T19:04:09.422745Z
+25482
+florian
+has-props
+
+
+
+
+
+
+
+
+
+
+
+
+
+
+
+
+
+
+
+
+2250
+
diff --git a/target/linux/uml/.svn/prop-base/Makefile.svn-base b/target/linux/uml/.svn/prop-base/Makefile.svn-base
new file mode 100644
index 0000000..8e522ae
--- /dev/null
+++ b/target/linux/uml/.svn/prop-base/Makefile.svn-base
@@ -0,0 +1,9 @@
+K 13
+svn:copyright
+V 30
+Copyright (C) 2006 OpenWrt.org
+K 13
+svn:eol-style
+V 6
+native
+END
diff --git a/target/linux/uml/.svn/prop-base/README.svn-base b/target/linux/uml/.svn/prop-base/README.svn-base
new file mode 100644
index 0000000..bdbd305
--- /dev/null
+++ b/target/linux/uml/.svn/prop-base/README.svn-base
@@ -0,0 +1,5 @@
+K 13
+svn:eol-style
+V 6
+native
+END
diff --git a/target/linux/uml/.svn/text-base/Makefile.svn-base b/target/linux/uml/.svn/text-base/Makefile.svn-base
new file mode 100644
index 0000000..ccdc3a2
--- /dev/null
+++ b/target/linux/uml/.svn/text-base/Makefile.svn-base
@@ -0,0 +1,36 @@
+#
+# Copyright (C) 2006-2011 OpenWrt.org
+#
+# This is free software, licensed under the GNU General Public License v2.
+# See /LICENSE for more information.
+#
+include $(TOPDIR)/rules.mk
+include $(INCLUDE_DIR)/host.mk
+
+# UML only makes sense on linux
+ifeq ($(HOST_OS),Linux)
+
+ARCH:=$(shell uname -m | sed \
+ -e 's/i[3-9]86/i386/' \
+ -e 's/mipsel/mips/' \
+ -e 's/mipseb/mips/' \
+ -e 's/powerpc/ppc/' \
+ -e 's/sh[234]/sh/' \
+ -e 's/armeb/arm/' \
+)
+BOARD:=uml
+BOARDNAME:=User Mode Linux
+FEATURES:=ext4 audio
+MAINTAINER:=Florian Fainelli <florian@openwrt.org>
+
+LINUX_VERSION:=3.6.11
+
+include $(INCLUDE_DIR)/target.mk
+
+LINUX_TARGET_CONFIG:=$(CURDIR)/config/$(ARCH)
+
+DEFAULT_PACKAGES += wpad-mini kmod-mac80211-hwsim
+
+endif
+
+$(eval $(call BuildTarget))
diff --git a/target/linux/uml/.svn/text-base/README.svn-base b/target/linux/uml/.svn/text-base/README.svn-base
new file mode 100644
index 0000000..c714485
--- /dev/null
+++ b/target/linux/uml/.svn/text-base/README.svn-base
@@ -0,0 +1,45 @@
+Openwrt inside a user mode linux. Why would we even want this many ask?
+
+There are potentially a lot of reasons, one obvious one to me, it allows
+folks to 'kick the tires' without actually flashing up any hardware. It's
+also a great environment for porting over packages, you can get a package
+fully functional in the uclibc root environment inside a uml without actually
+disturbing your 'real router', and then rebuild for a specific target once
+it's fully tested.
+
+This is a first stab at a build that 'just works' and there will be more
+cleanup to come. The simple directions are:-
+
+Configure for uml target
+Configure with an ext4 root file system
+build it all
+
+In your bin directory you will find a kernel and an ext4 root file system
+when it's finished. Just run it like this:-
+
+bin/uml/openwrt-uml-vmlinux ubd0=bin/uml/openwrt-uml-ext4.img con=null ssl=null ssl0=fd:0,fd:1 con0=null,fd:2
+
+The uml will start, and eventually the serial console of the uml will be at your
+console prompt. If you would like it in xterms, substitute con=xterm and con0=xterm.
+No networking is configured, but, it's a starting point. The resulting file system
+has just enough free space to start kicking the tires and playing in the world of
+'embedded routers' along with all the resource restrictions that come with that
+world.
+
+To configure networking and more, refer to the user mode linux documentation online.
+A quick start goes along this line. install the uml-utilities packages so you have
+the uml switch in and running, then add a command param to your uml start like this
+
+eth0=daemon,00:01:01:01:01:01,unix,/<your uml switch control socket here>
+
+With that in, and uml networking actually functional (can be a challenge at times),
+you should be able to ifconfig the interface and talk to the host side, or, if you
+bridged the uml switch to your host network, you should be able to run udhcp and be
+away with networking off to the world. Again, if you are unfamiliar with uml and
+uml networking, please read the docs and how-to stuff available on the net. It does
+take some fiddling to get it started and working right the first time, but after that,
+it opens up a whole new world of virtual machines.
+
+
+
+http://user-mode-linux.sourceforge.net/