aboutsummaryrefslogtreecommitdiffstats
path: root/target/linux/malta/Makefile
diff options
context:
space:
mode:
authorJames <>2013-03-17 12:16:37 +0000
committerJames <>2013-03-17 12:16:37 +0000
commit27b76ab0671089c47506615a796a261e993896a7 (patch)
tree61213d67e7fa87b20356b23798558e2c4212c42f /target/linux/malta/Makefile
downloadtrunk-36060-master.tar.gz
trunk-36060-master.tar.bz2
trunk-36060-master.zip
Diffstat (limited to 'target/linux/malta/Makefile')
-rw-r--r--target/linux/malta/Makefile24
1 files changed, 24 insertions, 0 deletions
diff --git a/target/linux/malta/Makefile b/target/linux/malta/Makefile
new file mode 100644
index 0000000..9b342c8
--- /dev/null
+++ b/target/linux/malta/Makefile
@@ -0,0 +1,24 @@
+#
+# Copyright (C) 2010-2011 OpenWrt.org
+#
+# This is free software, licensed under the GNU General Public License v2.
+# See /LICENSE for more information.
+#
+include $(TOPDIR)/rules.mk
+
+BOARD:=malta
+BOARDNAME:=MIPS Malta CoreLV board (qemu)
+CFLAGS:=-Os -pipe -mips32r2 -mtune=mips32r2 -fno-caller-saves
+SUBTARGETS:=le be
+INITRAMFS_EXTRA_FILES:=
+MAINTAINER:=Florian Fainelli <florian@openwrt.org>
+
+LINUX_VERSION:=3.8.3
+
+DEVICE_TYPE:=developerboard
+
+include $(INCLUDE_DIR)/target.mk
+
+DEFAULT_PACKAGES += wpad-mini kmod-mac80211-hwsim kmod-pcnet32
+
+$(eval $(call BuildTarget))