aboutsummaryrefslogtreecommitdiffstats
path: root/target/linux/ar71xx/Makefile
diff options
context:
space:
mode:
authorJames <>2013-03-17 12:16:37 +0000
committerJames <>2013-03-17 12:16:37 +0000
commit27b76ab0671089c47506615a796a261e993896a7 (patch)
tree61213d67e7fa87b20356b23798558e2c4212c42f /target/linux/ar71xx/Makefile
downloadtrunk-36060-master.tar.gz
trunk-36060-master.tar.bz2
trunk-36060-master.zip
Diffstat (limited to 'target/linux/ar71xx/Makefile')
-rw-r--r--target/linux/ar71xx/Makefile29
1 files changed, 29 insertions, 0 deletions
diff --git a/target/linux/ar71xx/Makefile b/target/linux/ar71xx/Makefile
new file mode 100644
index 0000000..ef4a3ee
--- /dev/null
+++ b/target/linux/ar71xx/Makefile
@@ -0,0 +1,29 @@
+#
+# Copyright (C) 2008-2011 OpenWrt.org
+#
+# This is free software, licensed under the GNU General Public License v2.
+# See /LICENSE for more information.
+#
+include $(TOPDIR)/rules.mk
+
+ARCH:=mips
+BOARD:=ar71xx
+BOARDNAME:=Atheros AR7xxx/AR9xxx
+FEATURES:=squashfs jffs2 targz
+CFLAGS:=-Os -pipe -mips32r2 -mtune=mips32r2 -fno-caller-saves -mno-branch-likely
+SUBTARGETS:=generic nand
+
+LINUX_VERSION:=3.8.3
+
+include $(INCLUDE_DIR)/target.mk
+
+DEFAULT_PACKAGES += \
+ kmod-leds-gpio kmod-gpio-button-hotplug kmod-wdt-ath79 swconfig \
+ kmod-ledtrig-default-on kmod-ledtrig-timer kmod-ledtrig-netdev \
+ kmod-ath9k wpad-mini uboot-envtools
+
+define Target/Description
+ Build firmware images for Atheros AR7xxx/AR9xxx based boards.
+endef
+
+$(eval $(call BuildTarget))