aboutsummaryrefslogtreecommitdiffstats
path: root/target/linux/ar7/Makefile
diff options
context:
space:
mode:
authorJames <>2013-03-17 12:16:37 +0000
committerJames <>2013-03-17 12:16:37 +0000
commit27b76ab0671089c47506615a796a261e993896a7 (patch)
tree61213d67e7fa87b20356b23798558e2c4212c42f /target/linux/ar7/Makefile
downloadtrunk-36060-master.tar.gz
trunk-36060-master.tar.bz2
trunk-36060-master.zip
Diffstat (limited to 'target/linux/ar7/Makefile')
-rw-r--r--target/linux/ar7/Makefile26
1 files changed, 26 insertions, 0 deletions
diff --git a/target/linux/ar7/Makefile b/target/linux/ar7/Makefile
new file mode 100644
index 0000000..e41d3ff
--- /dev/null
+++ b/target/linux/ar7/Makefile
@@ -0,0 +1,26 @@
+#
+# Copyright (C) 2006-2011 OpenWrt.org
+#
+# This is free software, licensed under the GNU General Public License v2.
+# See /LICENSE for more information.
+#
+include $(TOPDIR)/rules.mk
+
+ARCH:=mipsel
+BOARD:=ar7
+BOARDNAME:=TI AR7
+FEATURES:=squashfs jffs2 atm
+MAINTAINER:=Florian Fainelli <florian@openwrt.org>
+SUBTARGETS:=generic ac49x
+
+LINUX_VERSION:=3.3.8
+
+include $(INCLUDE_DIR)/target.mk
+
+DEFAULT_PACKAGES+= swconfig
+
+define Target/Description
+ Build firmware images for TI AR7 based routers.
+endef
+
+$(eval $(call BuildTarget))