aboutsummaryrefslogtreecommitdiffstats
path: root/scripts/symlink-tree.sh
diff options
context:
space:
mode:
authorJames <>2013-03-17 12:16:37 +0000
committerJames <>2013-03-17 12:16:37 +0000
commit27b76ab0671089c47506615a796a261e993896a7 (patch)
tree61213d67e7fa87b20356b23798558e2c4212c42f /scripts/symlink-tree.sh
downloadtrunk-36060-master.tar.gz
trunk-36060-master.tar.bz2
trunk-36060-master.zip
Diffstat (limited to 'scripts/symlink-tree.sh')
-rwxr-xr-xscripts/symlink-tree.sh45
1 files changed, 45 insertions, 0 deletions
diff --git a/scripts/symlink-tree.sh b/scripts/symlink-tree.sh
new file mode 100755
index 0000000..e44ebda
--- /dev/null
+++ b/scripts/symlink-tree.sh
@@ -0,0 +1,45 @@
+#!/usr/bin/env bash
+# Create a new openwrt tree with symlinks pointing at the current tree
+# Usage: ./scripts/symlink-tree.sh <destination>
+
+FILES="
+ BSDmakefile
+ Config.in
+ LICENSE
+ Makefile
+ README
+ dl
+ docs
+ feeds.conf.default
+ include
+ package
+ rules.mk
+ scripts
+ target
+ toolchain
+ tools"
+
+if [ -f feeds.conf ] ; then
+ FILES="$FILES feeds.conf"
+fi
+
+if [ -z "$1" ]; then
+ echo "Syntax: $0 <destination>" >&2
+ exit 1
+fi
+
+if [ -e "$1" ]; then
+ echo "Error: $1 already exists" >&2
+ exit 1
+fi
+
+set -e # fail if any commands fails
+mkdir -p dl "$1"
+for file in $FILES; do
+ [ -e "$PWD/$file" ] || {
+ echo "ERROR: $file does not exist in the current tree" >&2
+ exit 1
+ }
+ ln -s "$PWD/$file" "$1/"
+done
+exit 0