aboutsummaryrefslogtreecommitdiffstats
path: root/package/libs/uclibc++/patches/.svn
diff options
context:
space:
mode:
authorJames <>2013-03-17 12:16:37 +0000
committerJames <>2013-03-17 12:16:37 +0000
commit27b76ab0671089c47506615a796a261e993896a7 (patch)
tree61213d67e7fa87b20356b23798558e2c4212c42f /package/libs/uclibc++/patches/.svn
downloadtrunk-36060-master.tar.gz
trunk-36060-master.tar.bz2
trunk-36060-master.zip
Diffstat (limited to 'package/libs/uclibc++/patches/.svn')
-rw-r--r--package/libs/uclibc++/patches/.svn/entries96
-rw-r--r--package/libs/uclibc++/patches/.svn/text-base/002-path_to_bash.patch.svn-base11
-rw-r--r--package/libs/uclibc++/patches/.svn/text-base/006-eabi_fix.patch.svn-base38
3 files changed, 145 insertions, 0 deletions
diff --git a/package/libs/uclibc++/patches/.svn/entries b/package/libs/uclibc++/patches/.svn/entries
new file mode 100644
index 0000000..324a6a3
--- /dev/null
+++ b/package/libs/uclibc++/patches/.svn/entries
@@ -0,0 +1,96 @@
+10
+
+dir
+36060
+svn://svn.openwrt.org/openwrt/trunk/package/libs/uclibc++/patches
+svn://svn.openwrt.org/openwrt
+
+
+
+2012-10-08T11:24:12.513797Z
+33657
+nbd
+
+
+
+
+
+
+
+
+
+
+
+
+
+
+3c298f89-4303-0410-b956-a3cf2f4a3e73
+
+006-eabi_fix.patch
+file
+
+
+
+
+2013-03-17T12:13:09.000000Z
+6b8f1a7c16793650ed58978282792c9a
+2012-10-08T11:24:12.513797Z
+33657
+nbd
+
+
+
+
+
+
+
+
+
+
+
+
+
+
+
+
+
+
+
+
+
+1217
+
+002-path_to_bash.patch
+file
+
+
+
+
+2013-03-17T12:13:09.000000Z
+53862636fd67effae44a40bcb6471b47
+2012-10-08T11:24:12.513797Z
+33657
+nbd
+
+
+
+
+
+
+
+
+
+
+
+
+
+
+
+
+
+
+
+
+
+404
+
diff --git a/package/libs/uclibc++/patches/.svn/text-base/002-path_to_bash.patch.svn-base b/package/libs/uclibc++/patches/.svn/text-base/002-path_to_bash.patch.svn-base
new file mode 100644
index 0000000..26d88ee
--- /dev/null
+++ b/package/libs/uclibc++/patches/.svn/text-base/002-path_to_bash.patch.svn-base
@@ -0,0 +1,11 @@
+--- a/bin/Makefile
++++ b/bin/Makefile
+@@ -13,7 +13,7 @@ install:
+ $(INSTALL) -m 755 $(WRAPPER) $(PREFIX)$(UCLIBCXX_RUNTIME_BINDIR)
+
+ $(WRAPPER): Makefile
+- echo '#!/bin/sh' > $@
++ echo '#!/usr/bin/env bash' > $@
+ echo '' >> $@
+ echo 'WRAPPER_INCLUDEDIR="$${WRAPPER_INCLUDEDIR:=-I$(UCLIBCXX_RUNTIME_INCLUDEDIR)}"' >> $@
+ echo 'WRAPPER_LIBDIR="$${WRAPPER_LIBDIR:=-L$(UCLIBCXX_RUNTIME_LIBDIR)}"' >> $@
diff --git a/package/libs/uclibc++/patches/.svn/text-base/006-eabi_fix.patch.svn-base b/package/libs/uclibc++/patches/.svn/text-base/006-eabi_fix.patch.svn-base
new file mode 100644
index 0000000..65b436c
--- /dev/null
+++ b/package/libs/uclibc++/patches/.svn/text-base/006-eabi_fix.patch.svn-base
@@ -0,0 +1,38 @@
+--- a/include/typeinfo
++++ b/include/typeinfo
+@@ -44,6 +44,7 @@ namespace __cxxabiv1
+ class __class_type_info;
+ } // namespace __cxxabiv1
+
++#ifndef __GXX_MERGED_TYPEINFO_NAMES
+ #if !__GXX_WEAK__
+ // If weak symbols are not supported, typeinfo names are not merged.
+ #define __GXX_MERGED_TYPEINFO_NAMES 0
+@@ -51,6 +52,7 @@ namespace __cxxabiv1
+ // On platforms that support weak symbols, typeinfo names are merged.
+ #define __GXX_MERGED_TYPEINFO_NAMES 1
+ #endif
++#endif
+
+ namespace std
+ {
+--- a/include/unwind-cxx.h
++++ b/include/unwind-cxx.h
+@@ -173,6 +173,7 @@ extern std::unexpected_handler __unexpec
+
+ // This is the exception class we report -- "GNUCC++\0".
+ const _Unwind_Exception_Class __gxx_exception_class
++#ifndef __ARM_EABI_UNWINDER__
+ = ((((((((_Unwind_Exception_Class) 'G'
+ << 8 | (_Unwind_Exception_Class) 'N')
+ << 8 | (_Unwind_Exception_Class) 'U')
+@@ -181,6 +182,9 @@ const _Unwind_Exception_Class __gxx_exce
+ << 8 | (_Unwind_Exception_Class) '+')
+ << 8 | (_Unwind_Exception_Class) '+')
+ << 8 | (_Unwind_Exception_Class) '\0');
++#else
++= "GNUC++";
++#endif
+
+ // GNU C++ personality routine, Version 0.
+ extern "C" _Unwind_Reason_Code __gxx_personality_v0