aboutsummaryrefslogtreecommitdiffstats
path: root/package/libs/polarssl
diff options
context:
space:
mode:
authorJames <>2013-03-17 12:16:37 +0000
committerJames <>2013-03-17 12:16:37 +0000
commit27b76ab0671089c47506615a796a261e993896a7 (patch)
tree61213d67e7fa87b20356b23798558e2c4212c42f /package/libs/polarssl
downloadtrunk-36060-27b76ab0671089c47506615a796a261e993896a7.tar.gz
trunk-36060-27b76ab0671089c47506615a796a261e993896a7.tar.bz2
trunk-36060-27b76ab0671089c47506615a796a261e993896a7.zip
Diffstat (limited to 'package/libs/polarssl')
-rw-r--r--package/libs/polarssl/.svn/entries65
-rw-r--r--package/libs/polarssl/.svn/text-base/Makefile.svn-base81
-rw-r--r--package/libs/polarssl/Makefile81
-rw-r--r--package/libs/polarssl/patches/.svn/entries164
-rw-r--r--package/libs/polarssl/patches/.svn/text-base/100-disable-testsuites.patch.svn-base21
-rw-r--r--package/libs/polarssl/patches/.svn/text-base/200-reduce_config.patch.svn-base112
-rw-r--r--package/libs/polarssl/patches/.svn/text-base/300-openssl_cipher_name_compat.patch.svn-base53
-rw-r--r--package/libs/polarssl/patches/.svn/text-base/310-fix_blowfish_key_len.patch.svn-base29
-rw-r--r--package/libs/polarssl/patches/100-disable-testsuites.patch21
-rw-r--r--package/libs/polarssl/patches/200-reduce_config.patch112
-rw-r--r--package/libs/polarssl/patches/300-openssl_cipher_name_compat.patch53
-rw-r--r--package/libs/polarssl/patches/310-fix_blowfish_key_len.patch29
12 files changed, 821 insertions, 0 deletions
diff --git a/package/libs/polarssl/.svn/entries b/package/libs/polarssl/.svn/entries
new file mode 100644
index 0000000..9e92c65
--- /dev/null
+++ b/package/libs/polarssl/.svn/entries
@@ -0,0 +1,65 @@
+10
+
+dir
+36060
+svn://svn.openwrt.org/openwrt/trunk/package/libs/polarssl
+svn://svn.openwrt.org/openwrt
+
+
+
+2013-02-08T19:47:48.767455Z
+35525
+yardley
+
+
+
+
+
+
+
+
+
+
+
+
+
+
+3c298f89-4303-0410-b956-a3cf2f4a3e73
+
+patches
+dir
+
+Makefile
+file
+
+
+
+
+2013-03-17T12:13:07.000000Z
+72836fdf35167b4db392039160a2520d
+2013-02-08T19:47:48.767455Z
+35525
+yardley
+
+
+
+
+
+
+
+
+
+
+
+
+
+
+
+
+
+
+
+
+
+1983
+
diff --git a/package/libs/polarssl/.svn/text-base/Makefile.svn-base b/package/libs/polarssl/.svn/text-base/Makefile.svn-base
new file mode 100644
index 0000000..a66402c
--- /dev/null
+++ b/package/libs/polarssl/.svn/text-base/Makefile.svn-base
@@ -0,0 +1,81 @@
+#
+# Copyright (C) 2011 OpenWrt.org
+#
+# This is free software, licensed under the GNU General Public License v2.
+# See /LICENSE for more information.
+#
+
+include $(TOPDIR)/rules.mk
+
+PKG_NAME:=polarssl
+PKG_VERSION:=1.2.5
+PKG_RELEASE:=1
+
+PKG_SOURCE:=$(PKG_NAME)-$(PKG_VERSION)-gpl.tgz
+PKG_SOURCE_URL:=https://polarssl.org/code/releases
+PKG_MD5SUM:=f42dd79cd85384ac9ad482caa665ac8f
+
+include $(INCLUDE_DIR)/package.mk
+include $(INCLUDE_DIR)/cmake.mk
+
+define Package/polarssl/Default
+ SUBMENU:=SSL
+ TITLE:=Embedded SSL
+ URL:=http://polarssl.org/
+endef
+
+define Package/polarssl/Default/description
+The aim of the PolarSSL project is to provide a quality, open-source
+cryptographic library written in C and targeted at embedded systems.
+endef
+
+define Package/libpolarssl
+$(call Package/polarssl/Default)
+ SECTION:=libs
+ CATEGORY:=Libraries
+ TITLE+= (library)
+endef
+
+define Package/libpolarssl/description
+$(call Package/polarssl/Default/description)
+This package contains the PolarSSL library.
+endef
+
+define Package/polarssl-progs
+$(call Package/polarssl/Default)
+ SECTION:=utils
+ CATEGORY:=Utilities
+ DEPENDS:=+libpolarssl
+ TITLE+= (programs)
+endef
+
+define Package/polarssl-progs/description
+$(call Package/polarssl/Default/description)
+This package contains the PolarSSL programs.
+endef
+
+PKG_INSTALL:=1
+
+CMAKE_OPTIONS += \
+ -DCMAKE_BUILD_TYPE:String="Release" \
+ -DUSE_SHARED_POLARSSL_LIBRARY:Bool=ON \
+
+define Build/InstallDev
+ $(INSTALL_DIR) $(1)/usr/include
+ $(CP) $(PKG_INSTALL_DIR)/usr/include/polarssl $(1)/usr/include/
+ $(INSTALL_DIR) $(1)/usr/lib
+ $(CP) $(PKG_INSTALL_DIR)/usr/lib/libpolarssl.so* $(1)/usr/lib/
+endef
+
+define Package/libpolarssl/install
+ $(INSTALL_DIR) $(1)/usr/lib
+ $(CP) $(PKG_INSTALL_DIR)/usr/lib/libpolarssl.so* $(1)/usr/lib/
+endef
+
+define Package/polarssl-progs/install
+ $(INSTALL_DIR) $(1)/usr/bin
+ $(INSTALL_BIN) $(PKG_INSTALL_DIR)/usr/bin/* $(1)/usr/bin/
+endef
+
+$(eval $(call BuildPackage,libpolarssl))
+$(eval $(call BuildPackage,polarssl-progs))
diff --git a/package/libs/polarssl/Makefile b/package/libs/polarssl/Makefile
new file mode 100644
index 0000000..a66402c
--- /dev/null
+++ b/package/libs/polarssl/Makefile
@@ -0,0 +1,81 @@
+#
+# Copyright (C) 2011 OpenWrt.org
+#
+# This is free software, licensed under the GNU General Public License v2.
+# See /LICENSE for more information.
+#
+
+include $(TOPDIR)/rules.mk
+
+PKG_NAME:=polarssl
+PKG_VERSION:=1.2.5
+PKG_RELEASE:=1
+
+PKG_SOURCE:=$(PKG_NAME)-$(PKG_VERSION)-gpl.tgz
+PKG_SOURCE_URL:=https://polarssl.org/code/releases
+PKG_MD5SUM:=f42dd79cd85384ac9ad482caa665ac8f
+
+include $(INCLUDE_DIR)/package.mk
+include $(INCLUDE_DIR)/cmake.mk
+
+define Package/polarssl/Default
+ SUBMENU:=SSL
+ TITLE:=Embedded SSL
+ URL:=http://polarssl.org/
+endef
+
+define Package/polarssl/Default/description
+The aim of the PolarSSL project is to provide a quality, open-source
+cryptographic library written in C and targeted at embedded systems.
+endef
+
+define Package/libpolarssl
+$(call Package/polarssl/Default)
+ SECTION:=libs
+ CATEGORY:=Libraries
+ TITLE+= (library)
+endef
+
+define Package/libpolarssl/description
+$(call Package/polarssl/Default/description)
+This package contains the PolarSSL library.
+endef
+
+define Package/polarssl-progs
+$(call Package/polarssl/Default)
+ SECTION:=utils
+ CATEGORY:=Utilities
+ DEPENDS:=+libpolarssl
+ TITLE+= (programs)
+endef
+
+define Package/polarssl-progs/description
+$(call Package/polarssl/Default/description)
+This package contains the PolarSSL programs.
+endef
+
+PKG_INSTALL:=1
+
+CMAKE_OPTIONS += \
+ -DCMAKE_BUILD_TYPE:String="Release" \
+ -DUSE_SHARED_POLARSSL_LIBRARY:Bool=ON \
+
+define Build/InstallDev
+ $(INSTALL_DIR) $(1)/usr/include
+ $(CP) $(PKG_INSTALL_DIR)/usr/include/polarssl $(1)/usr/include/
+ $(INSTALL_DIR) $(1)/usr/lib
+ $(CP) $(PKG_INSTALL_DIR)/usr/lib/libpolarssl.so* $(1)/usr/lib/
+endef
+
+define Package/libpolarssl/install
+ $(INSTALL_DIR) $(1)/usr/lib
+ $(CP) $(PKG_INSTALL_DIR)/usr/lib/libpolarssl.so* $(1)/usr/lib/
+endef
+
+define Package/polarssl-progs/install
+ $(INSTALL_DIR) $(1)/usr/bin
+ $(INSTALL_BIN) $(PKG_INSTALL_DIR)/usr/bin/* $(1)/usr/bin/
+endef
+
+$(eval $(call BuildPackage,libpolarssl))
+$(eval $(call BuildPackage,polarssl-progs))
diff --git a/package/libs/polarssl/patches/.svn/entries b/package/libs/polarssl/patches/.svn/entries
new file mode 100644
index 0000000..9df2522
--- /dev/null
+++ b/package/libs/polarssl/patches/.svn/entries
@@ -0,0 +1,164 @@
+10
+
+dir
+36060
+svn://svn.openwrt.org/openwrt/trunk/package/libs/polarssl/patches
+svn://svn.openwrt.org/openwrt
+
+
+
+2013-02-08T19:47:48.767455Z
+35525
+yardley
+
+
+
+
+
+
+
+
+
+
+
+
+
+
+3c298f89-4303-0410-b956-a3cf2f4a3e73
+
+310-fix_blowfish_key_len.patch
+file
+
+
+
+
+2013-03-17T12:13:07.000000Z
+4b4b94fd373188387bc23600546cce34
+2013-01-30T20:07:04.784853Z
+35411
+nbd
+
+
+
+
+
+
+
+
+
+
+
+
+
+
+
+
+
+
+
+
+
+698
+
+100-disable-testsuites.patch
+file
+
+
+
+
+2013-03-17T12:13:07.000000Z
+24ac43df7734b072c1eb34d945cd475a
+2013-01-30T20:07:04.784853Z
+35411
+nbd
+
+
+
+
+
+
+
+
+
+
+
+
+
+
+
+
+
+
+
+
+
+530
+
+200-reduce_config.patch
+file
+
+
+
+
+2013-03-17T12:13:07.000000Z
+a6227d1541d6ab0b150e6a08b142549a
+2013-02-08T19:47:48.767455Z
+35525
+yardley
+
+
+
+
+
+
+
+
+
+
+
+
+
+
+
+
+
+
+
+
+
+2038
+
+300-openssl_cipher_name_compat.patch
+file
+
+
+
+
+2013-03-17T12:13:07.000000Z
+45a8286a43aa68da8a5c08ec988fba93
+2013-01-30T20:07:04.784853Z
+35411
+nbd
+
+
+
+
+
+
+
+
+
+
+
+
+
+
+
+
+
+
+
+
+
+1736
+
diff --git a/package/libs/polarssl/patches/.svn/text-base/100-disable-testsuites.patch.svn-base b/package/libs/polarssl/patches/.svn/text-base/100-disable-testsuites.patch.svn-base
new file mode 100644
index 0000000..cf9485e
--- /dev/null
+++ b/package/libs/polarssl/patches/.svn/text-base/100-disable-testsuites.patch.svn-base
@@ -0,0 +1,21 @@
+--- a/CMakeLists.txt
++++ b/CMakeLists.txt
+@@ -38,7 +38,7 @@ add_subdirectory(library)
+ add_subdirectory(include)
+
+ if(CMAKE_COMPILER_IS_GNUCC)
+- add_subdirectory(tests)
++# add_subdirectory(tests)
+ endif(CMAKE_COMPILER_IS_GNUCC)
+
+ add_subdirectory(programs)
+--- a/programs/CMakeLists.txt
++++ b/programs/CMakeLists.txt
+@@ -3,6 +3,6 @@ add_subdirectory(hash)
+ add_subdirectory(pkey)
+ add_subdirectory(random)
+ add_subdirectory(ssl)
+-add_subdirectory(test)
++#add_subdirectory(test)
+ add_subdirectory(x509)
+ add_subdirectory(util)
diff --git a/package/libs/polarssl/patches/.svn/text-base/200-reduce_config.patch.svn-base b/package/libs/polarssl/patches/.svn/text-base/200-reduce_config.patch.svn-base
new file mode 100644
index 0000000..c66bb3f
--- /dev/null
+++ b/package/libs/polarssl/patches/.svn/text-base/200-reduce_config.patch.svn-base
@@ -0,0 +1,112 @@
+--- a/include/polarssl/config.h
++++ b/include/polarssl/config.h
+@@ -177,8 +177,8 @@
+ * Requires: POLARSSL_BIGNUM_C, POLARSSL_RSA_C
+ *
+ * Enable the RSA prime-number generation code.
+- */
+ #define POLARSSL_GENPRIME
++ */
+
+ /**
+ * \def POLARSSL_FS_IO
+@@ -235,8 +235,8 @@
+ * \def POLARSSL_SELF_TEST
+ *
+ * Enable the checkup functions (*_self_test).
+- */
+ #define POLARSSL_SELF_TEST
++ */
+
+ /**
+ * \def POLARSSL_SSL_ALL_ALERT_MESSAGES
+@@ -425,8 +425,8 @@
+ * TLS_RSA_WITH_CAMELLIA_256_CBC_SHA256
+ * TLS_DHE_RSA_WITH_CAMELLIA_128_CBC_SHA256
+ * TLS_DHE_RSA_WITH_CAMELLIA_256_CBC_SHA256
+- */
+ #define POLARSSL_CAMELLIA_C
++ */
+
+ /**
+ * \def POLARSSL_CERTS_C
+@@ -437,8 +437,8 @@
+ * Caller:
+ *
+ * This module is used for testing (ssl_client/server).
+- */
+ #define POLARSSL_CERTS_C
++ */
+
+ /**
+ * \def POLARSSL_CIPHER_C
+@@ -477,8 +477,8 @@
+ * library/ssl_tls.c
+ *
+ * This module provides debugging functions.
+- */
+ #define POLARSSL_DEBUG_C
++ */
+
+ /**
+ * \def POLARSSL_DES_C
+@@ -560,8 +560,8 @@
+ * enabled as well):
+ * TLS_RSA_WITH_AES_128_GCM_SHA256
+ * TLS_RSA_WITH_AES_256_GCM_SHA384
+- */
+ #define POLARSSL_GCM_C
++ */
+
+ /**
+ * \def POLARSSL_HAVEGE_C
+@@ -574,8 +574,8 @@
+ * Requires: POLARSSL_TIMING_C
+ *
+ * This module enables the HAVEGE random number generator.
+- */
+ #define POLARSSL_HAVEGE_C
++ */
+
+ /**
+ * \def POLARSSL_MD_C
+@@ -649,8 +649,8 @@
+ * Caller: library/aes.c
+ *
+ * This modules adds support for the VIA PadLock on x86.
+- */
+ #define POLARSSL_PADLOCK_C
++ */
+
+ /**
+ * \def POLARSSL_PBKDF2_C
+@@ -763,8 +763,8 @@
+ * Caller:
+ *
+ * Requires: POLARSSL_SSL_CACHE_C
+- */
+ #define POLARSSL_SSL_CACHE_C
++ */
+
+ /**
+ * \def POLARSSL_SSL_CLI_C
+@@ -818,8 +818,8 @@
+ * Caller: library/havege.c
+ *
+ * This module is used by the HAVEGE random number generator.
+- */
+ #define POLARSSL_TIMING_C
++ */
+
+ /**
+ * \def POLARSSL_VERSION_C
+@@ -868,8 +868,8 @@
+ *
+ * Module: library/xtea.c
+ * Caller:
+- */
+ #define POLARSSL_XTEA_C
++ */
+ /* \} name */
+
+ #endif /* config.h */
diff --git a/package/libs/polarssl/patches/.svn/text-base/300-openssl_cipher_name_compat.patch.svn-base b/package/libs/polarssl/patches/.svn/text-base/300-openssl_cipher_name_compat.patch.svn-base
new file mode 100644
index 0000000..6ca43c3
--- /dev/null
+++ b/package/libs/polarssl/patches/.svn/text-base/300-openssl_cipher_name_compat.patch.svn-base
@@ -0,0 +1,53 @@
+--- a/library/cipher.c
++++ b/library/cipher.c
+@@ -279,15 +279,21 @@ const cipher_info_t *cipher_info_from_st
+ #if defined(POLARSSL_BLOWFISH_C)
+ if( !strcasecmp( "BLOWFISH-CBC", cipher_name ) )
+ return cipher_info_from_type( POLARSSL_CIPHER_BLOWFISH_CBC );
++ if( !strcasecmp( "BF-CBC", cipher_name ) )
++ return cipher_info_from_type( POLARSSL_CIPHER_BLOWFISH_CBC );
+
+ #if defined(POLARSSL_CIPHER_MODE_CFB)
+ if( !strcasecmp( "BLOWFISH-CFB64", cipher_name ) )
+ return cipher_info_from_type( POLARSSL_CIPHER_BLOWFISH_CFB64 );
++ if( !strcasecmp( "BF-CFB64", cipher_name ) )
++ return cipher_info_from_type( POLARSSL_CIPHER_BLOWFISH_CFB64 );
+ #endif /* defined(POLARSSL_CIPHER_MODE_CFB) */
+
+ #if defined(POLARSSL_CIPHER_MODE_CTR)
+ if( !strcasecmp( "BLOWFISH-CTR", cipher_name ) )
+ return cipher_info_from_type( POLARSSL_CIPHER_BLOWFISH_CTR );
++ if( !strcasecmp( "BF-CTR", cipher_name ) )
++ return cipher_info_from_type( POLARSSL_CIPHER_BLOWFISH_CTR );
+ #endif /* defined(POLARSSL_CIPHER_MODE_CTR) */
+ #endif
+
+--- a/library/cipher_wrap.c
++++ b/library/cipher_wrap.c
+@@ -643,7 +643,7 @@ const cipher_info_t blowfish_cbc_info =
+ POLARSSL_CIPHER_BLOWFISH_CBC,
+ POLARSSL_MODE_CBC,
+ 32,
+- "BLOWFISH-CBC",
++ "BF-CBC",
+ 8,
+ 8,
+ &blowfish_info
+@@ -654,7 +654,7 @@ const cipher_info_t blowfish_cfb64_info
+ POLARSSL_CIPHER_BLOWFISH_CFB64,
+ POLARSSL_MODE_CFB,
+ 32,
+- "BLOWFISH-CFB64",
++ "BF-CFB64",
+ 8,
+ 8,
+ &blowfish_info
+@@ -666,7 +666,7 @@ const cipher_info_t blowfish_ctr_info =
+ POLARSSL_CIPHER_BLOWFISH_CTR,
+ POLARSSL_MODE_CTR,
+ 32,
+- "BLOWFISH-CTR",
++ "BF-CTR",
+ 8,
+ 8,
+ &blowfish_info
diff --git a/package/libs/polarssl/patches/.svn/text-base/310-fix_blowfish_key_len.patch.svn-base b/package/libs/polarssl/patches/.svn/text-base/310-fix_blowfish_key_len.patch.svn-base
new file mode 100644
index 0000000..0b4878e
--- /dev/null
+++ b/package/libs/polarssl/patches/.svn/text-base/310-fix_blowfish_key_len.patch.svn-base
@@ -0,0 +1,29 @@
+--- a/library/cipher_wrap.c
++++ b/library/cipher_wrap.c
+@@ -642,7 +642,7 @@ const cipher_base_t blowfish_info = {
+ const cipher_info_t blowfish_cbc_info = {
+ POLARSSL_CIPHER_BLOWFISH_CBC,
+ POLARSSL_MODE_CBC,
+- 32,
++ 128,
+ "BF-CBC",
+ 8,
+ 8,
+@@ -653,7 +653,7 @@ const cipher_info_t blowfish_cbc_info =
+ const cipher_info_t blowfish_cfb64_info = {
+ POLARSSL_CIPHER_BLOWFISH_CFB64,
+ POLARSSL_MODE_CFB,
+- 32,
++ 128,
+ "BF-CFB64",
+ 8,
+ 8,
+@@ -665,7 +665,7 @@ const cipher_info_t blowfish_cfb64_info
+ const cipher_info_t blowfish_ctr_info = {
+ POLARSSL_CIPHER_BLOWFISH_CTR,
+ POLARSSL_MODE_CTR,
+- 32,
++ 128,
+ "BF-CTR",
+ 8,
+ 8,
diff --git a/package/libs/polarssl/patches/100-disable-testsuites.patch b/package/libs/polarssl/patches/100-disable-testsuites.patch
new file mode 100644
index 0000000..cf9485e
--- /dev/null
+++ b/package/libs/polarssl/patches/100-disable-testsuites.patch
@@ -0,0 +1,21 @@
+--- a/CMakeLists.txt
++++ b/CMakeLists.txt
+@@ -38,7 +38,7 @@ add_subdirectory(library)
+ add_subdirectory(include)
+
+ if(CMAKE_COMPILER_IS_GNUCC)
+- add_subdirectory(tests)
++# add_subdirectory(tests)
+ endif(CMAKE_COMPILER_IS_GNUCC)
+
+ add_subdirectory(programs)
+--- a/programs/CMakeLists.txt
++++ b/programs/CMakeLists.txt
+@@ -3,6 +3,6 @@ add_subdirectory(hash)
+ add_subdirectory(pkey)
+ add_subdirectory(random)
+ add_subdirectory(ssl)
+-add_subdirectory(test)
++#add_subdirectory(test)
+ add_subdirectory(x509)
+ add_subdirectory(util)
diff --git a/package/libs/polarssl/patches/200-reduce_config.patch b/package/libs/polarssl/patches/200-reduce_config.patch
new file mode 100644
index 0000000..c66bb3f
--- /dev/null
+++ b/package/libs/polarssl/patches/200-reduce_config.patch
@@ -0,0 +1,112 @@
+--- a/include/polarssl/config.h
++++ b/include/polarssl/config.h
+@@ -177,8 +177,8 @@
+ * Requires: POLARSSL_BIGNUM_C, POLARSSL_RSA_C
+ *
+ * Enable the RSA prime-number generation code.
+- */
+ #define POLARSSL_GENPRIME
++ */
+
+ /**
+ * \def POLARSSL_FS_IO
+@@ -235,8 +235,8 @@
+ * \def POLARSSL_SELF_TEST
+ *
+ * Enable the checkup functions (*_self_test).
+- */
+ #define POLARSSL_SELF_TEST
++ */
+
+ /**
+ * \def POLARSSL_SSL_ALL_ALERT_MESSAGES
+@@ -425,8 +425,8 @@
+ * TLS_RSA_WITH_CAMELLIA_256_CBC_SHA256
+ * TLS_DHE_RSA_WITH_CAMELLIA_128_CBC_SHA256
+ * TLS_DHE_RSA_WITH_CAMELLIA_256_CBC_SHA256
+- */
+ #define POLARSSL_CAMELLIA_C
++ */
+
+ /**
+ * \def POLARSSL_CERTS_C
+@@ -437,8 +437,8 @@
+ * Caller:
+ *
+ * This module is used for testing (ssl_client/server).
+- */
+ #define POLARSSL_CERTS_C
++ */
+
+ /**
+ * \def POLARSSL_CIPHER_C
+@@ -477,8 +477,8 @@
+ * library/ssl_tls.c
+ *
+ * This module provides debugging functions.
+- */
+ #define POLARSSL_DEBUG_C
++ */
+
+ /**
+ * \def POLARSSL_DES_C
+@@ -560,8 +560,8 @@
+ * enabled as well):
+ * TLS_RSA_WITH_AES_128_GCM_SHA256
+ * TLS_RSA_WITH_AES_256_GCM_SHA384
+- */
+ #define POLARSSL_GCM_C
++ */
+
+ /**
+ * \def POLARSSL_HAVEGE_C
+@@ -574,8 +574,8 @@
+ * Requires: POLARSSL_TIMING_C
+ *
+ * This module enables the HAVEGE random number generator.
+- */
+ #define POLARSSL_HAVEGE_C
++ */
+
+ /**
+ * \def POLARSSL_MD_C
+@@ -649,8 +649,8 @@
+ * Caller: library/aes.c
+ *
+ * This modules adds support for the VIA PadLock on x86.
+- */
+ #define POLARSSL_PADLOCK_C
++ */
+
+ /**
+ * \def POLARSSL_PBKDF2_C
+@@ -763,8 +763,8 @@
+ * Caller:
+ *
+ * Requires: POLARSSL_SSL_CACHE_C
+- */
+ #define POLARSSL_SSL_CACHE_C
++ */
+
+ /**
+ * \def POLARSSL_SSL_CLI_C
+@@ -818,8 +818,8 @@
+ * Caller: library/havege.c
+ *
+ * This module is used by the HAVEGE random number generator.
+- */
+ #define POLARSSL_TIMING_C
++ */
+
+ /**
+ * \def POLARSSL_VERSION_C
+@@ -868,8 +868,8 @@
+ *
+ * Module: library/xtea.c
+ * Caller:
+- */
+ #define POLARSSL_XTEA_C
++ */
+ /* \} name */
+
+ #endif /* config.h */
diff --git a/package/libs/polarssl/patches/300-openssl_cipher_name_compat.patch b/package/libs/polarssl/patches/300-openssl_cipher_name_compat.patch
new file mode 100644
index 0000000..6ca43c3
--- /dev/null
+++ b/package/libs/polarssl/patches/300-openssl_cipher_name_compat.patch
@@ -0,0 +1,53 @@
+--- a/library/cipher.c
++++ b/library/cipher.c
+@@ -279,15 +279,21 @@ const cipher_info_t *cipher_info_from_st
+ #if defined(POLARSSL_BLOWFISH_C)
+ if( !strcasecmp( "BLOWFISH-CBC", cipher_name ) )
+ return cipher_info_from_type( POLARSSL_CIPHER_BLOWFISH_CBC );
++ if( !strcasecmp( "BF-CBC", cipher_name ) )
++ return cipher_info_from_type( POLARSSL_CIPHER_BLOWFISH_CBC );
+
+ #if defined(POLARSSL_CIPHER_MODE_CFB)
+ if( !strcasecmp( "BLOWFISH-CFB64", cipher_name ) )
+ return cipher_info_from_type( POLARSSL_CIPHER_BLOWFISH_CFB64 );
++ if( !strcasecmp( "BF-CFB64", cipher_name ) )
++ return cipher_info_from_type( POLARSSL_CIPHER_BLOWFISH_CFB64 );
+ #endif /* defined(POLARSSL_CIPHER_MODE_CFB) */
+
+ #if defined(POLARSSL_CIPHER_MODE_CTR)
+ if( !strcasecmp( "BLOWFISH-CTR", cipher_name ) )
+ return cipher_info_from_type( POLARSSL_CIPHER_BLOWFISH_CTR );
++ if( !strcasecmp( "BF-CTR", cipher_name ) )
++ return cipher_info_from_type( POLARSSL_CIPHER_BLOWFISH_CTR );
+ #endif /* defined(POLARSSL_CIPHER_MODE_CTR) */
+ #endif
+
+--- a/library/cipher_wrap.c
++++ b/library/cipher_wrap.c
+@@ -643,7 +643,7 @@ const cipher_info_t blowfish_cbc_info =
+ POLARSSL_CIPHER_BLOWFISH_CBC,
+ POLARSSL_MODE_CBC,
+ 32,
+- "BLOWFISH-CBC",
++ "BF-CBC",
+ 8,
+ 8,
+ &blowfish_info
+@@ -654,7 +654,7 @@ const cipher_info_t blowfish_cfb64_info
+ POLARSSL_CIPHER_BLOWFISH_CFB64,
+ POLARSSL_MODE_CFB,
+ 32,
+- "BLOWFISH-CFB64",
++ "BF-CFB64",
+ 8,
+ 8,
+ &blowfish_info
+@@ -666,7 +666,7 @@ const cipher_info_t blowfish_ctr_info =
+ POLARSSL_CIPHER_BLOWFISH_CTR,
+ POLARSSL_MODE_CTR,
+ 32,
+- "BLOWFISH-CTR",
++ "BF-CTR",
+ 8,
+ 8,
+ &blowfish_info
diff --git a/package/libs/polarssl/patches/310-fix_blowfish_key_len.patch b/package/libs/polarssl/patches/310-fix_blowfish_key_len.patch
new file mode 100644
index 0000000..0b4878e
--- /dev/null
+++ b/package/libs/polarssl/patches/310-fix_blowfish_key_len.patch
@@ -0,0 +1,29 @@
+--- a/library/cipher_wrap.c
++++ b/library/cipher_wrap.c
+@@ -642,7 +642,7 @@ const cipher_base_t blowfish_info = {
+ const cipher_info_t blowfish_cbc_info = {
+ POLARSSL_CIPHER_BLOWFISH_CBC,
+ POLARSSL_MODE_CBC,
+- 32,
++ 128,
+ "BF-CBC",
+ 8,
+ 8,
+@@ -653,7 +653,7 @@ const cipher_info_t blowfish_cbc_info =
+ const cipher_info_t blowfish_cfb64_info = {
+ POLARSSL_CIPHER_BLOWFISH_CFB64,
+ POLARSSL_MODE_CFB,
+- 32,
++ 128,
+ "BF-CFB64",
+ 8,
+ 8,
+@@ -665,7 +665,7 @@ const cipher_info_t blowfish_cfb64_info
+ const cipher_info_t blowfish_ctr_info = {
+ POLARSSL_CIPHER_BLOWFISH_CTR,
+ POLARSSL_MODE_CTR,
+- 32,
++ 128,
+ "BF-CTR",
+ 8,
+ 8,