aboutsummaryrefslogtreecommitdiffstats
path: root/package/libs/libusb
diff options
context:
space:
mode:
authorJames <>2013-03-17 12:16:37 +0000
committerJames <>2013-03-17 12:16:37 +0000
commit27b76ab0671089c47506615a796a261e993896a7 (patch)
tree61213d67e7fa87b20356b23798558e2c4212c42f /package/libs/libusb
downloadtrunk-36060-27b76ab0671089c47506615a796a261e993896a7.tar.gz
trunk-36060-27b76ab0671089c47506615a796a261e993896a7.tar.bz2
trunk-36060-27b76ab0671089c47506615a796a261e993896a7.zip
Diffstat (limited to 'package/libs/libusb')
-rw-r--r--package/libs/libusb/.svn/entries65
-rw-r--r--package/libs/libusb/.svn/text-base/Makefile.svn-base49
-rw-r--r--package/libs/libusb/Makefile49
-rw-r--r--package/libs/libusb/patches/.svn/entries62
-rw-r--r--package/libs/libusb/patches/.svn/text-base/001-timerfd.patch.svn-base33
-rw-r--r--package/libs/libusb/patches/001-timerfd.patch33
6 files changed, 291 insertions, 0 deletions
diff --git a/package/libs/libusb/.svn/entries b/package/libs/libusb/.svn/entries
new file mode 100644
index 0000000..283e9fc
--- /dev/null
+++ b/package/libs/libusb/.svn/entries
@@ -0,0 +1,65 @@
+10
+
+dir
+36060
+svn://svn.openwrt.org/openwrt/trunk/package/libs/libusb
+svn://svn.openwrt.org/openwrt
+
+
+
+2013-01-29T10:48:37.032580Z
+35373
+nbd
+
+
+
+
+
+
+
+
+
+
+
+
+
+
+3c298f89-4303-0410-b956-a3cf2f4a3e73
+
+patches
+dir
+
+Makefile
+file
+
+
+
+
+2013-03-17T12:13:08.000000Z
+bf689335e8e1ee33d925bdf5b08069f4
+2013-01-29T10:48:37.032580Z
+35373
+nbd
+
+
+
+
+
+
+
+
+
+
+
+
+
+
+
+
+
+
+
+
+
+1101
+
diff --git a/package/libs/libusb/.svn/text-base/Makefile.svn-base b/package/libs/libusb/.svn/text-base/Makefile.svn-base
new file mode 100644
index 0000000..d1bdb01
--- /dev/null
+++ b/package/libs/libusb/.svn/text-base/Makefile.svn-base
@@ -0,0 +1,49 @@
+#
+# Copyright (C) 2010-2013 OpenWrt.org
+#
+# This is free software, licensed under the GNU General Public License v2.
+# See /LICENSE for more information.
+#
+
+include $(TOPDIR)/rules.mk
+
+PKG_NAME:=libusb
+PKG_VERSION:=1.0.9
+PKG_RELEASE:=1
+
+PKG_SOURCE:=$(PKG_NAME)-$(PKG_VERSION).tar.bz2
+PKG_SOURCE_URL:=@SF/$(PKG_NAME)
+PKG_MD5SUM:=7f5a02375ad960d4e33a6dae7d63cfcb
+
+PKG_INSTALL:=1
+PKG_BUILD_PARALLEL:=1
+
+PKG_MAINTAINER := Felix Fietkau <nbd@openwrt.org>
+
+include $(INCLUDE_DIR)/package.mk
+
+define Package/libusb-1.0
+ SECTION:=libs
+ CATEGORY:=Libraries
+ TITLE:=A library for accessing Linux USB devices
+ DEPENDS:=+libpthread +librt
+ URL:=http://libusb.wiki.sourceforge.net/
+endef
+
+define Package/libusb-1.0/description
+ libusb is a C library that gives applications easy access to USB devices on
+ many different operating systems.
+endef
+
+TARGET_CFLAGS += $(FPIC)
+
+define Build/InstallDev
+ $(CP) $(PKG_INSTALL_DIR)/* $(1)/
+endef
+
+define Package/libusb-1.0/install
+ $(INSTALL_DIR) $(1)/usr/lib
+ $(CP) $(PKG_INSTALL_DIR)/usr/lib/libusb*.so* $(1)/usr/lib/
+endef
+
+$(eval $(call BuildPackage,libusb-1.0))
diff --git a/package/libs/libusb/Makefile b/package/libs/libusb/Makefile
new file mode 100644
index 0000000..d1bdb01
--- /dev/null
+++ b/package/libs/libusb/Makefile
@@ -0,0 +1,49 @@
+#
+# Copyright (C) 2010-2013 OpenWrt.org
+#
+# This is free software, licensed under the GNU General Public License v2.
+# See /LICENSE for more information.
+#
+
+include $(TOPDIR)/rules.mk
+
+PKG_NAME:=libusb
+PKG_VERSION:=1.0.9
+PKG_RELEASE:=1
+
+PKG_SOURCE:=$(PKG_NAME)-$(PKG_VERSION).tar.bz2
+PKG_SOURCE_URL:=@SF/$(PKG_NAME)
+PKG_MD5SUM:=7f5a02375ad960d4e33a6dae7d63cfcb
+
+PKG_INSTALL:=1
+PKG_BUILD_PARALLEL:=1
+
+PKG_MAINTAINER := Felix Fietkau <nbd@openwrt.org>
+
+include $(INCLUDE_DIR)/package.mk
+
+define Package/libusb-1.0
+ SECTION:=libs
+ CATEGORY:=Libraries
+ TITLE:=A library for accessing Linux USB devices
+ DEPENDS:=+libpthread +librt
+ URL:=http://libusb.wiki.sourceforge.net/
+endef
+
+define Package/libusb-1.0/description
+ libusb is a C library that gives applications easy access to USB devices on
+ many different operating systems.
+endef
+
+TARGET_CFLAGS += $(FPIC)
+
+define Build/InstallDev
+ $(CP) $(PKG_INSTALL_DIR)/* $(1)/
+endef
+
+define Package/libusb-1.0/install
+ $(INSTALL_DIR) $(1)/usr/lib
+ $(CP) $(PKG_INSTALL_DIR)/usr/lib/libusb*.so* $(1)/usr/lib/
+endef
+
+$(eval $(call BuildPackage,libusb-1.0))
diff --git a/package/libs/libusb/patches/.svn/entries b/package/libs/libusb/patches/.svn/entries
new file mode 100644
index 0000000..e2856df
--- /dev/null
+++ b/package/libs/libusb/patches/.svn/entries
@@ -0,0 +1,62 @@
+10
+
+dir
+36060
+svn://svn.openwrt.org/openwrt/trunk/package/libs/libusb/patches
+svn://svn.openwrt.org/openwrt
+
+
+
+2013-01-29T10:48:37.032580Z
+35373
+nbd
+
+
+
+
+
+
+
+
+
+
+
+
+
+
+3c298f89-4303-0410-b956-a3cf2f4a3e73
+
+001-timerfd.patch
+file
+
+
+
+
+2013-03-17T12:13:08.000000Z
+dc81a91f10d4e67d54ed457b791d09be
+2013-01-29T10:48:37.032580Z
+35373
+nbd
+
+
+
+
+
+
+
+
+
+
+
+
+
+
+
+
+
+
+
+
+
+1075
+
diff --git a/package/libs/libusb/patches/.svn/text-base/001-timerfd.patch.svn-base b/package/libs/libusb/patches/.svn/text-base/001-timerfd.patch.svn-base
new file mode 100644
index 0000000..de48a7f
--- /dev/null
+++ b/package/libs/libusb/patches/.svn/text-base/001-timerfd.patch.svn-base
@@ -0,0 +1,33 @@
+commit cadb77d99e314e42c3eb02d016e9d90136ec6959
+Author: Alexander Gordeev <lasaine@lvk.cs.msu.su>
+Date: Thu Jan 27 06:39:16 2011 +0300
+
+ fix timerfd initialization
+
+ sys/timerfd.h defines TFD_NONBLOCK as 0x800 but in kernel TFD_NONBLOCK
+ is an alias for O_NONBLOCK which is defined in arch-specific fcntl.h.
+ While it's still 0x800 for most of archs but for mips it's 0x80. So
+ timerfd_create(..., TFD_NONBLOCK) returns -EINVAL because of that. Fix
+ this by using O_NONBLOCK instead.
+
+ Signed-off-by: Alexander Gordeev <lasaine@lvk.cs.msu.su>
+
+--- a/libusb/io.c
++++ b/libusb/io.c
+@@ -20,6 +20,7 @@
+
+ #include <config.h>
+ #include <errno.h>
++#include <fcntl.h>
+ #include <signal.h>
+ #include <stdint.h>
+ #include <stdlib.h>
+@@ -1072,7 +1073,7 @@ int usbi_io_init(struct libusb_context *
+
+ #ifdef USBI_TIMERFD_AVAILABLE
+ ctx->timerfd = timerfd_create(usbi_backend->get_timerfd_clockid(),
+- TFD_NONBLOCK);
++ O_NONBLOCK);
+ if (ctx->timerfd >= 0) {
+ usbi_dbg("using timerfd for timeouts");
+ r = usbi_add_pollfd(ctx, ctx->timerfd, POLLIN);
diff --git a/package/libs/libusb/patches/001-timerfd.patch b/package/libs/libusb/patches/001-timerfd.patch
new file mode 100644
index 0000000..de48a7f
--- /dev/null
+++ b/package/libs/libusb/patches/001-timerfd.patch
@@ -0,0 +1,33 @@
+commit cadb77d99e314e42c3eb02d016e9d90136ec6959
+Author: Alexander Gordeev <lasaine@lvk.cs.msu.su>
+Date: Thu Jan 27 06:39:16 2011 +0300
+
+ fix timerfd initialization
+
+ sys/timerfd.h defines TFD_NONBLOCK as 0x800 but in kernel TFD_NONBLOCK
+ is an alias for O_NONBLOCK which is defined in arch-specific fcntl.h.
+ While it's still 0x800 for most of archs but for mips it's 0x80. So
+ timerfd_create(..., TFD_NONBLOCK) returns -EINVAL because of that. Fix
+ this by using O_NONBLOCK instead.
+
+ Signed-off-by: Alexander Gordeev <lasaine@lvk.cs.msu.su>
+
+--- a/libusb/io.c
++++ b/libusb/io.c
+@@ -20,6 +20,7 @@
+
+ #include <config.h>
+ #include <errno.h>
++#include <fcntl.h>
+ #include <signal.h>
+ #include <stdint.h>
+ #include <stdlib.h>
+@@ -1072,7 +1073,7 @@ int usbi_io_init(struct libusb_context *
+
+ #ifdef USBI_TIMERFD_AVAILABLE
+ ctx->timerfd = timerfd_create(usbi_backend->get_timerfd_clockid(),
+- TFD_NONBLOCK);
++ O_NONBLOCK);
+ if (ctx->timerfd >= 0) {
+ usbi_dbg("using timerfd for timeouts");
+ r = usbi_add_pollfd(ctx, ctx->timerfd, POLLIN);