aboutsummaryrefslogtreecommitdiffstats
path: root/package/libs/libusb-compat
diff options
context:
space:
mode:
authorJames <>2013-03-17 12:16:37 +0000
committerJames <>2013-03-17 12:16:37 +0000
commit27b76ab0671089c47506615a796a261e993896a7 (patch)
tree61213d67e7fa87b20356b23798558e2c4212c42f /package/libs/libusb-compat
downloadtrunk-36060-master.tar.gz
trunk-36060-master.tar.bz2
trunk-36060-master.zip
Diffstat (limited to 'package/libs/libusb-compat')
-rw-r--r--package/libs/libusb-compat/.svn/entries62
-rw-r--r--package/libs/libusb-compat/.svn/text-base/Makefile.svn-base49
-rw-r--r--package/libs/libusb-compat/Makefile49
3 files changed, 160 insertions, 0 deletions
diff --git a/package/libs/libusb-compat/.svn/entries b/package/libs/libusb-compat/.svn/entries
new file mode 100644
index 0000000..507be3b
--- /dev/null
+++ b/package/libs/libusb-compat/.svn/entries
@@ -0,0 +1,62 @@
+10
+
+dir
+36060
+svn://svn.openwrt.org/openwrt/trunk/package/libs/libusb-compat
+svn://svn.openwrt.org/openwrt
+
+
+
+2013-01-29T16:12:00.814933Z
+35387
+nbd
+
+
+
+
+
+
+
+
+
+
+
+
+
+
+3c298f89-4303-0410-b956-a3cf2f4a3e73
+
+Makefile
+file
+
+
+
+
+2013-03-17T12:13:07.000000Z
+b5b52a9c660bd7cdd53f65e72e05a227
+2013-01-29T16:12:00.814933Z
+35387
+nbd
+
+
+
+
+
+
+
+
+
+
+
+
+
+
+
+
+
+
+
+
+
+1102
+
diff --git a/package/libs/libusb-compat/.svn/text-base/Makefile.svn-base b/package/libs/libusb-compat/.svn/text-base/Makefile.svn-base
new file mode 100644
index 0000000..e80f80b
--- /dev/null
+++ b/package/libs/libusb-compat/.svn/text-base/Makefile.svn-base
@@ -0,0 +1,49 @@
+#
+# Copyright (C) 2010-2013 OpenWrt.org
+#
+# This is free software, licensed under the GNU General Public License v2.
+# See /LICENSE for more information.
+#
+
+include $(TOPDIR)/rules.mk
+
+PKG_NAME:=libusb-compat
+PKG_VERSION:=0.1.4
+PKG_RELEASE:=1
+
+PKG_SOURCE:=$(PKG_NAME)-$(PKG_VERSION).tar.bz2
+PKG_SOURCE_URL:=@SF/libusb
+PKG_MD5SUM:=2ca521fffadd0c28fdf174e6ec73865b
+
+PKG_INSTALL:=1
+PKG_BUILD_PARALLEL:=1
+
+PKG_MAINTAINER := Felix Fietkau <nbd@openwrt.org>
+
+include $(INCLUDE_DIR)/package.mk
+
+define Package/libusb-compat
+ SECTION:=libs
+ CATEGORY:=Libraries
+ TITLE:=libusb-0.1 compatibility library
+ DEPENDS:=+libusb-1.0
+ URL:=http://libusb.wiki.sourceforge.net/
+endef
+
+define Package/libusb-compat/description
+ libusb is a C library that gives applications easy access to USB devices on
+ many different operating systems.
+endef
+
+TARGET_CFLAGS += $(FPIC)
+
+define Build/InstallDev
+ $(CP) $(PKG_INSTALL_DIR)/* $(1)/
+endef
+
+define Package/libusb-compat/install
+ $(INSTALL_DIR) $(1)/usr/lib
+ $(CP) $(PKG_INSTALL_DIR)/usr/lib/libusb-0.1.so* $(1)/usr/lib/
+endef
+
+$(eval $(call BuildPackage,libusb-compat))
diff --git a/package/libs/libusb-compat/Makefile b/package/libs/libusb-compat/Makefile
new file mode 100644
index 0000000..e80f80b
--- /dev/null
+++ b/package/libs/libusb-compat/Makefile
@@ -0,0 +1,49 @@
+#
+# Copyright (C) 2010-2013 OpenWrt.org
+#
+# This is free software, licensed under the GNU General Public License v2.
+# See /LICENSE for more information.
+#
+
+include $(TOPDIR)/rules.mk
+
+PKG_NAME:=libusb-compat
+PKG_VERSION:=0.1.4
+PKG_RELEASE:=1
+
+PKG_SOURCE:=$(PKG_NAME)-$(PKG_VERSION).tar.bz2
+PKG_SOURCE_URL:=@SF/libusb
+PKG_MD5SUM:=2ca521fffadd0c28fdf174e6ec73865b
+
+PKG_INSTALL:=1
+PKG_BUILD_PARALLEL:=1
+
+PKG_MAINTAINER := Felix Fietkau <nbd@openwrt.org>
+
+include $(INCLUDE_DIR)/package.mk
+
+define Package/libusb-compat
+ SECTION:=libs
+ CATEGORY:=Libraries
+ TITLE:=libusb-0.1 compatibility library
+ DEPENDS:=+libusb-1.0
+ URL:=http://libusb.wiki.sourceforge.net/
+endef
+
+define Package/libusb-compat/description
+ libusb is a C library that gives applications easy access to USB devices on
+ many different operating systems.
+endef
+
+TARGET_CFLAGS += $(FPIC)
+
+define Build/InstallDev
+ $(CP) $(PKG_INSTALL_DIR)/* $(1)/
+endef
+
+define Package/libusb-compat/install
+ $(INSTALL_DIR) $(1)/usr/lib
+ $(CP) $(PKG_INSTALL_DIR)/usr/lib/libusb-0.1.so* $(1)/usr/lib/
+endef
+
+$(eval $(call BuildPackage,libusb-compat))