aboutsummaryrefslogtreecommitdiffstats
path: root/package/libs/libnfnetlink
diff options
context:
space:
mode:
authorJames <>2013-03-17 12:16:37 +0000
committerJames <>2013-03-17 12:16:37 +0000
commit27b76ab0671089c47506615a796a261e993896a7 (patch)
tree61213d67e7fa87b20356b23798558e2c4212c42f /package/libs/libnfnetlink
downloadtrunk-36060-27b76ab0671089c47506615a796a261e993896a7.tar.gz
trunk-36060-27b76ab0671089c47506615a796a261e993896a7.tar.bz2
trunk-36060-27b76ab0671089c47506615a796a261e993896a7.zip
Diffstat (limited to 'package/libs/libnfnetlink')
-rw-r--r--package/libs/libnfnetlink/.svn/entries62
-rw-r--r--package/libs/libnfnetlink/.svn/text-base/Makefile.svn-base70
-rw-r--r--package/libs/libnfnetlink/Makefile70
3 files changed, 202 insertions, 0 deletions
diff --git a/package/libs/libnfnetlink/.svn/entries b/package/libs/libnfnetlink/.svn/entries
new file mode 100644
index 0000000..6ea4b36
--- /dev/null
+++ b/package/libs/libnfnetlink/.svn/entries
@@ -0,0 +1,62 @@
+10
+
+dir
+36060
+svn://svn.openwrt.org/openwrt/trunk/package/libs/libnfnetlink
+svn://svn.openwrt.org/openwrt
+
+
+
+2013-01-13T19:49:06.463965Z
+35142
+jow
+
+
+
+
+
+
+
+
+
+
+
+
+
+
+3c298f89-4303-0410-b956-a3cf2f4a3e73
+
+Makefile
+file
+
+
+
+
+2013-03-17T12:13:08.000000Z
+155fe06c3e2d3f916f3788cc4c763d18
+2013-01-13T19:49:06.463965Z
+35142
+jow
+
+
+
+
+
+
+
+
+
+
+
+
+
+
+
+
+
+
+
+
+
+1927
+
diff --git a/package/libs/libnfnetlink/.svn/text-base/Makefile.svn-base b/package/libs/libnfnetlink/.svn/text-base/Makefile.svn-base
new file mode 100644
index 0000000..f9ade14
--- /dev/null
+++ b/package/libs/libnfnetlink/.svn/text-base/Makefile.svn-base
@@ -0,0 +1,70 @@
+#
+# Copyright (C) 2007-2013 OpenWrt.org
+#
+# This is free software, licensed under the GNU General Public License v2.
+# See /LICENSE for more information.
+#
+
+include $(TOPDIR)/rules.mk
+
+PKG_NAME:=libnfnetlink
+PKG_VERSION:=1.0.1
+PKG_RELEASE:=1
+
+PKG_SOURCE:=$(PKG_NAME)-$(PKG_VERSION).tar.bz2
+PKG_SOURCE_URL:= \
+ http://www.netfilter.org/projects/libnfnetlink/files/ \
+ ftp://ftp.netfilter.org/pub/libnfnetlink/ \
+ http://mirrors.evolva.ro/netfilter.org/libnfnetlink/
+PKG_MD5SUM:=98927583d2016a9fb1936fed992e2c5e
+PKG_MAINTAINER:=Jo-Philipp Wich <jow@openwrt.org>
+
+PKG_FIXUP:=autoreconf
+
+PKG_INSTALL:=1
+
+include $(INCLUDE_DIR)/package.mk
+
+define Package/libnfnetlink
+ SECTION:=libs
+ CATEGORY:=Libraries
+ TITLE:=A low-level library for netfilter related kernel/userspace communication
+ URL:=http://netfilter.org/projects/libnfnetlink/
+endef
+
+define Package/libnfnetlink/description
+ libnfnetlink is is the low-level library for netfilter related kernel/userspace communication.
+ It provides a generic messaging infrastructure for in-kernel netfilter subsystems
+ (such as nfnetlink_log, nfnetlink_queue, nfnetlink_conntrack) and their respective users
+ and/or management tools in userspace.
+endef
+
+TARGET_CFLAGS += $(FPIC)
+
+CONFIGURE_ARGS += \
+ --enable-static \
+ --enable-shared
+
+define Build/InstallDev
+ $(INSTALL_DIR) $(1)/usr/include/libnfnetlink
+ $(CP) \
+ $(PKG_INSTALL_DIR)/usr/include/libnfnetlink/{libnfnetlink,linux_nfnetlink,linux_nfnetlink_compat}.h \
+ $(1)/usr/include/libnfnetlink/
+ $(INSTALL_DIR) $(1)/usr/lib
+ $(CP) \
+ $(PKG_INSTALL_DIR)/usr/lib/libnfnetlink.{a,so*} \
+ $(1)/usr/lib/
+ $(INSTALL_DIR) $(1)/usr/lib/pkgconfig
+ $(CP) \
+ $(PKG_INSTALL_DIR)/usr/lib/pkgconfig/libnfnetlink.pc \
+ $(1)/usr/lib/pkgconfig/
+endef
+
+define Package/libnfnetlink/install
+ $(INSTALL_DIR) $(1)/usr/lib
+ $(CP) \
+ $(PKG_INSTALL_DIR)/usr/lib/libnfnetlink.so.* \
+ $(1)/usr/lib/
+endef
+
+$(eval $(call BuildPackage,libnfnetlink))
diff --git a/package/libs/libnfnetlink/Makefile b/package/libs/libnfnetlink/Makefile
new file mode 100644
index 0000000..f9ade14
--- /dev/null
+++ b/package/libs/libnfnetlink/Makefile
@@ -0,0 +1,70 @@
+#
+# Copyright (C) 2007-2013 OpenWrt.org
+#
+# This is free software, licensed under the GNU General Public License v2.
+# See /LICENSE for more information.
+#
+
+include $(TOPDIR)/rules.mk
+
+PKG_NAME:=libnfnetlink
+PKG_VERSION:=1.0.1
+PKG_RELEASE:=1
+
+PKG_SOURCE:=$(PKG_NAME)-$(PKG_VERSION).tar.bz2
+PKG_SOURCE_URL:= \
+ http://www.netfilter.org/projects/libnfnetlink/files/ \
+ ftp://ftp.netfilter.org/pub/libnfnetlink/ \
+ http://mirrors.evolva.ro/netfilter.org/libnfnetlink/
+PKG_MD5SUM:=98927583d2016a9fb1936fed992e2c5e
+PKG_MAINTAINER:=Jo-Philipp Wich <jow@openwrt.org>
+
+PKG_FIXUP:=autoreconf
+
+PKG_INSTALL:=1
+
+include $(INCLUDE_DIR)/package.mk
+
+define Package/libnfnetlink
+ SECTION:=libs
+ CATEGORY:=Libraries
+ TITLE:=A low-level library for netfilter related kernel/userspace communication
+ URL:=http://netfilter.org/projects/libnfnetlink/
+endef
+
+define Package/libnfnetlink/description
+ libnfnetlink is is the low-level library for netfilter related kernel/userspace communication.
+ It provides a generic messaging infrastructure for in-kernel netfilter subsystems
+ (such as nfnetlink_log, nfnetlink_queue, nfnetlink_conntrack) and their respective users
+ and/or management tools in userspace.
+endef
+
+TARGET_CFLAGS += $(FPIC)
+
+CONFIGURE_ARGS += \
+ --enable-static \
+ --enable-shared
+
+define Build/InstallDev
+ $(INSTALL_DIR) $(1)/usr/include/libnfnetlink
+ $(CP) \
+ $(PKG_INSTALL_DIR)/usr/include/libnfnetlink/{libnfnetlink,linux_nfnetlink,linux_nfnetlink_compat}.h \
+ $(1)/usr/include/libnfnetlink/
+ $(INSTALL_DIR) $(1)/usr/lib
+ $(CP) \
+ $(PKG_INSTALL_DIR)/usr/lib/libnfnetlink.{a,so*} \
+ $(1)/usr/lib/
+ $(INSTALL_DIR) $(1)/usr/lib/pkgconfig
+ $(CP) \
+ $(PKG_INSTALL_DIR)/usr/lib/pkgconfig/libnfnetlink.pc \
+ $(1)/usr/lib/pkgconfig/
+endef
+
+define Package/libnfnetlink/install
+ $(INSTALL_DIR) $(1)/usr/lib
+ $(CP) \
+ $(PKG_INSTALL_DIR)/usr/lib/libnfnetlink.so.* \
+ $(1)/usr/lib/
+endef
+
+$(eval $(call BuildPackage,libnfnetlink))