aboutsummaryrefslogtreecommitdiffstats
path: root/target/linux/realview/Makefile
diff options
context:
space:
mode:
Diffstat (limited to 'target/linux/realview/Makefile')
-rw-r--r--target/linux/realview/Makefile29
1 files changed, 29 insertions, 0 deletions
diff --git a/target/linux/realview/Makefile b/target/linux/realview/Makefile
new file mode 100644
index 0000000..e7a1220
--- /dev/null
+++ b/target/linux/realview/Makefile
@@ -0,0 +1,29 @@
+#
+# Copyright (C) 2010-2011 OpenWrt.org
+#
+# This is free software, licensed under the GNU General Public License v2.
+# See /LICENSE for more information.
+#
+include $(TOPDIR)/rules.mk
+
+ARCH:=arm
+BOARD:=realview
+BOARDNAME:=ARM Ltd. Realview board (qemu)
+FEATURES:=ext4 fpu ramdisk
+CPU_TYPE:=mpcore
+CPU_SUBTYPE:=vfp
+MAINTAINER:=Florian Fainelli <florian@openwrt.org>
+
+KERNEL_PATCHVER:=3.18
+
+DEVICE_TYPE:=developerboard
+
+include $(INCLUDE_DIR)/target.mk
+
+define Target/Description
+ Build images for ARM Ltd. Realview boards to be run with qemu
+endef
+
+KERNELNAME:=zImage
+
+$(eval $(call BuildTarget))