aboutsummaryrefslogtreecommitdiffstats
path: root/target/linux/ramips/rt305x/profiles/tenda.mk
diff options
context:
space:
mode:
Diffstat (limited to 'target/linux/ramips/rt305x/profiles/tenda.mk')
-rw-r--r--target/linux/ramips/rt305x/profiles/tenda.mk42
1 files changed, 42 insertions, 0 deletions
diff --git a/target/linux/ramips/rt305x/profiles/tenda.mk b/target/linux/ramips/rt305x/profiles/tenda.mk
new file mode 100644
index 0000000..a3c5d3b
--- /dev/null
+++ b/target/linux/ramips/rt305x/profiles/tenda.mk
@@ -0,0 +1,42 @@
+#
+# Copyright (C) 2012 OpenWrt.org
+#
+# This is free software, licensed under the GNU General Public License v2.
+# See /LICENSE for more information.
+#
+
+define Profile/3G150B
+ NAME:=Tenda 3G150B
+ PACKAGES:=\
+ kmod-usb-core kmod-usb-dwc2 \
+ kmod-ledtrig-usbdev
+endef
+
+define Profile/3G150B/Description
+ Package set for Tenda 3G150B board
+endef
+$(eval $(call Profile,3G150B))
+
+
+define Profile/3G300M
+ NAME:=Tenda 3G300M
+ PACKAGES:=\
+ kmod-usb-core kmod-usb-dwc2 \
+ kmod-ledtrig-usbdev
+endef
+
+define Profile/3G300M/Description
+ Package set for Tenda 3G300M board
+endef
+$(eval $(call Profile,3G300M))
+
+
+define Profile/W306R_V20
+ NAME:=Tenda W306R V2.0
+ PACKAGES:=
+endef
+
+define Profile/W306R_V20/Description
+ Package set for Tenda W306R V2.0 board
+endef
+$(eval $(call Profile,W306R_V20))