aboutsummaryrefslogtreecommitdiffstats
path: root/target/linux/omap/profiles/beagleboard.mk
diff options
context:
space:
mode:
Diffstat (limited to 'target/linux/omap/profiles/beagleboard.mk')
-rw-r--r--target/linux/omap/profiles/beagleboard.mk23
1 files changed, 23 insertions, 0 deletions
diff --git a/target/linux/omap/profiles/beagleboard.mk b/target/linux/omap/profiles/beagleboard.mk
new file mode 100644
index 0000000..3cf51d4
--- /dev/null
+++ b/target/linux/omap/profiles/beagleboard.mk
@@ -0,0 +1,23 @@
+#
+# Copyright (C) 2015 OpenWrt.org
+#
+# This is free software, licensed under the GNU General Public License v2.
+# See /LICENSE for more information.
+#
+
+define Profile/BEAGLEBOARD
+ NAME:=EBV BeagleBoard
+ DEFAULT_PACKAGES += kmod-usb2 kmod-usb2-omap \
+ kmod-usb-net kmod-usb-net-asix \
+ kmod-usb-net-asix-ax88179 kmod-usb-net-hso \
+ kmod-usb-net-kaweth kmod-usb-net-pegasus \
+ kmod-usb-net-mcs7830 kmod-usb-net-smsc95xx \
+ kmod-usb-net-dm9601-ether
+endef
+
+define Profile/BEAGLEBOARD/Description
+ Package set for the BEAGLEBOARD and similar devices.
+ Contains various USB-NET drivers for boards without Ethernet.
+endef
+
+$(eval $(call Profile,BEAGLEBOARD))