aboutsummaryrefslogtreecommitdiffstats
path: root/target/linux/netlogic/xlp
diff options
context:
space:
mode:
Diffstat (limited to 'target/linux/netlogic/xlp')
-rw-r--r--target/linux/netlogic/xlp/config-default7
-rw-r--r--target/linux/netlogic/xlp/target.mk10
2 files changed, 17 insertions, 0 deletions
diff --git a/target/linux/netlogic/xlp/config-default b/target/linux/netlogic/xlp/config-default
new file mode 100644
index 0000000..eee7fb4
--- /dev/null
+++ b/target/linux/netlogic/xlp/config-default
@@ -0,0 +1,7 @@
+CONFIG_CPU_XLP=y
+CONFIG_DT_XLP_EVP=y
+CONFIG_DT_XLP_FVP=y
+CONFIG_DT_XLP_GVP=y
+CONFIG_DT_XLP_SVP=y
+CONFIG_NLM_XLP_BOARD=y
+CONFIG_SYS_HAS_CPU_XLP=y
diff --git a/target/linux/netlogic/xlp/target.mk b/target/linux/netlogic/xlp/target.mk
new file mode 100644
index 0000000..44c4460
--- /dev/null
+++ b/target/linux/netlogic/xlp/target.mk
@@ -0,0 +1,10 @@
+CPU_TYPE:=xlp
+CPU_FLAGS_xlp:=-march=xlp -mabi=64
+BOARDNAME:=xlp
+
+DEFAULT_PACKAGES += kmod-usb-core kmod-usb2 kmod-usb2-pci kmod-usb3 \
+ kmod-usb-net kmod-usb-net-smsc95xx
+
+define Target/Description
+ Build firmware images for Broadcom/Netlogic XLP boards.
+endef