aboutsummaryrefslogtreecommitdiffstats
path: root/target/linux/netlogic/image/Makefile
diff options
context:
space:
mode:
Diffstat (limited to 'target/linux/netlogic/image/Makefile')
-rw-r--r--target/linux/netlogic/image/Makefile26
1 files changed, 26 insertions, 0 deletions
diff --git a/target/linux/netlogic/image/Makefile b/target/linux/netlogic/image/Makefile
new file mode 100644
index 0000000..9541f6a
--- /dev/null
+++ b/target/linux/netlogic/image/Makefile
@@ -0,0 +1,26 @@
+#
+# Copyright (C) 2009-2010 OpenWrt.org
+#
+# This is free software, licensed under the GNU General Public License v2.
+# See /LICENSE for more information.
+#
+include $(TOPDIR)/rules.mk
+include $(INCLUDE_DIR)/image.mk
+
+define Image/BuildKernel
+endef
+
+define Image/Build/squashfs
+ $(call prepare_generic_squashfs,$(KDIR)/root.squashfs)
+endef
+
+define Image/Build/Initramfs
+ cp $(KDIR)/vmlinux-initramfs.elf $(BIN_DIR)/$(IMG_PREFIX)-vmlinux-initramfs.elf
+endef
+
+define Image/Build
+ $(call Image/Build/$(1))
+ dd if=$(KDIR)/root.$(1) of=$(BIN_DIR)/$(IMG_PREFIX)-root.$(1) bs=128k conv=sync
+endef
+
+$(eval $(call BuildImage))