aboutsummaryrefslogtreecommitdiffstats
path: root/target/linux/mcs814x/patches-3.18/006-mcs814x_wdt.patch
diff options
context:
space:
mode:
Diffstat (limited to 'target/linux/mcs814x/patches-3.18/006-mcs814x_wdt.patch')
-rw-r--r--target/linux/mcs814x/patches-3.18/006-mcs814x_wdt.patch25
1 files changed, 25 insertions, 0 deletions
diff --git a/target/linux/mcs814x/patches-3.18/006-mcs814x_wdt.patch b/target/linux/mcs814x/patches-3.18/006-mcs814x_wdt.patch
new file mode 100644
index 0000000..72481f6
--- /dev/null
+++ b/target/linux/mcs814x/patches-3.18/006-mcs814x_wdt.patch
@@ -0,0 +1,25 @@
+--- a/drivers/watchdog/Kconfig
++++ b/drivers/watchdog/Kconfig
+@@ -505,6 +505,12 @@ config MESON_WATCHDOG
+ To compile this driver as a module, choose M here: the
+ module will be called meson_wdt.
+
++config MCS814X_WATCHDOG
++ tristate "Moschip MCS814x watchdog"
++ depends on WATCHDOG_CORE && ARCH_MCS814X
++ help
++ Support for the Moschip MCS814x SoCs on-chip watchdog timer.
++
+ # AVR32 Architecture
+
+ config AT32AP700X_WDT
+--- a/drivers/watchdog/Makefile
++++ b/drivers/watchdog/Makefile
+@@ -63,6 +63,7 @@ obj-$(CONFIG_QCOM_WDT) += qcom-wdt.o
+ obj-$(CONFIG_BCM_KONA_WDT) += bcm_kona_wdt.o
+ obj-$(CONFIG_TEGRA_WATCHDOG) += tegra_wdt.o
+ obj-$(CONFIG_MESON_WATCHDOG) += meson_wdt.o
++obj-$(CONFIG_MCS814X_WATCHDOG) += mcs814x_wdt.o
+
+ # AVR32 Architecture
+ obj-$(CONFIG_AT32AP700X_WDT) += at32ap700x_wdt.o