aboutsummaryrefslogtreecommitdiffstats
path: root/target/linux/malta/Makefile
diff options
context:
space:
mode:
Diffstat (limited to 'target/linux/malta/Makefile')
-rw-r--r--target/linux/malta/Makefile22
1 files changed, 22 insertions, 0 deletions
diff --git a/target/linux/malta/Makefile b/target/linux/malta/Makefile
new file mode 100644
index 0000000..8392738
--- /dev/null
+++ b/target/linux/malta/Makefile
@@ -0,0 +1,22 @@
+#
+# Copyright (C) 2010-2011 OpenWrt.org
+#
+# This is free software, licensed under the GNU General Public License v2.
+# See /LICENSE for more information.
+#
+include $(TOPDIR)/rules.mk
+
+BOARD:=malta
+BOARDNAME:=MIPS Malta CoreLV board (qemu)
+CPU_TYPE:=24kc
+SUBTARGETS:=le be #le64 be64
+INITRAMFS_EXTRA_FILES:=
+MAINTAINER:=Florian Fainelli <florian@openwrt.org>
+
+KERNEL_PATCHVER:=3.18
+
+include $(INCLUDE_DIR)/target.mk
+
+DEFAULT_PACKAGES += wpad-mini kmod-mac80211-hwsim kmod-pcnet32
+
+$(eval $(call BuildTarget))