aboutsummaryrefslogtreecommitdiffstats
path: root/target/linux/kirkwood/patches-3.18/150-pogoplug_e02.patch
diff options
context:
space:
mode:
Diffstat (limited to 'target/linux/kirkwood/patches-3.18/150-pogoplug_e02.patch')
-rw-r--r--target/linux/kirkwood/patches-3.18/150-pogoplug_e02.patch127
1 files changed, 127 insertions, 0 deletions
diff --git a/target/linux/kirkwood/patches-3.18/150-pogoplug_e02.patch b/target/linux/kirkwood/patches-3.18/150-pogoplug_e02.patch
new file mode 100644
index 0000000..561c07f
--- /dev/null
+++ b/target/linux/kirkwood/patches-3.18/150-pogoplug_e02.patch
@@ -0,0 +1,127 @@
+--- a/arch/arm/boot/dts/Makefile
++++ b/arch/arm/boot/dts/Makefile
+@@ -147,6 +147,7 @@ dtb-$(CONFIG_MACH_KIRKWOOD) += kirkwood-
+ kirkwood-openrd-base.dtb \
+ kirkwood-openrd-client.dtb \
+ kirkwood-openrd-ultimate.dtb \
++ kirkwood-pogo_e02.dtb \
+ kirkwood-rd88f6192.dtb \
+ kirkwood-rd88f6281-z0.dtb \
+ kirkwood-rd88f6281-a.dtb \
+--- /dev/null
++++ b/arch/arm/boot/dts/kirkwood-pogo_e02.dts
+@@ -0,0 +1,114 @@
++/dts-v1/;
++
++#include "kirkwood.dtsi"
++#include "kirkwood-6281.dtsi"
++
++/ {
++ model = "Cloud Engines Pogoplug E02";
++ compatible = "cloudengines,pogoe02", "marvell,kirkwood-88f6281", "marvell,kirkwood";
++
++ memory {
++ device_type = "memory";
++ reg = <0x00000000 0x10000000>;
++ };
++
++ chosen {
++ bootargs = "console=ttyS0,115200n8 earlyprintk";
++ };
++
++ ocp@f1000000 {
++ pinctrl: pin-controller@10000 {
++ pmx_usb_power_enable: pmx-usb-power-enable {
++ marvell,pins = "mpp29";
++ marvell,function = "gpio";
++ };
++ pmx_led_green: pmx-led_green {
++ marvell,pins = "mpp48";
++ marvell,function = "gpio";
++ };
++ pmx_led_orange: pmx-led_orange {
++ marvell,pins = "mpp49";
++ marvell,function = "gpio";
++ };
++ };
++ serial@12000 {
++ status = "ok";
++ };
++ };
++ gpio-leds {
++ compatible = "gpio-leds";
++ pinctrl-0 = < &pmx_usb_power_enable &pmx_led_orange
++ &pmx_led_green >;
++ pinctrl-names = "default";
++
++ health {
++ label = "status:green:health";
++ gpios = <&gpio1 16 GPIO_ACTIVE_LOW>;
++ default-state = "keep";
++ };
++ fault {
++ label = "status:orange:fault";
++ gpios = <&gpio1 17 GPIO_ACTIVE_LOW>;
++ };
++ };
++ regulators {
++ compatible = "simple-bus";
++ #address-cells = <1>;
++ #size-cells = <0>;
++ pinctrl-0 = <&pmx_usb_power_enable>;
++ pinctrl-names = "default";
++
++ usb_power: regulator@1 {
++ compatible = "regulator-fixed";
++ reg = <1>;
++ regulator-name = "USB Power";
++ regulator-min-microvolt = <5000000>;
++ regulator-max-microvolt = <5000000>;
++ enable-active-high;
++ regulator-always-on;
++ regulator-boot-on;
++ gpio = <&gpio0 29 GPIO_ACTIVE_HIGH>;
++ };
++ };
++};
++
++&nand {
++ chip-delay = <40>;
++ status = "okay";
++
++ partition@0 {
++ label = "u-boot";
++ reg = <0x0000000 0x100000>;
++ read-only;
++ };
++
++ partition@100000 {
++ label = "uImage";
++ reg = <0x0100000 0x400000>;
++ };
++
++ partition@500000 {
++ label = "pogoplug";
++ reg = <0x0500000 0x2000000>;
++ };
++
++ partition@2500000 {
++ label = "root";
++ reg = <0x02500000 0x5b00000>;
++ };
++};
++
++&mdio {
++ status = "okay";
++
++ ethphy0: ethernet-phy@0 {
++ reg = <0>;
++ };
++};
++
++&eth0 {
++ status = "okay";
++ ethernet0-port@0 {
++ phy-handle = <&ethphy0>;
++ };
++};