aboutsummaryrefslogtreecommitdiffstats
path: root/target/linux/generic/patches-4.3/728-phy-rtl8367b.patch
diff options
context:
space:
mode:
Diffstat (limited to 'target/linux/generic/patches-4.3/728-phy-rtl8367b.patch')
-rw-r--r--target/linux/generic/patches-4.3/728-phy-rtl8367b.patch23
1 files changed, 23 insertions, 0 deletions
diff --git a/target/linux/generic/patches-4.3/728-phy-rtl8367b.patch b/target/linux/generic/patches-4.3/728-phy-rtl8367b.patch
new file mode 100644
index 0000000..881be7d
--- /dev/null
+++ b/target/linux/generic/patches-4.3/728-phy-rtl8367b.patch
@@ -0,0 +1,23 @@
+--- a/drivers/net/phy/Kconfig
++++ b/drivers/net/phy/Kconfig
+@@ -288,6 +288,10 @@ config RTL8367_PHY
+ tristate "Driver for the Realtek RTL8367R/M switches"
+ select SWCONFIG
+
++config RTL8367B_PHY
++ tristate "Driver fot the Realtek RTL8367R-VB switch"
++ select SWCONFIG
++
+ endif # RTL8366_SMI
+
+ endif # PHYLIB
+--- a/drivers/net/phy/Makefile
++++ b/drivers/net/phy/Makefile
+@@ -30,6 +30,7 @@ obj-$(CONFIG_RTL8366_SMI) += rtl8366_smi
+ obj-$(CONFIG_RTL8366S_PHY) += rtl8366s.o
+ obj-$(CONFIG_RTL8366RB_PHY) += rtl8366rb.o
+ obj-$(CONFIG_RTL8367_PHY) += rtl8367.o
++obj-$(CONFIG_RTL8367B_PHY) += rtl8367b.o
+ obj-$(CONFIG_LSI_ET1011C_PHY) += et1011c.o
+ obj-$(CONFIG_FIXED_PHY) += fixed_phy.o
+ obj-$(CONFIG_MDIO_BITBANG) += mdio-bitbang.o