aboutsummaryrefslogtreecommitdiffstats
path: root/target/linux/generic/patches-4.3/500-yaffs-Kbuild-integration.patch
diff options
context:
space:
mode:
Diffstat (limited to 'target/linux/generic/patches-4.3/500-yaffs-Kbuild-integration.patch')
-rw-r--r--target/linux/generic/patches-4.3/500-yaffs-Kbuild-integration.patch18
1 files changed, 18 insertions, 0 deletions
diff --git a/target/linux/generic/patches-4.3/500-yaffs-Kbuild-integration.patch b/target/linux/generic/patches-4.3/500-yaffs-Kbuild-integration.patch
new file mode 100644
index 0000000..ab184e6
--- /dev/null
+++ b/target/linux/generic/patches-4.3/500-yaffs-Kbuild-integration.patch
@@ -0,0 +1,18 @@
+--- a/fs/Kconfig
++++ b/fs/Kconfig
+@@ -30,6 +30,7 @@ source "fs/ocfs2/Kconfig"
+ source "fs/btrfs/Kconfig"
+ source "fs/nilfs2/Kconfig"
+ source "fs/f2fs/Kconfig"
++source "fs/yaffs2/Kconfig"
+
+ config FS_DAX
+ bool "Direct Access (DAX) support"
+--- a/fs/Makefile
++++ b/fs/Makefile
+@@ -125,3 +125,5 @@ obj-y += exofs/ # Multiple modules
+ obj-$(CONFIG_CEPH_FS) += ceph/
+ obj-$(CONFIG_PSTORE) += pstore/
+ obj-$(CONFIG_EFIVAR_FS) += efivarfs/
++obj-$(CONFIG_YAFFS_FS) += yaffs2/
++